Utilizing RIP - question about updates.

  • 0
  • 1
  • Question
  • Updated 5 years ago
  • Answered
Create Date: Dec 7 2012 6:01PM

I have 3 switches in a triangle running EAPS.  Each switch has vlan(s) that are only local to that device. IE;

Switch 1:
Vlan A

Switch 2:
Vlan B,C

Switch 3:
Vlan D,E

Also, there are some VLans that are common between those switches. I currently have those vlans added to the "Lags" between each switch, and I have them added to my EAPS domain.


My question, 

I want Switch 1,3 to know about the network on switch 2 and vise versa.

I ran these commands on Switch 2;
enable ipforwarding
enable rip
configure rip add vlan all

Now my question, how do I get switch2 to send its networks across the LAG without tagging the VLAN on the LAG? Right now, on switch 2, if I tag VLANS B,C on the LAG.. then the other switches route tables will show the networks. If I dont tag B,C then the other switches dont know about the networks. 

I dont want B,C to be added as a VLAN to any other switch, but I want the other switches to know about it. 

Thanks!  

(from Jeremy_Homan)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb

Posted 5 years ago

  • 0
  • 1
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Dec 7 2012 6:04PM

Also; will that cause problems for me if one end of the LAG there is added VLANS tagged, but its not reflected on the other end?


IE;
SW1 (Tag A,F,G,H) <---LAG---> SW2 (Tag B,C,F,G,H)
Thanks,
(from Jeremy_Homan)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Dec 10 2012 2:30PM

So there is L3 connectivity between all 3 switches. I enabled IPforwarding on all vlans on all switches, as well as RIP.

I'm not seeing the vlans local to each switch being propogated via RIP.
(from Jeremy_Homan)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Dec 10 2012 5:15PM

Here is a brief layout of the devices..




(from Jeremy_Homan)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Dec 10 2012 8:33PM

Hello Jhoman

let me see if I can provide some advice to help you out.  In order for any switch to send a router update to any other router there needs to be a subnet that they can all talk to.  So switch 1 (VLAN a&b) switch 2 (VLAN c&d) and switch 3 (VLAN E) if you want them to see one another there needs to be a VLAN across all of them with the same subnet so that they can talk to one another called backbone.  Eacn switch will route their VLANs to the backbone and each switch will talk to one another across the backbone subnet.

Think of it this way.  Each switch is a street with houses in it and are seperate for traffic to go from street to street we need to have another street connection them all to pass that traffic..

Does that help?

P

(from Paul_Russo)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Dec 10 2012 9:31PM

I believe thats what I have. All 3 switches have an IP from the 1337 VLAN. 

I want Networks 201, 202, 301, and 302 to be advertised via RIP. 

(from Jeremy_Homan)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Dec 10 2012 10:59PM

Did you use the command enable rip export direct cost <number like 1>?

P

(from Paul_Russo)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Dec 11 2012 8:16PM

I figured it out. I had no active ports assigned to the VLAN so RIP was not advertising it. Design flaw?

Anyways, I enabled loopback on the VLANs, and BOOM! It worked.

(from Jeremy_Homan)