VLAN Routing - interVLAN works but external Gateway is not accessable from Client

  • 1
  • 1
  • Problem
  • Updated 2 months ago
  • Solved

Hi,

I have some problems with routing. I hope you can help me quickly.

 

Thats my iprouting table

 Ori  Destination        Gateway         Mtr  Flags         VLAN       Duration
#s   Default Route      192.168.100.1   1    UG---S-um--f- Haus       0d:0h:43m:26s
#d   192.168.21.0/24    192.168.21.244  1    U------um--f- Video      0d:2h:42m:48s
#d   192.168.22.0/24    192.168.22.244  1    U------um--f- Control    0d:2h:42m:32s
#d   192.168.23.0/24    192.168.23.244  1    U------um--f- Internet   0d:3h:5m:5s
#d   192.168.100.0/24   192.168.100.244 1    U------um--f- Haus       0d:3h:5m:5s

My vlan table

-----------------------------------------------------------------------------------------------
Name            VID  Protocol Addr       Flags                         Proto  Ports  Virtual
                                                                              Active router
                                                                              /Total
-----------------------------------------------------------------------------------------------
Control         42   192.168.22.244 /24  ------------T-----P---------  ANY    1 /8   VR-Default
control_eaps1   3333 --------------------------------------C---------  ANY    1 /2   VR-Default
Default         1    ------------------------------------------------  ANY    0 /0   VR-Default
Haus            44   192.168.100.244/24  -f----------------P---------  ANY    2 /3   VR-Default
Internet        43   192.168.23.244 /24  -f----------T-----P---------  ANY    3 /7   VR-Default
Mgmt            4095 192.168.1.10   /24  ----------------------------  ANY    0 /1   VR-Mgmt
Video           41   192.168.21.244 /24  ------------T-----P---------  ANY    1 /14  VR-Default
-----------------------------------------------------------------------------------------------
 

My PC is in the VLAN Internet with following settings

 IP: 192.168.23.11/24

GW: 192.168.23.244

DNS 192.168.100.1

In the network Haus works all fine. Here is Gateway connected. The VLAN inter Routing is aktivates for vlan internet and Haus. Ping from internet vlan to haus vlan works fine. But i can ́t reach  the gateway 192.168.100.1. I make a default gateway entry in the iproute Table.

 When I ping a adress in the net like 8.8.8.8 from the switch it works.

What make I wrong? I will be happy for a fast answer.

 








Photo of Max

Max

  • 130 Points 100 badge 2x thumb

Posted 2 months ago

  • 1
  • 1
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 49,972 Points 20k badge 2x thumb
Looks like you miss the return route on 192.168.100.1.

Not sure what device that is but you need this route in it....
192.168.23.0/24 via 192.168.100.244
Photo of Max

Max

  • 130 Points 100 badge 2x thumb
Hi,
it is a simple RedLion UMTS Router for testing. When plug in the vlan44 and set 192.168.100.10/24 gw 1 all works. But when i use the Switch as Gateway, i can ́t ping adresses in the internet. I think a entry in routing table on switch is missing.

Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 49,972 Points 20k badge 2x thumb
If you ping from the X440 then the switch uses 192.168.100.244 as the source address for the ping = as the router knows the subnet (directly connected) he is able to return the echo reply.

You'd try it with the below commands = set the source IP for the ping

should work = ping with source from VLAN#44
#ping 8.8.8.8 from 192.168.100.244

will not work = ping with source from VLAN#43
#ping 8.8.8.8 from 192.168.23.244

Photo of Max

Max

  • 130 Points 100 badge 2x thumb
Oh sorry i write the false VLAN ID in the last post. But you are right. Ping from 100 works and from 23 not.
Photo of Max

Max

  • 130 Points 100 badge 2x thumb
I can make static routes in my ISP Router. I can create a route from a network to gateway. Also i must make a entry from 192.168.23.0 to GW 192.168.23.244 ?
Photo of Ronald Dvorak

Ronald Dvorak, Embassador

  • 49,972 Points 20k badge 2x thumb
sorry for non-German speakers....

du musst nur routen anlegen fuer netze die ins internet wollen UND hinter dem switch sind = alle ausser vlan#44

die oberfleaeche sieht vermutlich so aehnlich aus....


d.h. das netz plus mask und dann ueber welchen next hop = bei dir dann fuer alle die IP 192.168.100.244 (=switch IP interface im vlan#44)

Photo of Max

Max

  • 130 Points 100 badge 2x thumb
Wow, cool it works. Big thanks to you!!! I think allways in one direction, but you has right. the other gateway needs also the route!

Have a nice weekend!!!