vlan routing on X440

  • 0
  • 1
  • Question
  • Updated 3 years ago
  • Answered
I have followed the article in the GTAC on how to enable inter vlan routing and I am unable to ping the either PC in either vlan.  From PC A on vlan10 I can ping the gateway and the other gateway of vlan20, and from PC B on vlan20 I can ping the gateway and the gateway on vlan10 but I can not ping PC A to PC B or PC B to PC A. 
Also from the switch I can not ping either PC.

What am I missing??


sho vlan 
* X440-24p.35 # sho vlan-----------------------------------------------------------------------------------------------
Name            VID  Protocol Addr       Flags                         Proto  Ports  Virtual
                                                                              Active router
                                                                              /Total
-----------------------------------------------------------------------------------------------
Default         1    --------------------------------T---------------- ANY    0 /22  VR-Default
Mgmt            4095 ------------------------------------------------- ANY    0 /1   VR-Mgmt
v10             10   192.168.11.2   /24  -f--------------------------- ANY    1 /1   VR-Default
v20             20   192.168.10.2   /24  -f--------------------------- ANY    1 /1   VR-Default
-----------------------------------------------------------------------------------------------


* X440-24p.36 # sho fdb
Mac                     Vlan       Age  Flags         Port / Virtual Port List
------------------------------------------------------------------------------
00:1c:23:e2:8f:45        v10(0010) 0000 d mi           18
f0:1f:af:56:e5:92        v20(0020) 0000 d mi           10


config
configure vlan default delete ports allconfigure vr VR-Default delete ports 1-24
configure vr VR-Default add ports 1-24
configure vlan default delete ports 10, 18
create vlan "v10"
configure vlan v10 tag 10
create vlan "v20"
configure vlan v20 tag 20
configure vlan Default add ports 1-9, 11-17, 19-24 untagged
configure vlan v10 add ports 18 untagged
configure vlan v20 add ports 10 untagged
configure vlan v10 ipaddress 192.168.11.2 255.255.255.0
enable ipforwarding vlan v10
configure vlan v20 ipaddress 192.168.10.2 255.255.255.0
enable ipforwarding vlan v20


xos 15.7.1.4
Photo of Kurt Hansen

Kurt Hansen

  • 210 Points 100 badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of JS

JS, Employee

  • 630 Points 500 badge 2x thumb
Maybe disable the firewall feature on PC A and PC B ?
Photo of Lane, Mike

Lane, Mike, Employee

  • 904 Points 500 badge 2x thumb
Echoing jsfontana, it almost certainly the default behavior of Windows that is your issue.  Allow ICMP or turn off the firewall and you will be good to go. - Mike
Photo of Kurt Hansen

Kurt Hansen

  • 210 Points 100 badge 2x thumb
Ok, Well I got it working, was an extremely locked down linux laptop I was using on PC B but PC A was definitely off.
Do you have to have an IP on the default VLAN??

Thank you
Photo of Chad Smith

Chad Smith, Alum

  • 5,660 Points 5k badge 2x thumb
Kurt,

No an IP address on the default VLAN is not required.  It would only be required if you wanted to route traffic out of that VLAN or if you wanted to use that VLAN interface for switch management purposes.