vman - QinQ on summit 450

  • 0
  • 2
  • Question
  • Updated 5 years ago
  • Answered
Create Date: Aug 20 2013 1:47PM

Hi,
I try to set up config with vman/QinQ. I'd like move vlans 101,102,103..between summits 450a (xos 15.3) via vman1 with tag 804. I made loop between port 1 and 2 for test purpose on the same switch. Till now i can ping only vman1 interfaces.. what am i doing wrong ?

schema:
http://tnij.org/y7pn

my conf:
summit1:

enable jumbo-frame ports all
configure vman ethertype 0x8100

create vlan "vlan101"
configure vlan vlan101 tag 101
create vman "vman1"
configure vman vman1 tag 804

configure vlan vlan101 add ports 2 untagged
configure vman vman1 add ports 24  tagged
configure vman vman1 add ports 1 untagged

configure vlan vman1 ipaddress 192.168.1.11 255.255.255.0
configure vlan vlan101 ipaddress 192.168.0.11 255.255.255.0

enable dot1p examination inner-tag port 24


summit2

enable jumbo-frame ports all
configure vman ethertype 0x8100

create vlan "vlan101"
configure vlan vlan101 tag 101
create vman "vman1"
configure vman vman1 tag 804

configure vlan vlan101 add ports 2 untagged
configure vman vman1 add ports 24  tagged
configure vman vman1 add ports 1 untagged

configure vlan vman1 ipaddress 192.168.1.12 255.255.255.0
configure vlan vlan101 ipaddress 192.168.0.12 255.255.255.0

enable dot1p examination inner-tag port 24


thanks for help

(from peter_peter)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb

Posted 5 years ago

  • 0
  • 2
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Aug 26 2013 12:39PM

You should try with tagged ports on vlan101, that way it is QinQ (double tags).
I wonder why it didn't work with untagged though. Maybe there is some issue with ARP or FDB, since you are looping ports (same macaddress on both ports).  Or maybe there is some issue with vmans and untagged traffic.

(from Luis_Coelho)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Sep 2 2013 3:23PM

When i attached computer and laptop it works for me, it was some problem with loop on switch.

There is some way to send few untagged vlans  via one vman ?
(from peter_peter)
Photo of EtherNation User

EtherNation User, Employee

  • 20,340 Points 20k badge 2x thumb
Create Date: Sep 7 2013 2:00AM

Peter, you can only send one untagged vlan inside a VMAN, just as you can add a port as untagged to only one vlan.

The switch has no way of recognizing untagged traffic from different vlans because there's nothing in the packets to help determine whether the traffic  belongs to one vlan or the other.

(from Daniel_Flouret)

This conversation is no longer open for comments or replies.