What causes interface discards?

  • 1
  • 1
  • Problem
  • Updated 4 years ago
  • In Progress
I am seeing a high number (100k+/30 sec) of in(put) discards on one of the 10.0G switch interfaces on my S4 going to an N7. I went looking for input errors on the port, but there are none, and the interface is running at about 5% utilization. So, what is a discard, and how do I troubleshoot it? Note: The out(put) discards appear to be zero.
Photo of Chris

Chris

  • 162 Points 100 badge 2x thumb
  • uncertain

Posted 4 years ago

  • 1
  • 1
Photo of Doug Hyde

Doug Hyde, Technical Support Manager

  • 20,192 Points 20k badge 2x thumb
Typically a frame is discarded inbound if the switch determines it does not need to forward that frame. One common issue to look for on an uplink is if you are egressing a vlan from the partner switch that is not configured on the switch that reports the discard traffic inbound. The receiving switch does not need to forward that vlan traffic so it discards the frames. 


Photo of Chris

Chris

  • 162 Points 100 badge 2x thumb
Doug, I checked the port egress on both sides of the link in question with "show port egress". There was one VLAN on either side that was mismatched, but on both sides the VLAN was just on that one port. Regardless, I've tweaked those two VLANs so the lists on both sides of the fibre link match exactly, and the issue is still occurring.
Photo of Doug Hyde

Doug Hyde, Technical Support Manager

  • 20,192 Points 20k badge 2x thumb
Chris,

Can you contact the GTAC so we can open a ticket for tracking? If you want, send me your contact info directly and I will have a ticket opened and assigned for a callback. 

dhyde@extremenetworks.com

-Doug
Photo of Pala, Zdenek

Pala, Zdenek, Employee

  • 8,442 Points 5k badge 2x thumb
What about option that you are receiving tagged frames for non-existing VLAN?


Z.
(Edited)
Photo of Chris

Chris

  • 162 Points 100 badge 2x thumb
GTAC is currently investigating the possibility that there are pause frames on the link.
Photo of Brian Townsend

Brian Townsend, Employee

  • 486 Points 250 badge 2x thumb
Chris,
Good day, I hope you are well.  Have you been able to successfully open a case with the GTAC?  If not, and if this is still a concern, please send me your contact information and I will have an engineer open a case for you.

Best regards,
Brian Townsend
btownsen@extremenetworks.com
Photo of Chris

Chris

  • 162 Points 100 badge 2x thumb
A case is indeed open, and I've got a meeting scheduled with a GTAC engineer this Thursday to review the issue in more detail. The suggestions they've had so far - to terminate any port mirrors on the DFE, for example - didn't help with the issue.
Photo of Brian Townsend

Brian Townsend, Employee

  • 486 Points 250 badge 2x thumb
Chris,

Thank you for your speedy response.  Can you email me the case number?

My email address is btownsen@extremenetworks.com

Thank you
Brian 
Photo of Brian Townsend

Brian Townsend, Employee

  • 486 Points 250 badge 2x thumb
Chris,

Upon our investigation, we discovered that pause frames are being incorrectly counted as discards for the S and N-Series.  

This condition will be resolved in a future version of firmware.

Brian