when connected via console port getting error as System is in trial for 30 day(s) and this will expire in 7 day(s), X460-48t, EXOS

  • 0
  • 1
  • Problem
  • Updated 1 year ago
  • Solved
SW 1 & 2 are showing the following error when using the console port. Can you please advise why this trial licence warning is
appearing and is this potentially service impacting? NOTE: When logging in via SSH this warning is not seen.


SW-01.1 # exit

System is in trial for 30 day(s) and this will expire in 7 day(s)
login:

&

SW-02.1 # exit
04/04/2017 15:10:41.27 <Info:AAA.logout> User ****** logout from serial

System is in trial for 30 day(s) and this will expire in 8 day(s)
Photo of Somyaranjan

Somyaranjan

  • 150 Points 100 badge 2x thumb

Posted 1 year ago

  • 0
  • 1
Photo of Vellachery, Sumeesh

Vellachery, Sumeesh, Employee

  • 3,288 Points 3k badge 2x thumb
Somyaranjan,

Please execute "show license" and check the license type. You would get this warning message, if you are running a trial-license and it is about to expire in another 8 days.
Photo of Vellachery, Sumeesh

Vellachery, Sumeesh, Employee

  • 3,288 Points 3k badge 2x thumb
Somyaranjan,

could you please share the output of "show license"?

In case, if you have applied a permanent license and if you are still receiving this warning message. We could clear the trial license by executing the command "debug epm clear trial-license".

Note:- This would require a reboot of the switch.
Photo of Somyaranjan

Somyaranjan

  • 150 Points 100 badge 2x thumb
SW-01.1 # debug epm show nvram NVRAM Info:
      Current License: 3
      Previous License: 0
      Current Feature pack: 0
      Previous Feature pack: 0
      Trial Expiry Date: 0
      Number of trial license: 0
      Trial Secs: 0
      Checksum: 0
SW-01.2 # sh licenses 
Enabled License Level:
        Core
Enabled Feature Packs:
Photo of Somyaranjan

Somyaranjan

  • 150 Points 100 badge 2x thumb
There are no trail license running on it... When i logged in via console port i am getting this error, But while logged in via SSH no error observed..
Photo of Vellachery, Sumeesh

Vellachery, Sumeesh, Employee

  • 3,288 Points 3k badge 2x thumb
What is the model# of the switch and the EXOS Release running on it?
Photo of OscarK

OscarK, ESE

  • 7,912 Points 5k badge 2x thumb
Could the trial license be enabled previously and cleared without the switch being rebooted ?
A reboot is needed after the trial-license is cleared.
Photo of Somyaranjan

Somyaranjan

  • 150 Points 100 badge 2x thumb
Hi Oscark, No we have not enabled any license before... If so why we are not getting error while logged in via SSH.
Photo of Somyaranjan

Somyaranjan

  • 150 Points 100 badge 2x thumb
SW-01.2 # sh versionSwitch      : 800538-00-02 1333N-41165 Rev 2.0 BootROM: 2.0.1.7    IMG: 15.3.2.11 
PSU-1       : PSSW301201A -02 800519-00-05 1333A-40067
PSU-2       : PSSW301201A -02 800519-00-05 1332A-40501

Image   : ExtremeXOS version 15.3.2.11 v1532b11-patch1-2 by release-manager
          on Wed Aug 14 17:43:34 EDT 2013
BootROM : 2.0.1.7
Diagnostics : 5.10
SW-01.3 # sh switch

SysName:          SW-01
SysLocation:      
SysContact:       support@extremenetworks.com, +1 888 257 3000
System MAC:       00:04:96:8B:C3:65
System Type:      X460-48t

SysHealth check:  Enabled (Normal)
Recovery Mode:    All
System Watchdog:  Enabled

Current Time:     Thu Apr  6 06:51:21 2017
Timezone:         [Auto DST Disabled] GMT Offset: 0 minutes, name is UTC.
Boot Time:        Tue Sep 17 18:34:53 2013
Boot Count:       6
Next Reboot:      None scheduled
System UpTime:    1296 days 12 hours 16 minutes 27 seconds 

Current State:    OPERATIONAL             
Image Selected:   secondary               
Image Booted:     secondary               
Primary ver:      12.5.4.5                
Secondary ver:    15.3.2.11   
                  patch1-2

Config Selected:  primary.cfg                                          
Config Booted:    primary.cfg                                          

primary.cfg       Created by ExtremeXOS version 15.3.2.11
                  517495 bytes saved on Wed Dec 14 04:31:21 2016
Photo of Vellachery, Sumeesh

Vellachery, Sumeesh, Employee

  • 3,288 Points 3k badge 2x thumb
Somyaranjan,

Am suspecting a trial license might be installed in the past and the switch wouldn't have been rebooted after clearing the trial license. Would it be possible for you to reboot only 1 switch and check if it is still logging the following message?
Photo of Somyaranjan

Somyaranjan

  • 150 Points 100 badge 2x thumb
Is there any solution apart from this, for reboot i need to check with customer approval and get back to you..