Why Flexviews does not work on Port Element Groups?

  • 0
  • 2
  • Question
  • Updated 3 weeks ago
  • Answered
As the Title says, Flexviews works very well in the Device Groups in Console, but does not work (interface statistics as an example) in port element Groups, it does not respond.
Photo of Ahmed Haroun

Ahmed Haroun

  • 778 Points 500 badge 2x thumb

Posted 4 weeks ago

  • 0
  • 2
Photo of Ahmed Haroun

Ahmed Haroun

  • 778 Points 500 badge 2x thumb
Any idea? any one here knows the reason?
Photo of Bob Maheu

Bob Maheu, Employee

  • 900 Points 500 badge 2x thumb
Hello Ahmed,

One thing to note when creating the port element group is that you should use the FlexView that will be querying the ports to create them.  First open that FlexView, set the poll frequency to 0 and then retreive the results.  From here you can place the ports into the Port Element groups.  This is important as the instance information for the OIDs could be different if another FlexView is used.  If that were to happen then the Port Element groups would return no information.  For example if you used the Interface Statistics FlexView to add ports to a Port Element Group the instancing would be from the MIB-2 Interface.  If you then tried to query the Port Spanning Tree Information FlexView against that port element group it would not work as the instancing for that FlexView is 802.1d Bridge port.
Photo of Ahmed Haroun

Ahmed Haroun

  • 778 Points 500 badge 2x thumb
Yes, Thank you , that was it, i was creating with different FLexviews.

another question if you don't mind, i need to create one flexview that uses two different bases , one of them for example is to show LLDP neighpor plus ifalias, so i can do multiple updates for port display string based on LLDP neighbor.

i am aware that i can use request groups and instance offset somehow, but the documentation is not very clear about it, any idea?