Why not display the RR sometimes when I try to ping an ip address?

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
No RR display, is this feature only support on EXOS platform?


east3.6 # ping vr "VR-Mgmt" 172.16.11.210 with record-route
Ping(ICMP) 172.16.11.210: 4 packets, 8 data bytes, interval 1 second(s).
16 bytes from 172.16.11.210: icmp_seq=0 ttl=123 time=243 ms
RR:
  
  
  
  
  
  
  
  
16 bytes from 172.16.11.210: icmp_seq=1 ttl=123 time=275 ms
    (same route)
16 bytes from 172.16.11.210: icmp_seq=2 ttl=123 time=243 ms
    (same route)
16 bytes from 172.16.11.210: icmp_seq=3 ttl=123 time=243 ms
    (same route)

--- 172.16.11.210 ping statistics ---
4 packets transmitted, 4 packets received, 0% loss
round-trip min/avg/max = 243/251/275 ms
Photo of Li Tao

Li Tao

  • 338 Points 250 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Narayanan, Karthikeyan

Narayanan, Karthikeyan, Employee

  • 912 Points 500 badge 2x thumb
Hi Li,

Can you please check if it works via vr "VR-default"

Regards,
Karthikeyan
Photo of Li Tao

Li Tao

  • 338 Points 250 badge 2x thumb
Hi Karthikeyan,
It works with vr-default, is it means not support in vr-managment?
Photo of Henrique

Henrique, Employee

  • 10,302 Points 10k badge 2x thumb
RR should work through vr "vr-mgmt". Did you try using "traceroute vr vr-mgmt" to check if the switch can trace the path via vr-mgmt?
Photo of Prashanth KG

Prashanth KG, Employee

  • 5,300 Points 5k badge 2x thumb
Hi Li,

As Henrique pointed out, the RR should work via VR-MGMT too.
Did a quick test in lab with routing across three switches via VR-MGMT. RR is displayed without any issues.

X460G2-24x-10G4.11 # ping vr vr-mgmt 20.0.0.2 with record-route
Ping(ICMP) 20.0.0.2: 4 packets, 8 data bytes, interval 1 second(s).
16 bytes from 20.0.0.2: icmp_seq=0 ttl=63 time=0.644 ms
RR: 10.0.0.1
    20.0.0.1
    20.0.0.2
    20.0.0.2
    10.0.0.2
    10.0.0.1

It might be possible that the Routers/firewalls in the routing path via VR-MGMT in your network is blocking the IP option 7(this would be set when ping is initiated with record-route). Hence the RR is not displayed.

Please check and let us know.