WM3400 v5.5.5.0 causing IP conflict

  • 0
  • 1
  • Problem
  • Updated 3 years ago
  • Solved
So I just updated 24 locations using the WM3400 controller, of which 4 had a strange issue arise. I updated the devices and rebooted them, only to lose access to the network causing me to go onsite to find out what the issue was.  When on site I would attempt to access my firewall, lets call it 192.168.1.1, only for the Extreme login page to pop up.  I found this odd as I could also access the controller using its normal assigned IP address, lets call it 192.168.1.15.  Accessing the normal page (.15) I could find nothing odd, so I went ahead and signed into the .1 address.  Apparently the controller created another virtual interface allowing me to configure it.  I did a bit of navigating, found the VLAN 1 interface and had to disable DHCP which promptly fixed the network issue.

I'm curious why this is happening and how I can prevent it from happening again. (I rebooted the device yesterday and it occurred again) It seems strange that a firmware update would cause the devices to enable DHCP and create IP conflicts with my firewall.  Also as a side note, these particular devices  (4 out of the 24) will not allow me to ping them now, even though I created a static route for them. 
Photo of Sean Tutor

Sean Tutor

  • 484 Points 250 badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Colatuno, Joe

Colatuno, Joe, Escalation Support Engineer

  • 1,096 Points 1k badge 2x thumb
Hey Sean,

I assume you are getting the controller GUI login page and not a captive portal page correct? 

What version did you come from? 

Who is handing out DHCP? 

When you disable dhcp are you committing and saving the changes? 
(Edited)
Photo of Brandon Clay

Brandon Clay, Escalation Support Engineer

  • 13,086 Points 10k badge 2x thumb
Hi Sean,

I've got a few questions to get a better idea of what happened.

When you say the Extreme login page, is this the login page for the web interface of the WM? Or is it a captive portal page?

Is the normal IP address (192.168.1.15) on vlan 1, or is it on another vlan? 

What is the DHCP server in this network? Generally, I wouldn't expect it to hand out the firewall's IP as a lease.

Also, are there two controllers clustered, or just a single controller?

-Brandon
Photo of Sean Tutor

Sean Tutor

  • 484 Points 250 badge 2x thumb
Sorry for the late reply, had to go on site to poke and prod.  Quick reply to your questions:

Just the login page for the WM - which was apparently an access point and not the wireless controller

VLAN 1

The DHCP server was the problem, which I'll explain below.

And just a single controller.

So it would appear whoever setup the DHCP on our firewall used the IP address of the gateway and only the gateway on these 4 devices that were having issues.  So that explains why the devices are pulling a conflicting IP.  What is odd is that this issue is just now occurring.   The devices pulling the IP are the access point, which explains a little bit. However now, when I look up the access points IPs (after having changed the DHCP range) they come up as 0.0.0.0 instead of a proper IP like 192.168.1.25. (Using the GUI) 

I suppose this closes the main issue for now.  Now I just need to find out how to change the access points IP from 0.0.0.0.
Photo of Drew C.

Drew C., Community Manager

  • 37,364 Points 20k badge 2x thumb
Hi Sean, I've marked this thread as "Solved."  If that's not the case, let us know how we can help!

-Drew