X350 ports strange behavior

  • 0
  • 1
  • Problem
  • Updated 2 years ago
  • Solved
Hello, all!

Have an X350-48t (with XGM2 card) with strange behavior of ports.
In some time ports LEDs is showing thats port is active - but even cable dont inserted.
Ports which used is stopped to froward traffic.
Disabled management access (only work 10G ports from XGM2 card).

Diagnostic show that all normall (all test is pass).
Have below strange logs:
07/22/2016 20:17:54.12 <Erro:HAL.Port.Error> Port preferred-medium fiber failed for port 4807/22/2016 20:17:54.12 <Erro:HAL.Port.Error> Port preferred-medium fiber failed for port 47
07/22/2016 20:17:54.12 <Erro:HAL.Port.Error> Port preferred-medium fiber failed for port 46
07/22/2016 20:17:54.12 <Erro:HAL.Port.Error> Port preferred-medium fiber failed for port 45
07/22/2016 20:17:53.95 <Erro:HAL.Port.Error> Port auto-negation on failed for port 1:48 medium copper
07/22/2016 20:17:53.93 <Erro:HAL.Port.Error> Port auto-negation on failed for port 1:47 medium copper
07/22/2016 20:17:53.92 <Erro:HAL.Port.Error> Port auto-negation on failed for port 1:46 medium copper
07/22/2016 20:17:53.92 <Erro:HAL.Port.Error> Port auto-negation off failed for port 1:45 medium fiber
07/22/2016 20:17:53.92 <Erro:HAL.Port.Error> Port auto-negation on failed for port 1:45 medium copper

07/22/2016 20:11:36.66 <Erro:Kern.Error> smbus_xfer:0 smbus_wait_rdy error!! rc => -145 addr: 71; read_write 0; command 6; size 107/22/2016 20:11:36.66 <Erro:Kern.Error> smbus_wait_rdy: timeout waiting for SMBUS
07/22/2016 20:11:33.66 <Erro:Kern.Error> smbus_xfer:0 smbus_wait_rdy error!! rc => -145 addr: 47; read_write 1; command 4; size 2
07/22/2016 20:11:33.66 <Erro:Kern.Error> smbus_wait_rdy: timeout waiting for SMBUS
07/22/2016 20:11:30.66 <Erro:Kern.Error> smbus_xfer:0 smbus_wait_rdy error!! rc => -145 addr: 71; read_write 0; command 6; size 1
07/22/2016 20:11:30.66 <Erro:Kern.Error> smbus_wait_rdy: timeout waiting for SMBUS
07/22/2016 20:11:27.66 <Erro:Kern.Error> smbus_xfer:0 smbus_wait_rdy error!! rc => -145 addr: 47; read_write 0; command 2; size 2
07/22/2016 20:11:27.66 <Erro:Kern.Error> smbus_wait_rdy: timeout waiting for SMBUS
07/22/2016 20:11:24.66 <Erro:Kern.Error> smbus_xfer:0 smbus_wait_rdy error!! rc => -145 addr: 71; read_write 0; command 6; size 1
07/22/2016 20:11:24.66 <Erro:Kern.Error> smbus_wait_rdy: timeout waiting for SMBUS

EXOS is 12 version - but Customer have no access to newer version.

Any ideas?
Can it be RMA case? Because X350 is still have valid warranty.

Thank you!
Photo of Alexandr P

Alexandr P, Embassador

  • 12,042 Points 10k badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Necheporenko, Nikolay

Necheporenko, Nikolay, Employee

  • 1,370 Points 1k badge 2x thumb
Hi Alexandr!

Request customer to perform switch diagnostic with the command <run diagnostic extended>.
If some tests fail then open RMA.

BR,
Nikolay
Photo of Alexandr P

Alexandr P, Embassador

  • 12,042 Points 10k badge 2x thumb
Hello, Nikolay!

Diagnostic is all pass.
X350-48t_Statistics.9 # show diagnostics 
Last Test Date: Jul-22-2016   Last Test Version:   12.5.4.5
Summary: Diagnostics Pass

Thank you!
Photo of OscarK

OscarK, ESE

  • 7,702 Points 5k badge 2x thumb
Try removing all SFP's, reboot the switch and put them back in one by one. Maybe one of the SFP's is causing a hang on the i2c bus ?
Photo of Alexandr P

Alexandr P, Embassador

  • 12,042 Points 10k badge 2x thumb
Hello, Oscar!

There is no any SFP's in this switch - all ports don't working (with the exception of 10Gig ports).

Thank you!
Photo of OscarK

OscarK, ESE

  • 7,702 Points 5k badge 2x thumb
i think it is then time to replace/RMA the switch. You can try an upgrade but I doubt it will resurrect the ports.
Photo of Necheporenko, Nikolay

Necheporenko, Nikolay, Employee

  • 1,370 Points 1k badge 2x thumb
"@@@ system detail" from the "show tech detail" output may contain some info about the issue. Looks like the problem is with phy for combo-ports and most of all it is a RMA.
Photo of Alexandr P

Alexandr P, Embassador

  • 12,042 Points 10k badge 2x thumb
Thank you for help!