X450e to 2960S

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
I have a X450e that I am linking a Cisco 2960S too. Both ports are in VLAN 99 (management). They are not able to talk to each other and I am not able to access the Cisco switch by the IP assigned to VLAN 99.

Cisco Config

interface GigabitEthernet1/0/22 
 switchport access vlan 99
 spanning-tree portfast


Extreme Config

configure vlan Mgmt99 add ports 1-2, 39-42 untagged


Thanks for any assistance you can provide.
Photo of Andrew Schulz

Andrew Schulz

  • 432 Points 250 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Patrick Voss

Patrick Voss, Employee

  • 11,474 Points 10k badge 2x thumb
Hi Andrew,

Did you configure a IP address on the Extreme side? Where are you trying to ping from?
Photo of Dorian Perry

Dorian Perry, Employee

  • 2,300 Points 2k badge 2x thumb
Hi Andrew,

Is the Cisco mac address being learned for Vlan 99?
EXOS Command: "show fdb vlan mgmt99"
Photo of Zubair Ahmad

Zubair Ahmad

  • 188 Points 100 badge 2x thumb

Hi Andrew,

Since I only saw 1 command under the "Extreme config" I would go ahead and mention that make sure  you have "create vlan mgmt99 tag 99" command in there too.

that will specify the "vlan ID".  right now the switch looks at the "vlan name" as "mgmt99", tag could be something else...

I ran into it once.


Also make sure you have already taken care of "configure default delete ports all".

(Edited)
Photo of Andrew Schulz

Andrew Schulz

  • 432 Points 250 badge 2x thumb
Sorry, I should have provided the entire config for reference. See below

So a little more detail... I have 5 x450e switches all trunked to a stack of core x450e and they can all talk to each other on VLAN 99.

The Extreme is learning the MAC of the Cisco. 

I'm thinking this might be a default VLAN issue.


Extreme Config

## Module devmgr configuration.
#
configure snmp sysName "Extreme-Core"
configure snmp sysLocation "Kent"
configure snmp sysContact "Andrew Schulz"
configure sys-recovery-level switch reset

#
# Module vlan configuration.
#
configure vlan default delete ports all
configure vr VR-Default delete ports 1-50
configure vr VR-Default add ports 1-50
configure vlan default delete ports 1-50
create vlan "BlackHole"
configure vlan BlackHole tag 666
create vlan "Data"
configure vlan Data tag 3
create vlan "iSCSI"
configure vlan iSCSI tag 6
create vlan "Mgmt99"
configure vlan Mgmt99 tag 99
create vlan "Servers"
configure vlan Servers tag 10
create vlan "Voice"
configure vlan Voice tag 2
configure ports 1 display-string Firewall_1_Int_6
configure ports 2 display-string Firewall_2_Int_6
configure ports 3 display-string Firewall_1_Int_2
configure ports 4 display-string Firewall_2_Int_2
configure ports 5 display-string Firewall_1_Int_1
configure ports 6 display-string Firewall_2_Int_1
configure ports 7 display-string Fiery_Printer
configure ports 8 display-string CopyRoom_Printer
configure ports 32 display-string MailRoom_Printers
configure ports 33 display-string NWOps-Printer
configure ports 34 display-string AcctChks-Printer
configure ports 35 display-string Printer
configure ports 36 display-string Sandy-Printer
configure ports 39 display-string EMC-SAN-Mgmt
configure ports 40 display-string EMC-SAN-Mgmt
configure ports 41 display-string SAN-Switch-1-Mgmt
configure ports 42 display-string SAN-Switch-2-Mgmt
configure ports 43 display-string Voice_CPE
configure ports 44 display-string Trunk_to_A-5
configure ports 45 display-string Trunk_to_A-4
configure ports 46 display-string Trunk_to_A-3
configure ports 47 display-string Trunk_to_A-2
configure ports 48 display-string Trunk_to_A-1
configure vlan BlackHole add ports 49-50 untagged
configure vlan Data add ports 44-48 tagged
configure vlan Data add ports 3-4, 43 untagged
configure vlan Mgmt99 add ports 44-48 tagged
configure vlan Mgmt99 add ports 1-2, 39-42 untagged
configure vlan Servers add ports 5-38 untagged
configure vlan Voice add ports 43-48 tagged
configure vlan Mgmt99 ipaddress 10.10.99.2 255.255.255.0
configure vlan Data ipaddress 10.10.0.2 255.255.255.0
configure vlan Voice ipaddress 10.100.0.2 255.255.255.0

#
# Module fdb configuration.
#

#
# Module rtmgr configuration.
#
configure iproute add default 10.10.99.1

#
# Module mcmgr configuration.
#

#
# Module aaa configuration.
#
configure radius mgmt-access primary server 10.20.1.48 1645 client-ip 10.10.99.2 vr VR-Default
configure radius mgmt-access primary shared-secret encrypted "Om{i:q252"
configure radius mgmt-access secondary server 10.20.1.20 1645 client-ip 10.10.99.2 vr VR-Default
configure radius mgmt-access secondary shared-secret encrypted "Om{i:q252"
configure radius-accounting mgmt-access primary server 10.20.1.48 1646 client-ip 10.10.99.2 vr VR-Default
configure radius-accounting mgmt-access primary shared-secret encrypted "Om{i:q252"
configure radius-accounting mgmt-access secondary server 10.20.1.20 1646 client-ip 10.10.99.2 vr VR-Default
configure radius-accounting mgmt-access secondary shared-secret encrypted "Om{i:q252"
enable radius mgmt-access
enable radius-accounting mgmt-access
create account admin root encrypted "2O2ruq$SZLoivQc0NH3AqGkJ521I1"

#
# Module acl configuration.
#



configure access-list zone SYSTEM application NetLogin application-priority 3
configure access-list zone SYSTEM application HealthCheckLAG application-priority 4
configure access-list zone SYSTEM application IdentityManager application-priority 5
configure access-list zone SYSTEM application VMTracking application-priority 6
configure access-list zone SYSTEM application Snmp application-priority 9
configure access-list zone SYSTEM application Telnet application-priority 10
configure access-list zone SYSTEM application Http application-priority 11
configure access-list zone SYSTEM application Ssh2 application-priority 12

#
# Module bfd configuration.
#

#
# Module cfgmgr configuration.
#

#
# Module dosprotect configuration.
#

#
# Module dot1ag configuration.
#

#
# Module eaps configuration.
#

#
# Module edp configuration.
#

#
# Module elrp configuration.
#
enable elrp-client
configure elrp-client periodic Data ports all interval 1 log-and-trap disable-port duration 15
configure elrp-client periodic Voice ports all interval 1 log-and-trap disable-port duration 15
configure elrp-client disable-port exclude 44
configure elrp-client disable-port exclude 45
configure elrp-client disable-port exclude 46
configure elrp-client disable-port exclude 47
configure elrp-client disable-port exclude 48

#
# Module ems configuration.
#

#
# Module epm configuration.
#

#
# Module erps configuration.
#

#
# Module esrp configuration.
#

#
# Module ethoam configuration.
#

#
# Module etmon configuration.
#

#
# Module exsshd configuration.
#
enable ssh2

#
# Module hal configuration.
#

#
# Module idMgr configuration.
#
create ldap domain "Unknown" default
configure ldap domain "Unknown" base-dn none

#
# Module ipSecurity configuration.
#

#
# Module ipfix configuration.
#

#
# Module lldp configuration.
#
enable lldp ports 1
enable lldp ports 2
enable lldp ports 3
enable lldp ports 4
enable lldp ports 5
enable lldp ports 6
enable lldp ports 7
enable lldp ports 8
enable lldp ports 9
enable lldp ports 10
enable lldp ports 11
enable lldp ports 12
enable lldp ports 13
enable lldp ports 14
enable lldp ports 15
enable lldp ports 16
enable lldp ports 17
enable lldp ports 18
enable lldp ports 19
enable lldp ports 20
enable lldp ports 21
enable lldp ports 22
enable lldp ports 23
enable lldp ports 24
enable lldp ports 25
enable lldp ports 26
enable lldp ports 27
enable lldp ports 28
enable lldp ports 29
enable lldp ports 30
enable lldp ports 31
enable lldp ports 32
enable lldp ports 33
enable lldp ports 34
enable lldp ports 35
enable lldp ports 36
enable lldp ports 37
enable lldp ports 38
enable lldp ports 39
enable lldp ports 40
enable lldp ports 41
enable lldp ports 42
enable lldp ports 43
enable lldp ports 44
enable lldp ports 45
enable lldp ports 46
enable lldp ports 47
enable lldp ports 48
enable lldp ports 49
enable lldp ports 50

#
# Module mrp configuration.
#

#
# Module msdp configuration.
#

#
# Module netLogin configuration.
#

#
# Module netTools configuration.
#

#
# Module poe configuration.
#

#
# Module rip configuration.
#

#
# Module ripng configuration.
#

#
# Module snmpMaster configuration.
#
configure snmpv3 add community NOV_IT name NOV_IT user v1v2c_ro
disable snmpv3 default-group
disable snmpv3 default-user
disable snmp traps

#
# Module stp configuration.
#
configure mstp region 000496348f84
configure stpd s0 delete vlan default ports all
disable stpd s0 auto-bind vlan default
enable stpd s0 auto-bind vlan Default

#
# Module telnetd configuration.
#
disable telnet

#
# Module tftpd configuration.
#

#
# Module thttpd configuration.
#
enable web http

#
# Module vmt configuration.
#

#
# Module vsm configuration.
#




Cisco Config

Current configuration : 5298 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SAN-switch1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$Z0O8$.Ae0S1x/KfD3G7fxtPrx/.
!
username admin privilege 15 password 0 
!
!
aaa new-model
!
!
aaa authentication login userauthen local
aaa authorization network groupauthor local
!
!
!
aaa session-id common
switch 1 provision ws-c2960s-24ts-l
!
!
ip domain-name utilxnt.com
!
!
crypto pki trustpoint TP-self-signed-2299291904
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2299291904
 revocation-check none
 rsakeypair TP-self-signed-2299291904
!
!
crypto pki certificate chain TP-self-signed-2299291904
 certificate self-signed 01
  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32323939 32393139 3034301E 170D3933 30333031 30303032
  33335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 32393932
  39313930 3430819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100B3CF 0F0322A6 1B7D488D CE968F11 9FF2E2C2 3103EB7C A0E9CF73 C490CB17
  1A3B0696 471A6B5D 563DA075 78436AE4 0CA9C13F 4ED96270 4E020651 7F55D317
  8FF7DD2B 5AE68372 BBB6F1C4 3CC24C03 BBB91567 625E67F4 6F5AB8B5 86A12541
  56E011EA 2B938D03 6657EFFE E425B2DC 07FA859B A3960916 F7BA628D 772E3BEF
  310B0203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603
  551D1104 1B301982 1753414E 2D737769 74636831 2E757469 6C786E74 2E636F6D
  301F0603 551D2304 18301680 14036427 0BB7EC38 5E09E12C 1F842960 9C601486
  9B301D06 03551D0E 04160414 0364270B B7EC385E 09E12C1F 8429609C 6014869B
  300D0609 2A864886 F70D0101 04050003 8181000F 87930419 F36739A7 97368A0C
  46976999 36CE757E F3274BE5 00506629 017BB742 E707385E E46F446F B3B7D281
  237BF769 EDE2D3F0 0F65475C 1146274A CF8A368A CF79DDD7 07C21C47 D21DDF30
  C92F566B E191E751 DA799913 004CBD5C CC615F0D 933813FB 25E90671 627D46B9
  37E97C67 9D0377DA DF8524D2 5D882250 425050
  quit
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
ip ssh version 2
!
!
interface FastEthernet0
 no ip address
!
interface GigabitEthernet1/0/1
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/2
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/3
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/4
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/5
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/6
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/7
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/8
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/9
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/10
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/11
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/12
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/13
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/14
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/15
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/16
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/17
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/18
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/19
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/20
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/21
 switchport access vlan 2
 flowcontrol receive desired
 spanning-tree portfast
!
interface GigabitEthernet1/0/22
 switchport access vlan 99
 spanning-tree portfast
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
 ip address 10.20.1.217 255.255.255.0
!
interface Vlan99
 ip address 10.10.99.8 255.255.255.0
!
end
Photo of Zubair Ahmad

Zubair Ahmad

  • 188 Points 100 badge 2x thumb
I think you're missing "enable ipforwarding vlan vlan99" command...
(Edited)
Photo of Patrick Voss

Patrick Voss, Employee

  • 11,474 Points 10k badge 2x thumb
If they are directly attached (vlan to vlan) there should not be any routing. What port is connected to the Cisco. Extreme (Port ?) <--> (Port GE22) Cisco.
Photo of Andrew Schulz

Andrew Schulz

  • 432 Points 250 badge 2x thumb
Silly me, that was too easy. Thanks Zubair. Works like a charm now.
Photo of Andrew Schulz

Andrew Schulz

  • 432 Points 250 badge 2x thumb
Good point Patrick...

Extreme Port 41 <--> Cisco Port 22 
(Edited)
Photo of Patrick Voss

Patrick Voss, Employee

  • 11,474 Points 10k badge 2x thumb
This might be a tagged to untagged situation. I see extreme is configured as untagged in that vlan. how is it configured on the other side?
Photo of Zubair Ahmad

Zubair Ahmad

  • 188 Points 100 badge 2x thumb

Hi Patrick,

other side look like it's "switchport access vlan 99".  so it is also "untagged". 

(Edited)
Photo of Andrew Schulz

Andrew Schulz

  • 432 Points 250 badge 2x thumb
This is odd. I enabled ipforwarding vlan mgmt99 and then disabled it and I can still get to the cisco switch. 
Photo of Zubair Ahmad

Zubair Ahmad

  • 188 Points 100 badge 2x thumb
As Patrick pointed out, theoretically there isn't a need of that command, but I personally have ran into that problem in the lab and that's just a small 'work-around' it.