X460 and X440 stack locking up

  • 0
  • 2
  • Question
  • Updated 2 years ago
  • Answered
I have a customer with 6 x440's and 1 x460 switches in a stack. The 460 is the master in slot 1. The problem is that the switches on occasion lockup. When this happens all the lights go solid and no traffic will pass. The fix is to reboot the stack. When I have looked in the logs there were no signs of what caused the issue. They were running patch 1-33. I have just upgraded to patch 1-9. I am looking for anyone that has the switch stacks lock up. I have made sure it was not a loop. I have checked that is not an Intel NIC multicast issue.
Photo of Tim Senaldi

Tim Senaldi

  • 120 Points 100 badge 2x thumb

Posted 2 years ago

  • 0
  • 2
Photo of David Rahn

David Rahn

  • 762 Points 500 badge 2x thumb

look here to see if this helps

I had same issues...


is fixed in some software, or you set some  setting on the stacking, if it is this issue.

Photo of Tim Senaldi

Tim Senaldi

  • 120 Points 100 badge 2x thumb
This is helpful. It is hard to explain the issue to GTAC after the customer reboots the switches and the logs buffer out. Thanks.
Photo of Brandon Clay

Brandon Clay, Escalation Support Engineer

  • 12,754 Points 10k badge 2x thumb
Hi Tim,

If this happens again, please collect the output of the commands below from both the master and backup (if you can) in the stack before rebooting.

show ports stack-ports rxerrors no-refresh
show ports stack-ports txerrors no-refresh
show stacking stack-ports
show stacking detail
show stacking
show slot
show slot detail
show tech all
show log messages nvram
You should be able to connect to the backup in the stack by telnetting across the backplane with the command 'telnet slot <slot#>'.

This information will help us once you do open up a case with GTAC after rebooting the stack to recover.

Photo of Tripathy, Priya Ranjan

Tripathy, Priya Ranjan, ESE

  • 2,306 Points 2k badge 2x thumb
Hello Tim,
Going with Brandon and David suggestion would like to add few more points here to address if there is any Rx crc errors in the stacking ports when the issue reappears again on customer switch.

For this as this is X460 stack switch hence

To identify the presence of RX errors in the stack-port, use the command : "sh port stack-ports rxerrors "

The article provided by David earlier in the post should help you troubleshoot this! 

CRC errors are seen on Summit x460 stack links and mixed Summit x440 - x460 stack links 

Apart from the outputs requested by Brandon, please also collect the following outputs from the stack nodes and contact GTAC with these outputs. 

debug ems show trace devmgr all    

debug ems show trace nodemgr all

debug ems show trace hal all

Hope this helps! 
Photo of Tim Senaldi

Tim Senaldi

  • 120 Points 100 badge 2x thumb
Thanks. I will add these to the others.