x460 and x440 Not Passing the correct amount of power of PoE+

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
I've been running into a lot of problems with poe devices that are class4 and require PoE+. I have VoIP phones and Wireless AP (802.11AC) that aren't getting the correct amount of power. I have lldp enabled on the port with the AP (enable lldp port 1:3).

Is there any known issues with PoE+ that anyone has seen?

I fixed (at least I believe it has been fixed) our phone issue by telling the phones (cisco) to not use power negotiation. However I can't do it with the APs (Meraki MR34).

Slot-1 is x460
Slot-2 and 3 are both x440

Slot-1 DemoStack.3 # sho version
Slot-1 : 800324-00-12 1339N-44663 Rev 12.0 BootROM: 2.0.1.7 IMG: 15.4.1.3
Slot-2 : 800474-00-10 1343N-42635 Rev 10.0 BootROM: 2.0.1.7 IMG: 15.4.1.3
Slot-3 : 800474-00-11 1350N-40109 Rev 11.0 BootROM: 2.0.2.1 IMG: 15.4.1.3
Slot-4 :
Slot-5 :
Slot-6 :
Slot-7 :
Slot-8 :
SS-B-1 : 800384-00-01 1327N-40559 Rev 1.0

Slot: Slot-1 * Slot-2
------------------------ ------------------------
Current State: MASTER BACKUP (In Sync)

Image Selected: primary primary
Image Booted: primary primary
Primary ver: 15.4.1.3 15.4.1.3
patch1-10 patch1-10
Secondary ver: 15.3.2.11 15.3.2.11

Config Selected: primary.cfg
Config Booted: primary.cfg
Photo of bw447

bw447

  • 906 Points 500 badge 2x thumb

Posted 4 years ago

  • 0
  • 1
Photo of Jason Parker

Jason Parker, Employee

  • 2,918 Points 2k badge 2x thumb
Please open a ticket as we are willing to assist and look into this with you. Please contact the TAC.
Thanks
Jason
Photo of bw447

bw447

  • 906 Points 500 badge 2x thumb
I had a conference call with TAC yesterday. Thanks Jason.
Photo of Stephane Grosjean

Stephane Grosjean

  • 762 Points 500 badge 2x thumb
Hi,
please share the result, that could be interesting for a lot of people.
Photo of bw447

bw447

  • 906 Points 500 badge 2x thumb
Hi Stephane,

I spent about 1 hour with them connected into a machine that had a serial connection. After turning on log debugging and changing every possible setting for 802.3 we weren't able to pass more than 9 Watts. I did some packet captures during the AP boot and it shows the AP asking for 14 Watts (off the top of my head I think that's the correct amount requested). I then see the switch acknowledges it and says that it is passing 14 Watts back to the AP, but when you look at the command:

'sh inline-power info etail port

it still only shows passing 8 Watts. The person at TAC was very kind and I could tell really wanted to fix the problem. He took a bunch of data from the switch and was going to pass it on to engineering. I will update the post when I get more information.
Photo of Balaji

Balaji, Employee

  • 776 Points 500 badge 2x thumb
Hi,

On the extreme switch configure the following command " configure lldp transmit-interval 5"

Changing the transmit-interval to 5 secs and disabling and enabling the lldp will get the meraki work at .3at.
Photo of Mike Walker

Mike Walker

  • 130 Points 100 badge 2x thumb
I will add that I am seeing the same thing with an X440-48P-10G and a Cisco 2702i AP.  Everything comes up fine with .af POE but this restricts antenna usage as well as the secondary port on the AP.  AP gives an error about inadequate power available from the switch. 

Will try Balaji's suggestion next time I'm on site but definitely something that should 'just work' ideally.
Photo of Matt Hill

Matt Hill

  • 70 Points
I'll second Mike's issue.  I'm experiencing the same with a 2702i and an X440-48P.  The suggestion to change the LLDP interval to 5 seconds hasn't resolved the issue.

Has anyone had any luck getting this to work?
Photo of Mike Walker

Mike Walker

  • 130 Points 100 badge 2x thumb
I also implemented many of the suggestions in this thread with no success.  The switch is reporting Class 4 POE on the port but neither the AP nor a Fluke LinkRunner AT 2000 reports appropriate POE actually being delivered (LinkRunner AT reports class 0 and IIRC 9W or so and states that LLDP negotiation of higher power is not possible).

Have been sticking my neck out recommending Extreme over Cisco for switches on projects but basic incompatibilities such as this are making it not worth the risk...
Photo of Matt Hill

Matt Hill

  • 70 Points

The only progress I've made so far is this:

Based on the suggestion of a TAC Engineer, run the following command to enable class 4 power negation via LLDP -

#configure lldp ports [port] advertise vendor-specific dot3 power-via-mdi with-classification

#enable lldp ports [port]

At this point the AP registered to our controller still reports PoE Status as Medium Power (15.4W) under the advanced tab of the specific AP. 

Disabling CDP under the AP settings and rebooting the AP will then display a PoE status of Full Power.  The switch at this point will show higher wattage than it had before (I've had up to 8.4W today, vs mid-6W range earlier), but it's still not what I was expecting to see.  Cisco's Prime Infrastructure monitoring still reports that the AP is drawing low power.

It still doesn't feel like the AP is getting the power it's requesting, but maybe a step in the right direction.

Photo of Ryan Mathews

Ryan Mathews, Alum

  • 8,988 Points 5k badge 2x thumb