XOS versus EOS configuration file

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
Please forgive my ignorance, as I'm new to XOS, having used EOS for years.  I'm trying to grasp the way XOS handles it config file and compare it to Enterasys (EOS) but I can't seem to grasp some concepts.  Hopefully I can explain clearly enough so that someone can "translate" for me.

 Coming from years of experience in the EOS world, when I enter a command in EOS (spanning-tree for example), I can run the command "show config spantree" to see the commands I've entered or "show config all spantree" to see what I've entered plus what the defaults are behind the scenes.  When I do this for XOS, i don't think I'm getting the same results.  Using the same commands with regards to spanning tree in XOS, I run the command "show configuration stp", this seems to mimic EOS and show me only what I've configured.  However, lets say I then remove a command.  The command seems to be removed, essentially setting it back to default because I don't see it when I run "show configuration stp". Yet, it is still there when I run "show configuration detail stp" but in the "reverse state" if that makes since.  Shouldn't it be gone from both, since I set it back to defaults?  For example, I entered the command in XOS "enable stpd s0 ports 1:1".  This created a line in my config.  When I remove it running "disable stpd "s0" ports 1:1", the command no longer appears when I run "show configuration stp" but is somehow still there when I run "show configuration stp detail".  Since I set it back to the default, shouldn't that line be gone from both?  I'm really confused by this.
Photo of Eric Jackson

Eric Jackson

  • 130 Points 100 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of David Coglianese

David Coglianese, Embassador

  • 6,284 Points 5k badge 2x thumb
It is my understanding the show config detail shows the default config items as well. 

Is that what you are seeing?
Photo of Henrique

Henrique, Employee

  • 10,302 Points 10k badge 2x thumb
Hi Eric, 

show configuration stp shows non-default configuration
show configuration stp detail shows non-default + default configurations (all config)
Photo of EtherMAN

EtherMAN, Embassador

  • 6,688 Points 5k badge 2x thumb
Can see where this would be very confusing and really had to get used to.  Here is how we set up all our XOS switches to track who does what where.  Enable cli logging on all of them. This will record every command any one makes via a cli session.  Enable syslog and run a good syslog server.  This gives the ability to go back and do searches for configuration changes and who did what when.  Use netsight to manage your backup configurations.  We upload these every night from all switches... 1600 takes about 15 or 20 minutes total.. keep configs for your comfort level and if you need to restore and replace a bad switch you have the config if you need to go back a few days and see if something got changed you can use your syslog or the archived config to look and see.  
Photo of Stephen Williams

Stephen Williams, Employee

  • 8,950 Points 5k badge 2x thumb
en cli-config-logging

:)
Photo of Eric Jackson

Eric Jackson

  • 130 Points 100 badge 2x thumb
Thanks folks for your help. I was really pleasantly surprised to get a responses back so quickly.

To clarify a little more, I took a new switch out of the box and ran "show config stp" which obviously showed nothing.  I then ran "show config stp detail" which shows me the defaults only.  Then I decided to enter the command "enable stpd s0 port 1".  When I run "show config stp" or "show config stp detail" I now see the command I entered, which is what I would expect.

 The part that is troubling me is than when I run "disable stpd s0 port 1", shouldn't that put me back to the defaults?  If so, why is it when I run a "show config stp detail" do I see the command "disable stpd s0 port 1"? Since I "undid" the previous command (which was never in the original "show config stp detail" to begin with) shouldn't that line be omitted from the output?
Photo of Eric Jackson

Eric Jackson

  • 130 Points 100 badge 2x thumb
Drew I did as you suggested.  I uploaded a new switches "primary.cfg" to a tftp server.  I then entered "enable stpd s0 port 1".  I saved the config.  I then entered "disable stpd s0 port 1".  I then saved the config and uploaded it.  I compared the two configs and the only difference was on the 2nd config it had these extra lines:

configure sys-recovery-level switch resetconfigure vlan default delete ports all
configure vr VR-Default delete ports 1-54
configure vr VR-Default add ports 1-54
configure ports 49 auto off speed 10000 duplex full 
configure ports 50 auto off speed 10000 duplex full 
configure ports 51 auto off speed 10000 duplex full 
configure ports 52 auto off speed 10000 duplex full 
configure ports 53 auto off speed 10000 duplex full 
configure ports 54 auto off speed 10000 duplex full 
configure vlan Default add ports 1-54 untagged  

None of this seems to relate to STP.  However, when I run "show config stp detail" I see the line "disable stp s0 port 1".
Photo of Eric Jackson

Eric Jackson

  • 130 Points 100 badge 2x thumb
Actually, I just realized that wasn't the XML.  I try again and let you know what I find.
Photo of Eric Jackson

Eric Jackson

  • 130 Points 100 badge 2x thumb
Ok, after running this experiment it appears as though quite a few things change behind the scenes.  Specifically this is added:

<edpPortCfg><port>1</port><enable>1</enable></edpPortCfg><edpPortCfg><port>2</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>3</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>4</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>5</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>6</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>7</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>8</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>9</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>10</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>11</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>12</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>13</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>14</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>15</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>16</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>17</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>18</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>19</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>20</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>21</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>22</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>23</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>24</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>25</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>26</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>27</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>28</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>29</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>30</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>31</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>32</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>33</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>34</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>35</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>36</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>37</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>38</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>39</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>40</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>41</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>42</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>43</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>44</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>45</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>46</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>47</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>48</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>49</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>50</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>51</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>52</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>53</port><enable>1</enable></edpPortCfg>
<edpPortCfg><port>54</port><enable>1</enable></edpPortCfg>

So I guess simply "undoing" something doesn't really undo it.  However this could get frustrating if you ever want to go back to a "base" configuration.
Photo of Eric Jackson

Eric Jackson

  • 130 Points 100 badge 2x thumb
So does anyone know how to actually get back to defaults for spanning tree after entering those commands?  As shown, if you enable stp, simply disabling it doesn't undo it.  Here is my dilemma.  I've enabled stp on port 1.  Then, I decided that it would be better to simply use auto-bind.  So to remove the line from my config and use auto-bind, i disabled stp.  However, this seems to override the auto-bind on that port.  Any help?
Photo of Eric Jackson

Eric Jackson

  • 130 Points 100 badge 2x thumb
Contacted GTAC and they were able to help me with this one particular issue.  Basically, GTAC said I needed to remove the port from any vlans that have auto-bind enabled.  Then add the port back.  This worked.  I now no longer have either the "enable stp s0 port 1:1" command or "disable stp s0 port 1:1" in the "show config detail stp"

However, the larger issue of simply "undoing" something will, I"m sure rear its ugly head again as I progress through learning XOS.  Seems to me that if the default state of something is disabled, then you enable it, then decide to disable it again, you should be back at the default state.
Photo of Mike D

Mike D, Alum

  • 3,852 Points 3k badge 2x thumb
Hello Eric,
I dont have a switch in front of me but i'd guess you've got a case for an engineering change request (a bug).  Its unfortunate that that folks trying to learn are the ones who run into these sorts of things but if you're from the EOS side, consider how long its been since you've run 'show config xxx all' - unless looking for some obscure timer or such.  Its when trying to make sense of a new environment these sorts of commands are most helpful - and it's the perfect place for a bug to hide.  

Don't let it ruin the experience. I think you'll find there are some welcome features on the exos side once you break through the initial jolt of a new CLI.

Welcome to the hub.  I can tell you there are several here ramping up on exos. Access to the community should help the transition go more quickly.

Best regards,
Mike