Zero Touch Provisioning problem with EXOS-VM and windows 2012 DHCP server

  • 0
  • 1
  • Problem
  • Updated 2 years ago
  • Solved
Hi all, I'm trying to test the ZTP functionality wit the EXOS-VM and a Windows 2012 DHCP server.
I've defined in my DHCP server the option 125 as described in the GTAC article https://gtacknowledge.extremenetworks...
In my DHCP server I've added the option as follow (my extreme management server IP address is 192.168.10.1)

But when the EXOS-VM boot the first time, it receive correctly an IP address from my DHCP server (192.168.10.180 in my example below), but seems that don't receive the options . Below the screenshot of the wireshark capture where there is a request form the switch to the dhcp server for bootstrap protocol:



and as we can see in the screenshot above, the swithes made DNS query for extremecontrol.demo.com (demo.com is my domain in the lab and I've a DNS entry to resolve this fqdn to my extreme management server IP address...).
These repeat in cyclic manner and the extreme management server is not able to discover the new switch..

What's wrong with this configuration?
Photo of Antonio Opromolla

Antonio Opromolla

  • 2,126 Points 2k badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Antonio Opromolla

Antonio Opromolla

  • 2,126 Points 2k badge 2x thumb
My Extreme Control Management IP is 192.168.10.100 and not as write previously.
Photo of OscarK

OscarK, ESE

  • 7,792 Points 5k badge 2x thumb
This article describes ZTP, if your switch uses 21.1 it will use ZTP+. Together with netsight 7.0 the only thing you need to do is create a DNS entry for extremecontrol and add the IP for netsight.
Photo of Antonio Opromolla

Antonio Opromolla

  • 2,126 Points 2k badge 2x thumb
Hi Oscor, I'm using EXOS-VM version 21.1.1.4 and I've the DNS entry in my DNS server that point to my extremecontrol ip:

but seems that don't query my dns server because as you can see in the wireshark capture above, seems that use a reverse ip address 1.10.168.192 (my dns is instead 192.168.10.1).
My DHCP scope options are configured as follow:
Photo of Antonio Opromolla

Antonio Opromolla

  • 2,126 Points 2k badge 2x thumb
Hi, I've tried to add in my DHC server a new line for DNS server in reverse format as follow:

and now at boot my switch resolve the extremecontrol fqdn to the correct dns server:

and the new switch is correctly discovered by ExtremeControl:


So, now the question is: why I need to put in my DHCP options the DNS server ip address in the reverse order?
Photo of OscarK

OscarK, ESE

  • 7,792 Points 5k badge 2x thumb
That is weird indeed, should not be needed. Can you update the cloud connector and EXOS to see if it is still that way ? In my lab with a real switch I never encountered this.
Photo of Antonio Opromolla

Antonio Opromolla

  • 2,126 Points 2k badge 2x thumb
Hi Oscar, I'm using the latest releases of EXOS and clud connector on the virtual switch...
Photo of OscarK

OscarK, ESE

  • 7,792 Points 5k badge 2x thumb
Can you dump show version and show version imagesĀ output ?
Photo of Antonio Opromolla

Antonio Opromolla

  • 2,126 Points 2k badge 2x thumb
Here it is:
Photo of OscarK

OscarK, ESE

  • 7,792 Points 5k badge 2x thumb
Hello, I am afraid this is not the latest, but it might very well be the latest version for the VM switch at this moment for download on github. I will ask if they will add the 21.1.1.4-patch1-5 vm to github.
Photo of Stephen Williams

Stephen Williams, Employee

  • 8,950 Points 5k badge 2x thumb
21.1.1.4-patch1-5 VM is now added to github.
Photo of Antonio Opromolla

Antonio Opromolla

  • 2,126 Points 2k badge 2x thumb
Thanks Stephen, I'll do a test with this version
Photo of Antonio Opromolla

Antonio Opromolla

  • 2,126 Points 2k badge 2x thumb
Hi Stephen, I've installed the patch to my virtual switch, but the problem is always the same, the DNS is reversed on the switch when obtain the dhp options from the dhcp server..
Photo of OscarK

OscarK, ESE

  • 7,792 Points 5k badge 2x thumb
Hello Antonio, was the cloud-connector upgraded by that patch or are you still using the same cloud connector ?

May I ask where you downloaded the cloud-connector for the EXOS vm switch ?
Photo of Antonio Opromolla

Antonio Opromolla

  • 2,126 Points 2k badge 2x thumb
Hi Oscar, I've download the cloud connector from the following github link:
https://github.com/extremenetworks/EX...
I've reinstalled the cloud connector after the patch upgrade.
Photo of OscarK

OscarK, ESE

  • 7,792 Points 5k badge 2x thumb
Hi Antonio, I see the same in my lab now. I think this is probably an issue in the cloud-connector not being adjusted for use on a VM.
As the VM is just for testing there is not much development done on it, let me check if this can be fixed easily.
(Edited)
Photo of Antonio Opromolla

Antonio Opromolla

  • 2,126 Points 2k badge 2x thumb
Thanks Oscar for your help.
Photo of OscarK

OscarK, ESE

  • 7,792 Points 5k badge 2x thumb
Hello Antonio, this is indeed an issue with the cloud connector. It will be fixed, I dont know when it will be fixed but keep an eye on the cloud connector releases and release notes when a new release comes out.
Photo of Antonio Opromolla

Antonio Opromolla

  • 2,126 Points 2k badge 2x thumb
Hi Oscar, I've upgraded the virtual exos to latest version and now ZTP+ is working.

The only question is: is possible to configure the Management VLAN instead the IP address of the default or other added VLANs?

I've made a test and the settings that I put in teh ZTP+ Device Setting section



are always assigned to the VLAN where I enable the Management and not on the real Mngt VLAN and its port:




The same happens if I leave the Management port in the Default VLAN.





How to assign an IP address to the Mngt port with ZTP+?
(Edited)
Photo of OscarK

OscarK, ESE

  • 7,792 Points 5k badge 2x thumb
If ZTP learns its IP with mgmt it should use that vlan to assign its IP. At this moment I dont know if vr-mgmt is supported with ZTP+.
Photo of Antonio Opromolla

Antonio Opromolla

  • 2,126 Points 2k badge 2x thumb
Hi Oscar, in my tests I've got a DHCP server on Mgmt VLAN but also on the Default VLAN.
For a test I've leaved attached only the Mgmt port and the discover process has found the switch, but also in this case, when I fill the switch IP\subnet, gateway etc.. details for provisioning, it assign this IP addresses to the VLAN assigned to the other ports and not to the Mgmt vlan as obvious must be...