Solved

Extreme Cloud Appliance guest pre-registration

  • 11 July 2019
  • 5 replies
  • 166 views

According to the ECA Manual it is possible to enable the "Pre-Registration-Portal". There are also links for it. Who can access this portal? Where to configure the user / administrator for this Pre-Registration-Portal?
icon

Best answer by Rodney Lacroix 11 July 2019, 18:05

So, I THINK I may have just seen what you're seeing. It appears - from my minor testing - that there is a disconnect when the user is created/added inline on that portal administration page.

Try this:

In AAA, create a local repository user (if one exists that you want to use, delete it/save/recreate).
Go BACK to the portal administration and select to add a login configuration.
Choose the existing user you just created and assign it the admin role.
Try logging in again.

I could not do this when creating the user inline in the portal administration "add login configuration" dialog.

If you see the same results, I'll confirm again and then open a bug. Regardless, let me know either way.
View original

5 replies

Userlevel 3
You set up portal administrators on the Portal -> Administration tab of XCA.

There, you determine what accounts (local, RADIUS or LDAP users) can login to your XCA's https:///administration and/or https:///pre-registration pages.
Hi Rodney, thanks for your answer. I have the default admin, and I have created a prereg user. Both user can login to the XCA itself, but cannot login to the preregistration portal.



Result when trying to login as admin:




Same result when I try to login as "prereg".

Regards
Wendelin
Userlevel 3
So, I THINK I may have just seen what you're seeing. It appears - from my minor testing - that there is a disconnect when the user is created/added inline on that portal administration page.

Try this:

In AAA, create a local repository user (if one exists that you want to use, delete it/save/recreate).
Go BACK to the portal administration and select to add a login configuration.
Choose the existing user you just created and assign it the admin role.
Try logging in again.

I could not do this when creating the user inline in the portal administration "add login configuration" dialog.

If you see the same results, I'll confirm again and then open a bug. Regardless, let me know either way.
Hi Rodney,
I created a new user as you suggested. This user can now login to the pre-register portal and also to the guest administration.
Thanks a lot
Userlevel 3
You're welcome. I'll open a bug on it. Glad you got it working.

Reply