Question

EXOS switch will not properly connect to Cloud IQ

  • 7 January 2021
  • 3 replies
  • 82 views

Userlevel 2

I have created a Cloud IQ Connect account and I am trying to add my EXOS X460-G2 switches.

I have attempted to onboard 3 switches, all are X460G2-48p-10G4 running ExtremeXOS version 30.7.1.1-patch1-54.

One of the switches has on-boarded properly and can fully monitored.

The other 2 switches only partially on-board.  The iqagent connects and the switches register to Cloud IQ but are not fully monitored.  On the manage device page the cloud turns green but the host name never resolves.  On the individual switch page the picture of the switch is greyed out.  The IP address and the MAC address appear but there are no stats.

In the log of the switch itself the following warning continually repeats:

 01/07/2021 10:06:25.68 <Warn:SNMP.Master.AuthFail> Login failed through SNMPv1/v2c - bad community name (127.0.0.1)

I have compared the snmp config between the switch that has successfully connected and the others that have not and other than the randomized community name for the iqagent everything is the same.

I have also compared the “show snmp vr VR-Default” and they match as well.

For the switches that are not connecting fully I had to reboot them to get them to connect to Cloud IQ but the working one discovered on its own.

Is there a way to push them to the cloud from the CLI?

 

Thank you,

Chris


3 replies

Check out the following article  https://extremeportal.force.com/ExtrArticleDetail?an=000079814


Especially apart from the remaining checks mentioned in the above provided article - check these commands to see if you can get some useful information 

debug iqagent show log hive-agent all
debug iqagent show log agent all


 ​​​​Regards,
Subanesh

Userlevel 2

I checked and followed the steps in the article “Add an EXOS Switch to ExtremeCloud IQ (XIQ)”

I have now tried with several switches and except for the one each switch does not fully connect and logs the error “<Warn:SNMP.Master.AuthFail> Login failed through SNMPv1/v2c - bad community name (127.0.0.1)”

I have tried the debug commands and what I see is the switches that don’t fully connect appear to be trying to connect to the Cloud with out success.

Does anyone know when the option to add XMC to XIQ will be available?

Thanks,

Chris

XMC in XIQ is still a work in progress. I will let someone else comment on the timelines for the same. Meanwhile if its possible, you can provide the logs to the problematic switch that you are not able to succesfully onboard to XIQ to see if someone can check out and possibly provide some useful info to get around the same.

Regards,
Subanesh

Reply