Header Only - DO NOT REMOVE - Extreme Networks

404 - Not Found after EMC Upgrade from 7.1.3.25 to 8.0.3.53


Userlevel 1
Hello there,

after EMC upgrading from 7.1.3.25 to 8.0.3.53 i have a web page error
404 - Not found

Checking system database had some errors:

netsightrpt.appid_attribute
error : Partitioning upgrade required. Please dump/reload to fix it or do: ALTER TABLE 'netsightrpt'.'appid_attribute' UPGRADE PARTITIONING
netsightrpt.appid_datapoint
error : Partitioning upgrade required. Please dump/reload to fix it or do: ALTER TABLE 'netsightrpt'.'appid_datapoint' UPGRADE PARTITIONING
netsightrpt.application_usage_default
error : Partitioning upgrade required. Please dump/reload to fix it or do: ALTER TABLE 'netsightrpt'.'application_usage_default' UPGRADE PARTITIONING
netsightrpt.application_usage_hr_default
error : Partitioning upgrade required. Please dump/reload to fix it or do: ALTER TABLE 'netsightrpt'.'application_usage_hr_default' UPGRADE PARTITIONING
netsightrpt.application_usage_rt_default
error : Partitioning upgrade required. Please dump/reload to fix it or do: ALTER TABLE 'netsightrpt'.'application_usage_rt_default' UPGRADE PARTITIONING
08:59:10,838 INFO ProcUtils:212 - netsightrpt.end_system_event
error : Partitioning upgrade required. Please dump/reload to fix it or do: ALTER TABLE 'netsightrpt'.'end_system_event' UPGRADE PARTITIONING
netsightrpt.nsalarmhistory
Error : Failed to read from the .par file
Error : Incorrect information in file: './netsightrpt/nsalarmhistory.frm'
error : Corrupt
netsightrpt.rpt_default_datapoint
Error : Failed to read from the .par file
Error : Incorrect information in file: './netsightrpt/rpt_default_datapoint.frm'
error : Corrupt
netsightrpt.rpt_default_day
error : Partitioning upgrade required. Please dump/reload to fix it or do: ALTER TABLE 'netsightrpt'.'rpt_default_day' UPGRADE PARTITIONING
netsightrpt.rpt_default_hour
error : Partitioning upgrade required. Please dump/reload to fix it or do: ALTER TABLE 'netsightrpt'.'rpt_default_hour' UPGRADE PARTITIONING
netsightrpt.rpt_default_month
error : Partitioning upgrade required. Please dump/reload to fix it or do: ALTER TABLE 'netsightrpt'.'rpt_default_month' UPGRADE PARTITIONING
netsightrpt.rpt_default_raw
error : Partitioning upgrade required. Please dump/reload to fix it or do: ALTER TABLE 'netsightrpt'.'rpt_default_raw' UPGRADE PARTITIONING
netsightrpt.rpt_default_week
error : Partitioning upgrade required. Please dump/reload to fix it or do: ALTER TABLE 'netsightrpt'.'rpt_default_week' UPGRADE PARTITIONING

Repairing tables

Upgrading tables
netsightrpt.nsalarmhistory
Error : Failed to read from the .par file
Error : Incorrect information in file: './netsightrpt/nsalarmhistory.frm'
error : Corrupt
netsightrpt.rpt_default_datapoint
Error : Failed to read from the .par file
Error : Incorrect information in file: './netsightrpt/rpt_default_datapoint.frm'
error : Corrupt
Running : ALTER TABLE 'netsightrpt'.'appid_attribute' UPGRADE PARTITIONING
status : OK
Running : ALTER TABLE 'netsightrpt'.'appid_datapoint' UPGRADE PARTITIONING
status : OK
Running : ALTER TABLE 'netsightrpt'.'application_usage_default' UPGRADE PARTITIONING
status : OK
Running : ALTER TABLE 'netsightrpt'.'application_usage_hr_default' UPGRADE PARTITIONING
status : OK
Running : ALTER TABLE 'netsightrpt'.'application_usage_rt_default' UPGRADE PARTITIONING
status : OK
08:59:10,939 INFO ProcUtils:205 - Running : ALTER TABLE 'netsightrpt'.'end_system_event' UPGRADE PARTITIONING
status : OK
Running : ALTER TABLE 'netsightrpt'.'rpt_default_day' UPGRADE PARTITIONING
status : OK
Running : ALTER TABLE 'netsightrpt'.'rpt_default_hour' UPGRADE PARTITIONING
status : OK
Running : ALTER TABLE 'netsightrpt'.'rpt_default_month' UPGRADE PARTITIONING
status : OK
Running : ALTER TABLE 'netsightrpt'.'rpt_default_raw' UPGRADE PARTITIONING
status : OK
Running : ALTER TABLE 'netsightrpt'.'rpt_default_week' UPGRADE PARTITIONING
status : OK

5 replies

Userlevel 4
Hi Yves,

Before we start to troubleshoot this issue please check below KB for basic requirements.

https://gtacknowledge.extremenetworks.com/articles/How_To/Considerations-for-upgradingExtreme-Manage...

1) Check your DNS configuration.

2) Also check below kb for further details.

https://gtacknowledge.extremenetworks.com/articles/Solution/Common-Issues-Unable-to-connect-to-NetSi...

Thanks,
Suresh.B
Userlevel 1
Hi Suresh

I've checked anything...but I didn't found any matching errors...
I will install netsight new, restore the database and upgrade to v8 again...
maybe that helps.
Userlevel 3
If this is a virtual machine, double check the memory allocated to the VM. We had a customer that upgraded on their own, and ignored the memory requirements. The install completed, but was corrupt, and the web site would not come up even though the VM was running and we could SSH in.

The solution was to allocate more memory and perform a clean install, and restore from backup.

Thanks,

Bill
Userlevel 1
Hi Bill,

I allocated enough memory, CPU and disk. I setup the netsight completely new and restored the database. After this, I tried the upgrade again, but had the same errors.

Thanks, Yves
Userlevel 7
Resolved via GTAC case.

Reply