Header Only - DO NOT REMOVE - Extreme Networks
Solved

Display string from ports on switch is not being displayed in XMC

  • 29 January 2019
  • 6 replies
  • 477 views

Userlevel 2
We have an X440G2 running 22.4.1.4 22.4.1.4-patch1-2 that correctly shows the configured port display string in the "Switch Port" column in XMC. We have another X440G2 running the same version of XOS but the display strings for each port are not showing up in XMC for that switch. We thought we had them configured the same, but clearly something is missing. What setting controls that information being polled from the switch?
icon

Best answer by Stephen Stormont 3 July 2019, 22:07

Now that we are running 22.5.1.7-patch1-7 and MAC authentication, the "Switch Port" column is correctly showing what is configured via "display-string" so it seems like it was just an issue when using identity management.
View original

6 replies

Userlevel 2
Now that we are running 22.5.1.7-patch1-7 and MAC authentication, the "Switch Port" column is correctly showing what is configured via "display-string" so it seems like it was just an issue when using identity management.
Userlevel 2
That was a suggestion that I received (using description string), but I don't understand why display-string works on the one switch using the same settings. We would rather only have to configure one option on each port and be able to query the results in XMC and in Cacti.

Regarding the version, we are trying to stick to the "most stable release" as per https://www.extremenetworks.com/support/compatibility-matrices/sw-release-extremexos-eos/?_ga=2.160210622.28786639.1548692841-1377444939.1542305913
Userlevel 6
i recommend use 22.6 patch1-1 - netlogin runs much better than with 22.4 ...
Userlevel 6
set display string also as description string on the ports and this will works reliable !
Userlevel 2
The same configuration was performed on both switches.

Switch A (172.22.118.2) that shows the correct information in XMC:
configure ports 2:27 display-string Mac-mini
configure ports 1:25 display-string PatsC
configure ports 2:26 display-string RV-Public

Switch B (172.22.34.2) that does not show the correct information in XMC
configure ports 3:17 display-string LoeM
configure ports 1:41 display-string ScoS
configure ports 4:7 display-string SchR

Attached is an image showing this.

Userlevel 6
is it possible that you only set the switch local relevant display-string and NOT the snmp relevant description string on your EXOS device ??

BR

Reply