Header Only - DO NOT REMOVE - Extreme Networks
Question

EMC - Identity management - stops working on one network card


Userlevel 2
Hello,
I have been using IDM in Netsight without using NAC. Since some time Netsight stops records data from one network card.

I have EMC network configured that way:
ifconfig
eth0 Link encap:Ethernet HWaddr 00:50:56:8c:65:56
inet addr:xxx.254.6.55 Bcast:xxx.254.6.63 Mask:255.255.255.192

eth1 Link encap:Ethernet HWaddr 00:50:56:8c:35:5c
inet addr:10.10.3.254 Bcast:10.10.3.255 Mask:255.255.255.0

And I have some switches in first address pool, and some in second one. From some time, dont exactly know from where, IDM works only on first address pool.

As you can see it worked without problem on switches before. There are evet send with success.

x430-48# show xml-notification statistics
Target Name : netsight
Server URL : https://10.10.3.254:8443/axis/services/event
Server Queue Size : 100
Enabled : yes
Connection Status : fail
Events Received : 11852
Connection Failures : 7350
Events Sent Success : 1010
Events Sent Failed : 10842
Events Dropped : 0

I think the issue occurred after EMC upgrade to 8.0.3 not sure tho. Yesterday I have upgrade EMC to 8.0.5 but nothing changed.

Switches with xxx.254.6.x address still working alright, and I see new records on EMC in control/end-system tab.

I done some more tests, tries connection from browser on PC with address 10.10.3.x to https://10.10.3.254:8443/axis/services/event and got no response from site. And tcpdump on netsight shows that:

tcpdump -i eth1 | grep 10.10.3.51
11:37:20.576720 IP 10.10.3.51.49736 > 10.10.3.254.8443: Flags , seq 2031014396, win 65535, options [mss 1460,nop,wscale 3,nop,nop,sackOK], length 0
11:37:20.576741 IP 10.10.3.254.8443 > 10.10.3.51.49736: Flags [R.], seq 0, ack 2031014397, win 0, length 0
11:37:21.084343 IP 10.10.3.51.49736 > 10.10.3.254.8443: Flags , seq 2031014396, win 65535, options [mss 1460,nop,wscale 3,nop,nop,sackOK], length 0
11:37:21.084372 IP 10.10.3.254.8443 > 10.10.3.51.49736: Flags [R.], seq 0, ack 1, win 0, length 0
11:37:21.600418 IP 10.10.3.51.49736 > 10.10.3.254.8443: Flags , seq 2031014396, win 65535, options [mss 1460,nop,wscale 3,nop,nop,sackOK], length 0
11:37:21.600450 IP 10.10.3.254.8443 > 10.10.3.51.49736: Flags [R.], seq 0, ack 1, win 0, length 0

So there are some connections going. Also switches are added to inventory so they are communicating without problem. There is some issue with EMC in my opinion.

Dont know what to check next.
cheers
Michal

0 replies

Be the first to reply!

Reply