Header Only - DO NOT REMOVE - Extreme Networks

EXOS Firmware upgrade problem in NetSight 7.0.5


Some EXOS switches cannot be upgraded in NetSight 7.0.5. When I right click and select Firmware Upgrade on a device, I immediately receive the Error "Selected devices do not support Firmware Upgrade or have never been contacted".

It was the same problem in ver. 7.0.4.

7 replies

Userlevel 6
I think it could be a problem with the EXOS version the switch is using at this moment. I think Netsight can only upgrade when the switch is using a version higher than x.x. Are all switches you cannot upgrade use a low EXOS version ?
Userlevel 7
Please post the switch model, the current software and the software that you try to upgrade to.
I have seen this on two different models (x430-8p and x460-G2-10g), but the on I am working now is an x430-8p running Exos 15.5.3.4. I ma trying to upgrade to Exos ver 16.1.3.6 patch 1-9.
Userlevel 6
Have you tried to "rediscover" those devices? What methods do you use for upgrade/firmware transfer? With rediscover the sysobjectid is checked and than inventory manager can choose what method to use. Regards
Yes, I have rediscoverd the device, but it didn't help.

But You gave me an idea!

I deleted the device and rediscovered it. Then it worked. I could uprade the device

The solution for this device was to delete it and add it again. But I have other similar switches where it doesn't help, so this is ver strange.
Userlevel 1
lhuso wrote:

Yes, I have rediscoverd the device, but it didn't help.

But You gave me an idea!

I deleted the device and rediscovered it. Then it worked. I could uprade the device

The solution for this device was to delete it and add it again. But I have other similar switches where it doesn't help, so this is ver strange.

I ran into that same problem a few times, with newly added devices. I also fixed it by deleting the device from Management Center, then adding it again.
Userlevel 1
I will attempt the delete and rediscover to see what happens and advise. But I am experiencing the same thing with code EXOS 16.1.3.6 patch1-2 upgrading to 16.2.1.6 on X460-G2-48p-10GE4 switches. We upgraded Netsight to 7.0.6.27 just last week Server JRE 1.8.0_101 in case this helps.

Reply