EXOS TFTP put to Netsight failing due to incorrect forward slash



Show first post

29 replies

Userlevel 1
Here was the problem:



When I installed Management Center, I don’t think it ever gave me an option of changing the path to the TFTP root directory, which defaults to (C:/tftpboot). I found where to change this in Management Center > Administation > Options > Inventory Manager > File Transfer, and did so, assigning the path for TFTP to another drive letter (b:/, on my server).

Of course, I had to manually create the tftpboot/ and its subdirectories on that new drive letter, which I did. As I already wrote in this incident, Management Center was aware of this new path, as I could observe it create the appropriate files in the tftpboot/configs/tmp/ directory to prepare for a switch to send its configs to the Management Center server.

The problem was that the file %install_dir%/Extreme Networks/NetSight/services/nstftpd.cfg remained pointed to the default tftpboot directory on the C:/ drive, even after I modified the path to the tftpboot directory using the Management Center GUI.

When I manually edited the nstftp.cfg file to reflect the actual path in which the tftpboot directory is located and restarted the tftp service on the Management Center server, I was able to successfully stamp configuration archives.

Thanks to everyone for your suggestions.
Userlevel 1
Here was the problem:



When I installed Management Center, I don’t think it ever gave me an option of changing the path to the TFTP root directory, which defaults to (C:/tftpboot). I found where to change this in Management Center > Administation > Options > Inventory Manager > File Transfer, and did so, assigning the path for TFTP to another drive letter (b:/, on my server).

Of course, I had to manually create the tftpboot/ and its subdirectories on that new drive letter, which I did. As I already wrote in this incident, Management Center was aware of this new path, as I could observe it create the appropriate files in the tftpboot/configs/tmp/ directory to prepare for a switch to send its configs to the Management Center server.

The problem was that the file %install_dir%/Extreme Networks/NetSight/services/nstftpd.cfg remained pointed to the default tftpboot directory on the C:/ drive, even after I modified the path to the tftpboot directory using the Management Center GUI.

When I manually edited the nstftp.cfg file to reflect the actual path in which the tftpboot directory is located and restarted the tftp service on the Management Center server, I was able to successfully stamp configuration archives.

Thanks to everyone for your suggestions.

By the way, I found this by installing the tftp client on my windows workstation, and successfully putting a file onto my Management Center server from my workstation. I wanted to prove the TFTP server, good or bad. At that point, I still had the "-c" switch active in the nstftp.cfg file. When I couldn't see the file I put onto the server on the new path to the tftpboot directory, I found that it was in the default path, which was on the C:/ drive.

I failed to note the incorrect drive letter designated in the nstftp.cfg file when I added that "-c" switch. But, after I found the file I put onto the TFTP server, it reminded me to inspect that config file more closely.
Userlevel 6
Here was the problem:



When I installed Management Center, I don’t think it ever gave me an option of changing the path to the TFTP root directory, which defaults to (C:/tftpboot). I found where to change this in Management Center > Administation > Options > Inventory Manager > File Transfer, and did so, assigning the path for TFTP to another drive letter (b:/, on my server).

Of course, I had to manually create the tftpboot/ and its subdirectories on that new drive letter, which I did. As I already wrote in this incident, Management Center was aware of this new path, as I could observe it create the appropriate files in the tftpboot/configs/tmp/ directory to prepare for a switch to send its configs to the Management Center server.

The problem was that the file %install_dir%/Extreme Networks/NetSight/services/nstftpd.cfg remained pointed to the default tftpboot directory on the C:/ drive, even after I modified the path to the tftpboot directory using the Management Center GUI.

When I manually edited the nstftp.cfg file to reflect the actual path in which the tftpboot directory is located and restarted the tftp service on the Management Center server, I was able to successfully stamp configuration archives.

Thanks to everyone for your suggestions.

Thanks for sharing this insight Jesse. This will definitely help others in the future that run in to something similar. Really good stuff!
Userlevel 1
To close this, I sent my findings to GTAC, and Tom Currier answered me. There is a separate place to configure that file from the GUI: Administration > Options > Services for Extreme Management Center Server > TFTP. That's the second place to change the path for the TFTP service configuration file, which I had changed manually.

I suggested it might be better if that were all on one page...

Reply