Question

firmware download page too complicated


Userlevel 7
I'd like to upgrade my EMC but I don't plan to search for minutes on the download page for the right file.

Example:


I'm sorry but either I'm doing something wrong or that is the most complicated way to present firmware versions.

-Ron

32 replies

Userlevel 2
I was going to post something about this as well - it does seem overly complicated to find firmware now as well.
Userlevel 3
+1

The move to the Salesforce portal has done nothing for software downloading. It was significantly better beforehand.

On the specific point of the EMC download, I seem to remember that the filename is very counter-intuitive too.

Paul.
Userlevel 4
Currently, it's not friendly enough, Extreme portal is new, it will be improved and optimized.
Userlevel 4
Agreed. It should at least be separated by platform.
Userlevel 1
Count me in with the folks that have to spend a lot of time to find the firmware I need. Glad to hear it will be improved.
Userlevel 7
It was more "friendly" before - so the plan to replace the download page with what we've now failed.

As far as I remember I've pointed out that shortcoming during the alpha phase of the page......

In regards to "it will be improved and optimized" - what is the ETA for that - should we "work" with that for months/years ?
Userlevel 4
Hi,

please try the "advanced" button when searching for software - This way it was possible for me to find the new EMC images in seconds.



Cheers
André
Userlevel 7
André Herkenrath wrote:

Hi,

please try the "advanced" button when searching for software - This way it was possible for me to find the new EMC images in seconds.



Cheers
André

Fair enough, let's play around....

Search filter: advanced, ExtremeControl
Result: also non ExtremeControl files are shown, i.e. EMC, ExtremeAnalytics

Search filter: advanced, ExtremeAnalytics
Result: also non ExtremeAnalytics files are shown, i.e. EMC, ExtremeControl

In case I'd like to get the files to upgrade my whole EMC suit I'd need to know that the upgrade files end with a .bin - only then I'll get all 3 files on the first page of the search result (filter: advanced, ExtremeManagment, bin).
I'm pretty sure not everyone knows that.

Next step is to click the download link - I select the EMC link - now I get the pop-up with the "Select a Customer to Download on Behalf of" menu where I'd search the right one out of 7 pages.

After a while the download starts and now the best one.... it loads once again the main download page and all my search settings are gone.
To download now also the NAC, Purview file I need to go to thru the whole process again.

-Ron
Userlevel 2
For download i use the menu PRODUCTS, and on product have the informations, download and others

Luis Mendes wrote:

For download i use the menu PRODUCTS, and on product have the informations, download and others

This is what I have been using too. Puts the firmware in one spot in order.
Userlevel 7
Luis Mendes wrote:

For download i use the menu PRODUCTS, and on product have the informations, download and others

OK in case of EMC 8.0.3.46 I get a list with 32 files and I'd hover over every filename to see more details (= the full file name) and if I'm familiar with the differences I'd select the right one.

Why are there NAC .ova files small/medium/large - the controller has only one .ova and the CPU/RAM decide whether it's a small/medium/large deployment.
Userlevel 4
Ron,

you put your finger finger on the key point.
The download speed is much more better since working with akamai but since I was beta tester of the new portal I recommend to use a easy way to find the files you need. I preferred the view from the existing portal.
In the case of EMC the amount of files for a single version is extremly confusing.
And Yes! the authorisation process to download more than one file is annoying !

- Coming via products to the downloads, there is no advanced option
- the advanced filter skips the search field


- you cannot see the full file description - you have to check every single file


- the file description is crazy ... (EMC.., Windows..., Linux...

there is a lot of space to make this easier !

br
Volker
Userlevel 2
Hi all,

complained about exactly the same yesterday

What i did use is hovering over that "Multiple Products" text in the Product Name column and select only one of them via mouse click.

That makes the choice much smaller but nevertheless it's still too much and that hovering over the file name is annoying.

Quick and dirty enhancement would be making the columns resizable so i can see the whole filename at once. Also allowing to select how many items are displayed should be easy to implement and then allow a text search for faster finding the correct file.

There's still a lot of work to do in that section...

regards
Peter
This is my problem (speed).
https://www.youtube.com/watch?v=TMrvY5qDBOE&feature=em-upload_owner
Userlevel 7
Jeremy Gibbs wrote:

This is my problem (speed).
https://www.youtube.com/watch?v=TMrvY5qDBOE&feature=em-upload_owner

Is it always that slow, Jeremy?
Userlevel 4
Jeremy Gibbs wrote:

This is my problem (speed).
https://www.youtube.com/watch?v=TMrvY5qDBOE&feature=em-upload_owner

I guess most of the slow is caused by region Country or if Akamai deployed. In China, all US website was slow like this, but APAC website will be fast.
Userlevel 4
Jeremy Gibbs wrote:

This is my problem (speed).
https://www.youtube.com/watch?v=TMrvY5qDBOE&feature=em-upload_owner

As I know, Akamai is involved only for file downloads and not for publishing the website - what Jeremy showed us. The downloads are working better than ever but again, the delay in the website ist still present - for me, it does not matter where you are and when you try it.

@Drew: Are you using external monitoring tools for the website ?
Jeremy Gibbs wrote:

This is my problem (speed).
https://www.youtube.com/watch?v=TMrvY5qDBOE&feature=em-upload_owner

Yes, it's very slow. Here is our internet connection. I am limited because of my 1 Gbps connection to the network, my other computer is connected at 10 Gbps...
http://speedtest.xfinity.com/results/J6GIWQ6RGP5Z8DD
Userlevel 7
Jeremy Gibbs wrote:

This is my problem (speed).
https://www.youtube.com/watch?v=TMrvY5qDBOE&feature=em-upload_owner

I get a faster connection via WLAN, that ISP sucks 🙂
Userlevel 4
Jeremy Gibbs wrote:

This is my problem (speed).
https://www.youtube.com/watch?v=TMrvY5qDBOE&feature=em-upload_owner

Nice speed! Did you check if the bottleneck from service provider or interface between different service provider?
Userlevel 7
Jeremy Gibbs wrote:

This is my problem (speed).
https://www.youtube.com/watch?v=TMrvY5qDBOE&feature=em-upload_owner

Let me bring this up with the IT team. I'm not sure what monitoring tools they use, but I'm seeing the slowness on the products pages here in the office as well. That's not good.
Jeremy Gibbs wrote:

This is my problem (speed).
https://www.youtube.com/watch?v=TMrvY5qDBOE&feature=em-upload_owner

haha.. I have used my VPN service (tunnlebear), trying various countries, regions.. etc.. Nothing helped the speed. It seems like a poorly built database index, and it's having trouble on the backend with a massive SQL select statement.
Jeremy Gibbs wrote:

This is my problem (speed).
https://www.youtube.com/watch?v=TMrvY5qDBOE&feature=em-upload_owner

Drew, it's been like this for months... (I tried telling a few internal people on a phone conversation at one point). I was a Unix SysAdmin in a past life.. and I do enjoy database stuff... It really does seem like an unoptimized database query or bad indexing.
Userlevel 4
Jeremy Gibbs wrote:

This is my problem (speed).
https://www.youtube.com/watch?v=TMrvY5qDBOE&feature=em-upload_owner

I'm using vpn as well, because access US website from China is really a pain. After using vpn, the speed is fine, not slowly like your video. Anyway, let's see is there something back from Drew.
Userlevel 7
Jeremy Gibbs wrote:

This is my problem (speed).
https://www.youtube.com/watch?v=TMrvY5qDBOE&feature=em-upload_owner

I think you're correct about the database and/or the queries being run against it not being quite "right." I'm aware that the licensing page is often abysmally slow, and I believe there's some optimization that should be done there. The products page is a new one for me... I'll make sure the right people are aware of the feedback in this thread and hopefully they can figure out how to fix this.

Reply