how to add port groups to Eaps Domain in Netsight ?

  • 3 February 2016
  • 18 replies
  • 235 views

In Ridgeline you would create port groups and associate those port groups to a defined Eaps Domain and run a script to add a new vlan to those ports. How would you perform this in Netsight 6.3 ?

18 replies

Userlevel 3
Hi Tiburicio,

This related conversation may be helfpul:

https://community.extremenetworks.com/extreme/topics/easiest-way-to-add-a-eaps-protected-vlan-with-n...

You can add ring ports to EAPS rings along with other actions.

Tony
I have tried this and does not work for me, it creates the vlan and tags it, it fails when ithe script tries to add to the ports have selected in the Eaps script
In Ridgeline you would create port groups, from there you would sync which eaps script you wan to add to those port groups.
Userlevel 3
Are there any messages from the script wizard corresponding to when it fails indicating why it failed? Any messages in the switch log created when the script is run?
Are there any messages from the script wizard corresponding to when it fails indicating why it failed? Any messages in the switch log created when the script is run?[i]it just says it could not add the ports to the corresponding switches, i can send you some snap shots ?
Are there any messages from the script wizard corresponding to when it fails indicating why it failed? Any messages in the switch log created when the script is run?a total of 3 switches and 6 ports
Userlevel 3
Are there any messages from the script wizard corresponding to when it fails indicating why it failed? Any messages in the switch log created when the script is run?You can upload an image to a post using the icon that looks like a camera when typing your post.
Were there any messages in the switch log indicating a problem as the script ran? If there are some, please post the output of those messages too.
Are there any messages from the script wizard corresponding to when it fails indicating why it failed? Any messages in the switch log created when the script is run?My script on NetSight



#@MetaDataStart

#############################################################################################

# Define your user parameters in this section. For reference, see EPICenter bundled scripts.

#############################################################################################

#@VariableFieldLabel (description = "VLAN Name",

# type = String,

# scope = global,

# required = yes

# )

set var vlanname ""

##############################################################################################

#@VariableFieldLabel (description = "VLAN Tag", type = String,

# scope = global,

# required = yes

# )

set var vlannametag ""



#@MetaDataEnd

# Enter all CLI commands from here

create vlan $vlanname

config vlan $vlanname tag $vlannametag

disable igmp snooping vlan $vlanname

config eaps burke_commerce add protected $vlanname

config $vlanname add port $port tagged

regexp {.*Adding EAPS ring ports to a VLAN could cause a loop.*} ${CLI.OUT} foundit

IF ([info exists foundit]) THEN

CLI y

ENDIF
Are there any messages from the script wizard corresponding to when it fails indicating why it failed? Any messages in the switch log created when the script is run?

Userlevel 3
Are there any messages from the script wizard corresponding to when it fails indicating why it failed? Any messages in the switch log created when the script is run?Thank you for the information. Are ports 1:6 and 2:6 already members of vlan 'burke_commerce'? If they are not, they need to be added to the vlan. If you have not already done so, these same ports need to be added to the EAPS control vlan too.
Are there any messages from the script wizard corresponding to when it fails indicating why it failed? Any messages in the switch log created when the script is run?they are members of the Eaps Ports
Are there any messages from the script wizard corresponding to when it fails indicating why it failed? Any messages in the switch log created when the script is run?yes
Are there any messages from the script wizard corresponding to when it fails indicating why it failed? Any messages in the switch log created when the script is run?correct, they are already a part of the control vlan, when i run the script in Ridgeline it performs normal. In NetSight it does not
Userlevel 3
Are there any messages from the script wizard corresponding to when it fails indicating why it failed? Any messages in the switch log created when the script is run?Sorry, my mistake, are ports 1:6 and 2:6 need to be members of vlan piw_inet_test_burke2_1014? They need to be. burke_commerce is the EAPS domain.
Userlevel 3
Are there any messages from the script wizard corresponding to when it fails indicating why it failed? Any messages in the switch log created when the script is run?Ooops hit 'send' before I proofread my reply. Those ports need to be members of vlan 'piw_Inet_test_burke2_1014'.
Are there any messages from the script wizard corresponding to when it fails indicating why it failed? Any messages in the switch log created when the script is run?I have opened a GTAC case. Netsight is not pulling in port information from Port Element groups.
Are there any messages from the script wizard corresponding to when it fails indicating why it failed? Any messages in the switch log created when the script is run?I have opened a GTAC case. Netsight is not pulling in port information from Port Element groups.
Userlevel 3
Are there any messages from the script wizard corresponding to when it fails indicating why it failed? Any messages in the switch log created when the script is run?Ok, thanks for the update. I think you'll get this solved in no time with GTAC's help!
Have a good day

Reply