How to backup XOS with Netsight Inventory Manager

Userlevel 7
How could I backup my XOS X440 v15.7.1.4 with Netsight Inventroy Manager

I can't get it to work with SNMPv1 / telnet.
IM is set to Script/Controlled by Device Type/Extreme OS - SCP (VR-Default)


7 replies

Userlevel 4
Hi Ron,

I've never tried that myself, however I would imagine since the copy is done via SCP, then SSH needs to be at least enabled and possibly set as CLI creds. Again, not positive, but I would give that a try.

Userlevel 2
Have you tried with
Extreme XOS - TFTP ??

I have a BD8810 (with VR-MGMT) with TFTP is working well

Userlevel 6

From the documentation:

"You must be running the SSH2 module (ssh.xmod), which is under Export Control, in order to use the SCP2 command.
SSH2 does not need to be enabled on the switch in order to use this command."

Also, there seems to be a problem with the permissions of the anonymous account. Go to Inventory Manager -> Tools -> Options scroll down to File Transfer Settings -> SCP Settings, uncheck anonymous and use the root credentials instead.

The backup should now succeed.
Userlevel 7
I've installed the ssh image on the XOS but it doesn't work.

I'm a little bit disappointed by the XOS "integration" in v6.2.
Userlevel 6

A couple of things to check:
Did you do a run update after loading the ssh xmod or did you reboot the switch?

The command show management will show you if the SSH module is loaded or not. It does not matter if a key has been generated or not.

XOS1.3 # show management
CLI idle timeout : Enabled (20 minutes)
CLI max number of login attempts : 3
CLI max number of sessions : 8
CLI paging : Enabled (this session only)
CLI space-completion : Disabled (this session only)
CLI configuration logging : Disabled
CLI scripting : Disabled (this session only)
CLI scripting error mode : Ignore-Error (this session only)
CLI persistent mode : Persistent (this session only)
CLI prompting : Enabled (this session only)
Telnet access : Enabled (tcp port 23 vr all)
: Access Profile : not set
SSH access : Disabled (Key invalid, tcp port 22 vr all)
: Access Profile : not set
Web access : Enabled (tcp port 80)
: Access Profile : not set
Total Read Only Communities : 1
Total Read Write Communities : 1
RMON : Disabled
SNMP access : Enabled
: Access Profile : not set
SNMP Compatibility Options :
GETBULK Reply Too Big Action : Too Big Error
IP Fragmentation : Disallow
XOS1.4 #

[/code]If the ssh module is not loaded, the scp2 command will not be available.

XOS1.4 # scp2
%% Invalid input detected at '^' marker.
XOS1.5 #

Are you using the correct script?

There are two versions, one that tries to reach the NetSight server through virtual router VR-Mgmt and one that tries to reach it through virtual router VT-Default.

You can troubleshoot this by issuing the following commands from the CLI:

XOS1.4 # save config test
Do you want to save configuration to test.cfg? (y/N) Yes
Saving configuration on master Node .. done!
Configuration saved to test.cfg successfully.

The current selected default configuration database to boot up the system
(primary.cfg) is different than the one just saved (test.cfg).
Do you want to make test.cfg the default database? (y/N) No
Default configuration database selection cancelled.
XOS1.5 # scp2 vr "VR-Mgmt" test.cfg root@
Upload /config/test.cfg to
ssh: connect to host port 22: Network is unreachable
XOS1.6 # scp2 vr "VR-Default" test.cfg root@
Upload /config/test.cfg to
root@'s password:
Connected to
Uploading /config/test.cfg to /root/primary.cfg
/config/test.cfg 100% 127KB 127.3KB/s 00:00
XOS1.7 #

Userlevel 7
Daniel, I've tried it with my lab X430 and it's working now.
I'd need to verify it also with the customers hardware and Netsight.

Thanks for your help.
Is there some kind of log available in Netsight that show more information if something is going wrong with the configuration backup ?

Userlevel 4
There are some basic alarms in Inventory Manager. In the archive, if a device has failed to backup there usually is an exclamation warning symbol.

In a deeper dive sense, is to turn up logging (Should only do temporarily). There are a few different diagnostics that can be turned up.

The ones that are useful in this particular case would be: Inventory Manager, Inventory Manager Script, Telnet/SSH command Shell.