Question

How to disable ZTP+ for a device?

  • 25 June 2020
  • 5 replies
  • 165 views

Userlevel 3
  • Participator
  • 54 replies

Hi,

XMC 8.4.3: in our device groups for core server switches one of the switches has poll status “ZTP+ staged” and poll details “Configuration staged for device.” Additionally as firmware version an older version is shown.

If I do a “rediscover” for this device, the actual running firmwareversion is shown (22.7.1.2) for some seconds, then the table view switches back to firmware 22.6.2.4, which was used two switch updates ago. “Configure device” shows a ZTP+ tab, where configuration and firmware updates are disabled:

How can I disable ZTP+ for this device?


5 replies

Userlevel 7

right click on the device → Configure → change “Poll Type” from ZTP+ to SNMP and Save.

Userlevel 3

Hi Zdenek,

thanks for your reply. I checked Poll Type Setting and it was already set to “SNMP”.

Just to be sure I changed it to none, saved and set it back to SNMP, but the behaviour is still the same.

Userlevel 7

Are you sure you do not have duplicate IP in your network =  two switches with the same IP?

 

Userlevel 3

Hi,

i’m quite sure that there is no second switch with this IP.

The ARP entry (in this subnets router) is 389 days old, which is the time when we installed the switch. I compared switch MAC address and serial number in XMC when I do rediscover and for a short time the current Firmwareversion is shown before it switches back to show the former firmware version 22.6.2.4 . In both cases MAC address and serial number are the same.

It feels like the switch was once in a site with ZTP+ or had ZTP+ enabeld, XMC staged some configuration (as the current status says “configuration staged for device”), then ZTP+ was disabled but XMC kept this staging information.

 

Maybe deleting the switch from XMC with all data and readding would help?

Userlevel 3

Update: deleting and readding switch solved the problem.

Reply