Header Only - DO NOT REMOVE - Extreme Networks

I don't receive traps from switch which is managed through management port


Userlevel 4
I have some switches connected through the management port.

For some reason I don't receive any traps when a port went down or a EAPS change happend

14 replies

Userlevel 7
Hi Johan, could you please post the output for "show config | incl target-addr".

Do you rx any traps at all ?
Could it be that you haven't set vr-mgmt as the vr to forward the traffic.
Userlevel 4
Ron wrote:

Hi Johan, could you please post the output for "show config | incl target-addr".

Do you rx any traps at all ?
Could it be that you haven't set vr-mgmt as the vr to forward the traffic.

configure snmpv3 add target-addr "v1v2cNotifyTAddr1" param "v1v2cNotifyParam1" ipaddress 144.2.144.77 transport-port 162 vr "VR-Mgmt" tag-list "defaultNotify"

From this device I don't receive any trap at all. From other devices ( management not through mgmt port) I receive traps.
Ron wrote:

Hi Johan, could you please post the output for "show config | incl target-addr".

Do you rx any traps at all ?
Could it be that you haven't set vr-mgmt as the vr to forward the traffic.

Could you check whether the MIB-View is configured?

show snmpv3 mib-view
Userlevel 4
Ron wrote:

Hi Johan, could you please post the output for "show config | incl target-addr".

Do you rx any traps at all ?
Could it be that you haven't set vr-mgmt as the vr to forward the traffic.

View Name : defaultUserView
MIB Subtree : 1.0
Mask : 80
View Type : Included
Storage Type : NonVolatile
Row Status : Active

View Name : defaultUserView
MIB Subtree : 1.3.6.1.6.3.16
Mask :
View Type : Excluded
Storage Type : NonVolatile
Row Status : Active

View Name : defaultUserView
MIB Subtree : 1.3.6.1.6.3.18
Mask :
View Type : Excluded
Storage Type : NonVolatile
Row Status : Active

View Name : defaultUserView
MIB Subtree : 1.3.6.1.6.3.15.1.2.2.1.4
Mask :
View Type : Excluded
Storage Type : NonVolatile
Row Status : Active

View Name : defaultUserView
MIB Subtree : 1.3.6.1.6.3.15.1.2.2.1.6
Mask :
View Type : Excluded
Storage Type : NonVolatile
Row Status : Active

View Name : defaultUserView
MIB Subtree : 1.3.6.1.6.3.15.1.2.2.1.9
Mask :
View Type : Excluded
Storage Type : NonVolatile
Row Status : Active

View Name : defaultAdminView
MIB Subtree : 1.0
Mask : 80
View Type : Included
Storage Type : NonVolatile
Row Status : Active

View Name : defaultNotifyView
MIB Subtree : 1.0
Mask : 80
View Type : Included
Storage Type : NonVolatile
Row Status : Active

Total num. of entries in vacmViewTreeFamilyTable : 8
Ron wrote:

Hi Johan, could you please post the output for "show config | incl target-addr".

Do you rx any traps at all ?
Could it be that you haven't set vr-mgmt as the vr to forward the traffic.

Clear counters, disable and enable a port and then do "show management" there will be counters for traps sent check whether this counter incrementing.
Userlevel 7
could you post the full output of "show config snmp"
Userlevel 4
Ron wrote:

could you post the full output of "show config snmp"

Ronald,

The full output:

configure snmpv3 add group "v1v2cNotifyGroup" user "v1v2cNotifyUser1" sec-model snmpv2c
configure snmpv3 add community "audax" name "audax" user "v1v2c_ro"
configure snmpv3 add target-addr "v1v2cNotifyTAddr1" param "v1v2cNotifyParam1" ipaddress 144.2.144.77 transport-port 162 vr "VR-Mgmt" tag-list "defaultNotify"
configure snmpv3 add target-params "ST.-1878880179.10550_Params" user "initialmd5" mp-model snmpv3 sec-model usm sec-level authnopriv
configure snmpv3 add target-params "ST.-1878880249.10550_Params" user "initialmd5" mp-model snmpv3 sec-model usm sec-level authnopriv
configure snmpv3 add target-params "v1v2cNotifyParam1" user "v1v2cNotifyUser1" mp-model snmpv2c sec-model snmpv2c sec-level noauth
configure snmpv3 add notify "ST.-1878880249.10550_Notify" tag "EPICenter"
Userlevel 4
Ron wrote:

could you post the full output of "show config snmp"

Ronald,

The full output:

configure snmpv3 add group "v1v2cNotifyGroup" user "v1v2cNotifyUser1" sec-model snmpv2c
configure snmpv3 add community "audax" name "audax" user "v1v2c_ro"
configure snmpv3 add target-addr "v1v2cNotifyTAddr1" param "v1v2cNotifyParam1" ipaddress 144.2.144.77 transport-port 162 vr "VR-Mgmt" tag-list "defaultNotify"
configure snmpv3 add target-params "ST.-1878880179.10550_Params" user "initialmd5" mp-model snmpv3 sec-model usm sec-level authnopriv
configure snmpv3 add target-params "ST.-1878880249.10550_Params" user "initialmd5" mp-model snmpv3 sec-model usm sec-level authnopriv
configure snmpv3 add target-params "v1v2cNotifyParam1" user "v1v2cNotifyUser1" mp-model snmpv2c sec-model snmpv2c sec-level noauth
configure snmpv3 add notify "ST.-1878880249.10550_Notify" tag "EPICenter"
Userlevel 7
I've tried last week to enable SNMPv3 and run into the same issue so I've took a closer look on the commands and I've tried to unterstand which variable/name is the reference to the next command and so I came up with this.....



The last thing that I've missed was the "type inform" at the end of the last command.
As soon as I've changed that I was able to rx the traps on my EMC/Netsight.

I'd be wrong with my colour/variable list but you'd give it a try.
Userlevel 4
Ron wrote:

I've tried last week to enable SNMPv3 and run into the same issue so I've took a closer look on the commands and I've tried to unterstand which variable/name is the reference to the next command and so I came up with this.....



The last thing that I've missed was the "type inform" at the end of the last command.
As soon as I've changed that I was able to rx the traps on my EMC/Netsight.

I'd be wrong with my colour/variable list but you'd give it a try.

I have added the 'type inform' but not success.
Userlevel 7
Ron wrote:

I've tried last week to enable SNMPv3 and run into the same issue so I've took a closer look on the commands and I've tried to unterstand which variable/name is the reference to the next command and so I came up with this.....



The last thing that I've missed was the "type inform" at the end of the last command.
As soon as I've changed that I was able to rx the traps on my EMC/Netsight.

I'd be wrong with my colour/variable list but you'd give it a try.

Hi Johan,

SNMP informs were added in version 3, but you are using SNMPv2c, thus it would not be correct to add "type inform."

Br,
Erik
Userlevel 7
I've used this two KB articles and the command reference giude for my "study"...

https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-set-up-SNMPv3-on-EXOS https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-configure-SNMPv3-informs-in-EXOS
Userlevel 7
Hello Johan,
Has any of the information shared here helped you to resolve this issue?
Userlevel 4
Drew C. wrote:

Hello Johan,
Has any of the information shared here helped you to resolve this issue?

Hello Drew, No it isn't solved yet. I'm setting up a new test environment
Userlevel 4
Drew C. wrote:

Hello Johan,
Has any of the information shared here helped you to resolve this issue?

Drew, it works now good after I made the changes according the two KB articles

Reply