NAPALM driver/support?

  • 22 December 2017
  • 9 replies
  • 533 views

Userlevel 5
I was wondering if you had a NAPALM driver for EXOS, are working on one, or are planning on working on one? (https://napalm.readthedocs.io/en/latest/index.html)

If not, feel free to change this post to "idea" or "suggestion" :)

Frank

9 replies

Userlevel 7
Hi all,

as I understand it, SaltStack, StackStorm, and Extreme's Workflow Composer rely on NAPALM to communicate with network devices. NAPALM provides an Ansible module as well. Thus I'd say a NAPALM driver for EXOS seems to be a good idea.

Thanks,
Erik
Take a look at this! :D[/code]
Userlevel 1
Take a look at this! :D[/code]
Cant see the link...
Take a look at this! :D[/code]
sorry :D
https://github.com/ktbyers/netmiko/tree/develop/netmiko/extreme
Userlevel 1
Take a look at this! :D[/code]
Thanks!
Take a look at this! :D[/code]
https://github.com/tardoe/napalm-exos
Userlevel 2
Take a look at this! :D[/code]
FYI, that repo is now at https://github.com/ixaustralia/napalm-exos
Check this:
https://github.com/ixaustralia/napalm-exos

Reply