Header Only - DO NOT REMOVE - Extreme Networks

Need help getting Eaton Flexview to work

I can't figure out why the UPS reports to the mib tool but not to the Flexview. It seems like it should be either both or neither.

18 replies

Userlevel 4
Hi David,

What is the netsight version which you are using ?


Userlevel 2
Hi Dave, I can't tell what the OIDs you are reading nor the device type/family you are looking at.

Is this a new 3rd party MIB ? i.e. one you added?
note FlexViews send the OIDs in PDU blocks if you are including OIDs in the 'default' group that are not responding at the device it may appear there is no support at all.

Verify each OID you are looking for in the FlexView is being returned by MIB Tools.
Any that are different instances other that (0 - scalars) I would move to the 2 request block using the FlexView editor.
Userlevel 2
Perhaps you could attach the FlexView file that is not behaving as expected? Also provided the firmware / device that are you see responses from using MIB Tools. I cannot tell from the image thanks.
Yes, these are mibs for Eaton to monitor a UPS we have at our office. I am looking at them in the mib tool and it displays: xupsBatteryAbmStatus 0 Integer 4 batteryResting

This is what makes it so confusing. The mib appears to provide data in the mib tool but not in the flex view.
Here is the Flexview I am trying to get working:

When I started it up this morning I the following error in Console, which I now suspect is the problem.
Warning Application 10/02/2015 10:02:59 AM --- dcog_e6440 netsight Event SNMP Startup Warning: Cannot adopt OID in EATON-EPDU-MIB: notifyHumidityThStatus ::= { notifications 42 }

Thanks for the help
Userlevel 2
I would also need all the MIBs you have added --
Did you place them in MyMibs?
Console Event Log on startup should load these and read them and show any parsing errors filter on 'SNMP'.
Perhaps there are more than just the one you provided?
Murphy, Daniel wrote:

I would also need all the MIBs you have added --
Did you place them in MyMibs?
Console Event Log on startup should load these and read them and show any parsing errors filter on 'SNMP'.
Perhaps there are more than just the one you provided?

Yes you are correct. I appears they all the mibs are failing in this location. I will post a link for the mib file as soon as I get a chance to put it in dropbox. I will also check for duplicate OIDs as you suggest below.

Thanks for the help
Userlevel 2
This looks like it is related to the new MIBs.
One thing to understand about FlexViews is the 'OID Name' must be unique in the MIB Tool database to ensure the FlexView uses the correct OID in the PDU.

Verify using MIB Tools that for each OID you have the the FlexView there is one and only when you search in MIB Tools.
Hope that helps some.
I have gone through and cleaned things up and currently only have 1 third party mib file in the mymibs folder I am attaching a link to the file:

I have also tried looking for duplicate OIDs using the MIB tool and not found any.
Userlevel 2
1) This MIB seems to be safe - no issues I see on import.
2) However looking at the 'created FlexView you provided. The new OIDs added are not found in the MIB database.
xupsBatTimeRemaing, xupsIdentModel, xupsBatteryLastReplacedDate, xupsBatteryAbmStatus, xupsOutputLoad .... etc.
Note: if you open the FlexView and click on the columns the MIB Tree will select the OID. This shows the current MIB database does not have these entries.
Good Luck.

If I go to properties in the flex view I can search the OID and find it as shown in the below picture

If I open the mib tool I can find it in the tree and it provides data as seen below

So I dont understand how all this can be true if it is not in the database. And it appears in the Mymibs folder

We are trying to get these third party devices working as many of our customers seem interested in the prospect of consolidating some of there network management into one application.

Thanks for the help
Userlevel 2
You provided only the pwernet414.mib so I do not have yet the Xups.mib
So if you are seeing things correctly with no issues perhaps it works for you now?
Have you tried moving the xups values to the (2) request block (i.e. not the (default (1)) request block?

Are you sure that the xups values you are reading all share the same instance (ifIndex) as the ifPhysAddress?
Userlevel 2
Also when you upload that other MIB perhaps you could export a MIB tools read of the xups tables from MIB tools in HTML
Here is the other mib file, I thought I had uploaded both last week, sorry for the mixup on that. https://www.dropbox.com/s/fqw38el3vlqctus/Xups.mib?dl=0
I tried moving the xups values to the 2 block as you suggested and saw no change in the Flexview output.

Here is the HTML output from the mibtool table

Userlevel 2
The HTML does have information but only some scalars, could you back up a level and redo.
All it takes is a single (VALUE packed into the PDU to not respond) and the FlexView will fail.
Now you can add them if they are always going to be there.
So moving all to Request 2 Not (sysName, sysLocation, sysContact) keep these in (Default)

Then you have 12 (new scalars) but I suspect some are not returned.
I cannot verify with the MIB result you provided.

::= { powerware 1 }

For example


You have xups what appear to be all scalar values.

So 1 or more are not being returned.
You would need to test by moving the request block (3 and 4)
perhaps if you provide the full HTML i can see the issue (on the single device) you are reading.
Other wise just take your time -- adding only a single (Table) at once.
and test across multiple devices - MIBs are not always consistently implemented.
I have none of these in house and I have never read from these tables before.
Userlevel 2
My suggestion is to create 4 or 5 test FlexViews label them by (table) you are in when testing.
That way you can see on a set of devices if the scalar values are being returned by the device.
This would help point to the issues quicker.
I assume one or more of the OIDs are deprecated or not supported on the device we are testing.

Thanks for your help with this. The issues appears to have been 3 columns that were returning missing values and causing all columns except the mac address to fail to display.

Going forward when trying to build flex views I will add one column at a time.

Thanks again
Userlevel 2
Good luck - I usually save test1---- test2.... that way if I mess up I have a previous working one.
This is very important because of 2 issues.
Save -- it tricky and sometimes you are not looking (cached) ad the edit FlexView so save under a new name.
This always works.
Write expression can be a pain and corrupt the flexView so if you have a complicated one and mess it up you want a valid back up.