No access to Netsight_although valid logging credentials


Userlevel 1
Hello guys,



i’m actually facing following issue with Netsight 6.2.X running on Hyper-V.

the logging on the system is always failing although the user is active on the system. The user password has been successfully controlled.

Two users are present: root and an additional user. Both of them do not gain access.



Any hint how to overcome it?

Access to the console (cli) is possible.

Is there any special way, how to configure new user for GUI access? Since those, I’ve configured so far a still not gaining access.



Thanks in advance for your attention as well as feedback.



Regards



Gradelain

9 replies

Userlevel 1
please also note that if i test any valid user on the console (CLI) as follow,i gain access.

> login
> ---> password is required

but why i'm not gaining access on the GUI using the same user ?
Userlevel 7
Are you running local or LDAP authentication.

Could it be that someone changed it from local to LDAP ?

Here a link how to change it back to local....
How to setup and Use Netsight Authorization/Device Access to access Netsight for specific users groups and privileges

-Ron
Userlevel 6
So assuming NO GUI ACCESS, but access via SSH.
Please review the following article. 80 percent of the time it does the trick.
https://gtacknowledge.extremenetworks.com/articles/Solution/Unable-to-login-to-Netsight-Console-using-LDAP-or-OS-credentials

Let us know if this does or does not work.
Userlevel 1
Thanks Mike for the link. i used it unsuccessfully.
this is actually the ouput of the "nsproperties".
can you find any discrepancies?

mysql> update nsporperties set VALUE = 'true' where VALUE = 'false';
ERROR 1146 (42S02): Table 'netsight.nsporperties' doesn't exist
mysql> update nsproperties set VALUE = 'true' where VALUE = 'false';
Query OK, 3 rows affected (0.00 sec)
Rows matched: 3 Changed: 3 Warnings: 0

mysql> select * from nsproperties;
+----+------------------------------+-------------------------------+
| ID | NAME | VALUE |
+----+------------------------------+-------------------------------+
| 1 | serverAuthType | Default ( OS Authentication ) |
| 2 | serverAuthOSAuto | true |
| 3 | serverAuthOSGroup | NetSight Administrator |
| 4 | serverAuthLDAPConfig | None |
| 5 | serverAuthLDAPFailToOS | true |
| 6 | serverAuthLDAPGroup | NetSight Administrator |
| 7 | serverAuthRadiusConfig | None |
| 8 | serverAuthRadiusBackupConfig | None |
| 9 | serverAuthRadiusFailToOS | true |
| 10 | serverAuthRadiusGroup | NetSight Administrator |
+----+------------------------------+-------------------------------+
10 rows in set (0.00 sec)

mysql>

regards
Userlevel 6
There is a spelling error nsporperties should be nsproperties
Userlevel 1
true, but get a look on the second line.. has been corrected "nsproperties".
base on the ouput you cann see how the variable are set right now.

thanks
Userlevel 7
Regarding your question how to add a user to access the GUI...

First create the user in the GUI..
How to setup and Use Netsight Authorization/Device Access to access Netsight for specific users groups and privileges

Then create the account in the OS.
- ssh to Netsight
#useradd "name"
#passwd "name"

-Ron

admin edit: link updated
Userlevel 6
Ron wrote:

Regarding your question how to add a user to access the GUI...

First create the user in the GUI..
How to setup and Use Netsight Authorization/Device Access to access Netsight for specific users groups and privileges

Then create the account in the OS.
- ssh to Netsight
#useradd "name"
#passwd "name"

-Ron

admin edit: link updated

Updated Link
https://gtacknowledge.extremenetworks.com/articles/How_To/How-to-setup-and-Use-Netsight-Authorization-Device-Access-to-access-Netsight-for-specific-users-groups-and-priviledges
Userlevel 1
Thnaks a lot guys,

it turns out that the customer has implemented additional security in its network which lead to the failure. everything fine now.

Reply