OneView Automatic Deployment


NetSight 5.1
C5-Series FW 6.81

When testing the new Automatic Deployment feature, the switch gets assigned an ip address by dhcpd but does not send a trap.

Tested this without option 125, send the trap to the dhcpd ip address.
Tested this with option 125 delivering the netsight ip address.

The network was monitored with wireshark.

I can clearly see the communication process between the switch and the dhcpd but as sson as the switch gets its ip address, there is no trap to be seen on the wire.
[/code]subnet 10.1.0.0 netmask 255.255.255.0 {
range 10.1.0.1 10.1.0.20;
option vivso 00:00:15:F8:06:01:04:0A:00:00:02;
option subnet-mask 255.25.255.0;
option broadcast-address 10.1.0.255;
option routers 10.1.0.254;
}
[/code]This is my subnet definition in dhcpd can anyone spot something wrong there ??

Thanks Hans
[/code]

4 replies

Userlevel 7
Hans, I'm not an expert on the DHCP config but the subnet mask is not correct there is a typo...
255.25.255.0 should be 255.255.255.0

As far as I'd see Netsight has IP 10.0.0.2 and the client is in the 10.1.0.0 subnet - could you try whether it work in the same subnet.

Kind regards,
Ron
Ahhhh.....you are right, indeed the mask is wrong,......
As for your suggestion of trying both on the same subnet, thats why i temporarly disabled the option 125 to force the switch to send the trap to the dhcp server ip address (10.1.0.254).
But as i dont know how the switch my react to a malformed mask i first will check the mask and
see if that makes any difference.

Hans
Ahhhh.....you are right, indeed the mask is wrong,......
As for your suggestion of trying both on the same subnet, thats why i temporarly disabled the option 125 to force the switch to send the trap to the dhcp server ip address (10.1.0.254).
But as i dont know how the switch my react to a malformed mask i first will check the mask and
see if that makes any difference.

Hans
And as i changed the mask to a correct value, all started working as seen on tv,...

Thanks Dvorak for your eagle eyes,....

Reply