Header Only - DO NOT REMOVE - Extreme Networks

restore Control/NAC - Control up but as device down in EMC


Userlevel 7
Hi,

I've upgraded my Control engine last night to the 8.0 early build and messed up during the OS Ubuntu upgrade.

At that point I'd either troubleshoot why the mount didn't work or just do what I've learned in my NAC training ... to just delpoy another engine .ova image with the same data and sync it via the Control Manager.

As I've never done it I thought that is a good test just in case I ever run into such situation at the customer site.

So I've...
- turned the corrupted Control engine off
- loaded the fresh 8.0 .ova on my host
- configured it with the same dnet, SNMP settings
- refresh/rediscovere it in EMC
- done a enforce all via Control Manager

At that point all my clients where able to authenticate once again via Control and it looked pretty good.
The only issue was that EMC reported the Control engine switching up/down as a device.
After some time it stayed down but still all clients where able to authenticate and I'd also see the end-system tab client information.

Is there anything I've missed or any idea why Control show the Control Engine as up but in Network/Devices it's down ?

Cheers,
Ron

4 replies

Userlevel 6
Hello Ron,

Can you verify the SNMP profile you assigned to the NAC appliance matches the snmp credentials that you configured?

It sounds like you have snmp contact lost, but the web service connection is up, as the enforce was successful.

Thanks
-Ryan
Userlevel 6
First verify what Ryan suggested.

Try delete the Engine from the "devices" and add it again. Do not delete it from Extreme Control configuration, just from the "console". I guess the SNMPengine ID is different now and Management Center does remember the old one.

You can try assign different SNMP profile and then assign it back.

Z.
Userlevel 7
Sorry that I didn't update the thread.

The problem was gone after upgrading to a higher early build without changing any settings.

Thanks guys.
Userlevel 6
Nice!

Thanks Ron!

Reply