Solved

XMC and Firefox ESR: Security error (websocket?)

  • 26 July 2019
  • 4 replies
  • 161 views

Userlevel 3
Hi,
I'm unable to use XMC (8.2.6.5) in Firefox Quantum ESR (60.7.2).
It's a fresh install and I wouldn't know what version worked before, if any.
The console shows the following, seems to be related to some websocket thing.
(Chrome works fine)




As a matter of fact when I look at what it loads next in Chrome it's in fact a connection upgrade to a websocket (wss://xmc:8443/....). So what's the problem? The https connection's self-signed certificate has been accepted, and the location of the websocket is secure (wss), I don't get it...

Thanks,
Marki
icon

Best answer by Rodney Lacroix 27 July 2019, 13:58

Hi Marki,

Although technically on the supported browser list, it SHOULD work unless something has been added/removed or set in the browser, specifically. I just downloaded Quantum - leaving the defaults - and don't see any issues.

One thing you may want to try is simply changing the url from /center to /devices. There is a known defect assigned to Development where the /center URL will sporadically pull up a blank page.

We try to pull up the previously known url as the default, but if we don't know it, we default to the /center view. From time to time, this can pull up blank pages. If you manually edit the url from /oneview/view/center to oneview/view/devices, this should fix the issue and - in most cases - stop you from seeing it again.

Here is my screen with Quantum, to show you it does work:

View original

4 replies

Userlevel 2
Hi,

The supported browser for XMC are:

MS Edge
IE 11
FF 34
Chrome 33

NOTE: Browsers must have Java Script and Cookie enabled
Userlevel 3
Hi,

The supported browser for XMC are:

MS Edge
IE 11
FF 34
Chrome 33

NOTE: Browsers must have Java Script and Cookie enabled


What are you trying to tell me? I mean these minimal requirements are fulfilled (FF60 > FF34) Of course Cookies are enabled, as is javascript which launches the WS queries in the first place.
Userlevel 3
Hi Marki,

Although technically on the supported browser list, it SHOULD work unless something has been added/removed or set in the browser, specifically. I just downloaded Quantum - leaving the defaults - and don't see any issues.

One thing you may want to try is simply changing the url from /center to /devices. There is a known defect assigned to Development where the /center URL will sporadically pull up a blank page.

We try to pull up the previously known url as the default, but if we don't know it, we default to the /center view. From time to time, this can pull up blank pages. If you manually edit the url from /oneview/view/center to oneview/view/devices, this should fix the issue and - in most cases - stop you from seeing it again.

Here is my screen with Quantum, to show you it does work:

Userlevel 3
Hi,

The supported browser for XMC are:

MS Edge
IE 11
FF 34
Chrome 33

NOTE: Browsers must have Java Script and Cookie enabled


You know, I have to add a thing: I'm really sick of such answers actually. This kind of answer is by the way totally unusual for an Extreme employee, way below their standards, at least those I've been in contact with so far.
Instead of just trying FF Quantum as Rodney did, and confirming it wouldn't work (which it does NOT, as we have established) you throw a list at me containing browsers five years(!) old claiming that would be the cause and insinuating I should use those I guess. That fact alone is worrisome. (FF 34 release date = Dec 1, 2014)

Reply