Header Only - DO NOT REMOVE - Extreme Networks

Zero Touch out of box 450-G2 EXOS 16.1


I have a few dozen new 450-G2 switches I want to deploy using zero touch. I have created a new vlan and setup dhcp in a win2k8 server (yes I remembered to setup ip forwarding, and I do have option 125 set, but I'm net even getting far enough in dhcp for the options to get to the client) I have that vlan (32) egressing tagged from my edge switch (a D2-12) to the core. I have the downlink to the switch untagged on vlan 32. I have tried using both the management port and port 1 on the 450-G2. When I put a windows client on that port, I get a lease. when I connect the switch, although I see an offer from the DHCP server, and the offered IP and MAC populates in the DHCP server, the switch remains on the 169.254 network and a sho dhcp-client state shows 0.0.0.0 addresses. My hope is to get this working to get the switches to zero config enough to push out 21.x firmware, then discover netsight via ZTP+ and start to config. Without even getting a successful DHCP lease I'm stuck.

5 replies

Userlevel 5
I'm not sure I followed all of the above, so I would like to ask a question. Would the DHCP request/response be untagged as the X450-G2 would see the traffic?

For ZTP to work, the DHCP request/response is assumed to be untagged
yes, the dhcp requests are untagged. I can see the conversation in wireshark with the switch making a request and the server making an offer. what does not happen is the accept from the switch and the switch replacing the 169 address with the dhcp offered address. I think I have the port/egress right as a desktop client on the same port successfully gets an address. my hunch is that there was a problem in 16.1 with dhcp-client. I also wonder if it would work better with a linux server.
Keith Obermeier wrote:

yes, the dhcp requests are untagged. I can see the conversation in wireshark with the switch making a request and the server making an offer. what does not happen is the accept from the switch and the switch replacing the 169 address with the dhcp offered address. I think I have the port/egress right as a desktop client on the same port successfully gets an address. my hunch is that there was a problem in 16.1 with dhcp-client. I also wonder if it would work better with a linux server.

I do remember seeing a kb article about the switch rejecting a lease that has a lease time under 2 seconds. I tried changing the lease time to infinity, and to 8 hours to see if the lease time was causing the switch to reject the lease. no luck.
Userlevel 5
To remove ZTP as a variable, you could enable dhcp vlan mgmt for the mgmt port or enable dhcp vlan default for front panel to see if the switch gets a DHCP address. If that works, then there is something with ZTP,
Userlevel 4
As said earlier by Dave if there is anything found to be with the ZTP then please have a look at the below link for its configuration if that matches yours:

https://gtacknowledge.extremenetworks.com/articles/How_To/What-configuration-is-needed-for-ZTP-Zero-...

Reply