Header Only - DO NOT REMOVE - Extreme Networks

ZTP+ Device Configuration Failed

Userlevel 5

In the process of trying to add a switch via ZTP+ and tried every permutation I can think of to get the switch to pass, but no matter what I do or how simple I set it I always get a 'Device Configuration Failed'

At the moment I've pretty much disabled everything and just got it adding an IP address to a VLAN called Local-Subnet PVID 100, here are some screenshots:

The switch will get its new IP as part of the configuration passed by EMC but other configurations fail and the ZTP+ status never moves from 'Configuration Error'

So the ZTP+ config is stripped down to as far as I can make it, but fails as per the screenshot above on commands like the below:

delete vlan Default
create vlan DEFAULT VLAN tag 1
configure stpd s0 mode mstp cist

I can't do anything about the vlan DEFAULT as your not allowed to delete it, so I can't move past the error?

I assume it is these errors that are causing the issue?

The switch gets an IP of from DHCP and then transitions OK to IP, and also configures SSH login via ZTP+ - so it works in part then stalls.

Running latest version of CC3.
Switch firmware is
EMC is

2 replies

Userlevel 5
After many many hours working on it finally got to the bottom of the issue. The answer was starring me in the face and couldn't see it until GTAC pointed out the command above was trying to create a vlan called 'DEFAULT VLAN' were it should have been 'Default'

I think the error has come in due to the ZTP+ configuration were there is a button called 'Import VLANs' under the policy section:

Here the default policy domain has been selected, although it could be any.

By default the following VLANs are part of policy. Although I had adjusted the VLANs in my policy to match the customers I hadn't touched the default vlan, mainly as you can't remove it even if you are not using it anyway:

As you can see the VLAN is called 'DEFAULT VLAN' and not 'Default' and why ZTP+ kept failing as it imported the wrong name!

In addition I was getting these errors:

Command "configure port 52 auto on" failed: CLI command failure:configure port 52 auto on:Error: Speed has to be specified on port 52

So you need to make sure the ports are disabled for auto and fixed, which you can do once the device as been discovered an waiting pre-configuration. You just go to the ports tab and set it.

Once staged just manually reboot the switch (you can wait but you'll be waiting a while) then it should pop into EMC without issue.

Here are some additional prerequisites to be aware of:

· The Cloud Collector needs to be download from GitHub.

· No Stacking Support

· No real State (Upgrading, Rebooting, Operational etc..) reporting

· ZTP+ Debug option in XMC Administration - Diagnostics

· Licensing is not managed (ie if switch has a licence installed , will have to be manually re-applied)

· Auto setting sysLocation & sysContact (MIB Objects) might not work

· Do NOT add CC XMOD manually, must update from EMC

· Set the reference firmware in EMC

· Make sure the switch has had ‘unconfigure switch all’ run, NO config must be on it

· Do NOT attach the console cable when booting otherwise CC will not start

· Configure extremecontrol. with IP of EMC

Think that's it.

Great protocol, once everything is in place 🙂
Hi Martin,

we have the same problem like you with ZTP+ but in Management Center Version

So we updated the Management Center to Version
As expected, the update was only partially effective:
The bug with the deletion and creation of the Default VLAN is fixed.
The Problem with the Uplink/VIM Ports is still present.

I hope they will fix it in the next Management Center version.

Best regards