ZTP+: Invalid configuration provided by controller IP address extremecontrol


Userlevel 1
I have a X460G2-24t-10G4 that has connected to Extreme Management via ZTP+. It is in a "ZTP+ Pending Edit" stage, but when I edit it and click "Save", EMC says "ZTP+ Configuration Error" and the log on the switch says "[i] ZTP+: Invalid configuration provided by controller IP address extremecontrol"

10 replies

Userlevel 7
Hi,

if you're using XMC 8.x, you really should use CC 3.0. So, did you upgrade the CC version on the switch to the latest 3.0?

You might have tried to send a config command that is not supported on the default CC version on EXOS (1.1.x), thus the error message.

CC 3.0 can be found here:
https://github.com/extremenetworks/EXOS_Apps/tree/master/CloudConnector
Userlevel 1
Yes, CC has been updated to version 3.0.34.54

In the Discovered section, I click on the device, click the "Configure Devices" button, and those are the only settings I am attempting to change at this time.
Userlevel 7
Can you enable the logs on ZTP+ to Verbose (XMC side) and paste the relevant part, so that we see the exact issue?

Eventually, if you can access the switch, there's a cc_logs directory on the switch. The files in it can be useful to troubleshoot.

Edit: btw, what EXOS version on the switch?
Userlevel 1
It is running 21.1.4.4 patch1-6. I think I have the problem partially figured out. Looking at the logs on the server, I do see the messages below about configuring certain ports. I went ahead and hard set 29-32 at 10 gig since that is all that can be installed in those ports, and the errors regarding those ports went away. But what are ports 33 and 34 on a X460G2-24t-10G4?

2018-05-02 08:58:21,823 ERROR [com.enterasys.netsight.server.webapps.monitor.ezConfig.MsgDispatcher] ZTP+ configuration failure for device : 1750N
2018-05-02 09:01:48,939 ERROR [com.enterasys.netsight.server.webapps.monitor.ezConfig.MsgDispatcher] ZTP+ event : 1750N : CLI : Command "configure port 29 auto on" failed: CLI command failure:configure port 29 auto on:Error: Speed has to be specified on port 29

2018-05-02 09:01:48,939 ERROR [com.enterasys.netsight.server.webapps.monitor.ezConfig.MsgDispatcher] ZTP+ event : 1750N : CLI : Command "configure port 30 auto on" failed: CLI command failure:configure port 30 auto on:Error: Speed has to be specified on port 30

2018-05-02 09:01:48,939 ERROR [com.enterasys.netsight.server.webapps.monitor.ezConfig.MsgDispatcher] ZTP+ event : 1750N : CLI : Command "configure port 31 auto on" failed: CLI command failure:configure port 31 auto on:Error: Speed has to be specified on port 31

2018-05-02 09:01:48,939 ERROR [com.enterasys.netsight.server.webapps.monitor.ezConfig.MsgDispatcher] ZTP+ event : 1750N : CLI : Command "configure port 32 auto on" failed: CLI command failure:configure port 32 auto on:Error: Speed has to be specified on port 32

2018-05-02 09:01:48,939 ERROR [com.enterasys.netsight.server.webapps.monitor.ezConfig.MsgDispatcher] ZTP+ event : 1750N : CLI : Command "configure port 33 auto on" failed: CLI command failure:configure port 33 auto on:Error: Speed has to be specified on port 33

2018-05-02 09:01:48,940 ERROR [com.enterasys.netsight.server.webapps.monitor.ezConfig.MsgDispatcher] ZTP+ event : 1750N : CLI : Command "configure port 34 auto on" failed: CLI command failure:configure port 34 auto on:Error: Speed has to be specified on port 34
Userlevel 7
do you have a VIM?

Edit: were you trying to change the config of those ports via ZTP+, btw?
Userlevel 1
No, we do not have a VIM and no we were not trying to change the config. Device showed up as discovered, clicked "Configure Device", changed settings on the main "Device" page and clicked Save. Ports are showing up as not present as shown below. Setting then to "Disabled" in Extreme Management Center doesn't resolve the issue either. I guess we'll just pick a random number and see if that allows the process to continue.

Userlevel 7
indeed, you'll have to set the speed/duplex to a discrete value, not auto/auto for all those ports at the moment, I'm afraid.
Stephen and Stephane,

I'm seeing the same error. When I try to enter the command that is failing to a 10GigE port on my X460G2-48p-10G4, I get the following.

Slot-1 LabNet_Core.2 # conf port 1:51 auto on
Error: Speed has to be specified on port 1:51

This is to be expected when you run that command on a 10GigE port, since auto negotiation isn't supported on our 10GigE ports.

Slot-1 LabNet_Core.4 # conf port 1:51 auto on speed 10000 duplex full
Error: Auto negotiation is not supported on port 1:51 at 10G speed

I wonder if this is a ZTP+ bug.

Regards, Scott
Userlevel 7
scott singer wrote:

Stephen and Stephane,

I'm seeing the same error. When I try to enter the command that is failing to a 10GigE port on my X460G2-48p-10G4, I get the following.

Slot-1 LabNet_Core.2 # conf port 1:51 auto on
Error: Speed has to be specified on port 1:51

This is to be expected when you run that command on a 10GigE port, since auto negotiation isn't supported on our 10GigE ports.

Slot-1 LabNet_Core.4 # conf port 1:51 auto on speed 10000 duplex full
Error: Auto negotiation is not supported on port 1:51 at 10G speed

I wonder if this is a ZTP+ bug.

Regards, Scott

It's a known issue on XMC that will be addressed, I double-checked that. XMC sends a speed/duplex of auto/auto by default, and some type of ports don't like that. That's why you need to set that manually at the moment.
scott singer wrote:

Stephen and Stephane,

I'm seeing the same error. When I try to enter the command that is failing to a 10GigE port on my X460G2-48p-10G4, I get the following.

Slot-1 LabNet_Core.2 # conf port 1:51 auto on
Error: Speed has to be specified on port 1:51

This is to be expected when you run that command on a 10GigE port, since auto negotiation isn't supported on our 10GigE ports.

Slot-1 LabNet_Core.4 # conf port 1:51 auto on speed 10000 duplex full
Error: Auto negotiation is not supported on port 1:51 at 10G speed

I wonder if this is a ZTP+ bug.

Regards, Scott

Stephane,

This also appears to be the case with PoE. I have PoE enabled globally in the ZTP+ Device Defaults and ZTP+ seems to be trying to apply it to non-PoE ports.

20793 1525445366930 ZTP+ Events.6.Event --- 1708N-40331 192.168.10.10 Device Event Command "configure inline-power priority low ports 52" response: CLI command failure:configure inline-power priority low ports 52:Error: Port 52 is not inline-power capable

Do you know if this is also included in the known issue that is being addressed?

Thanks, Scott

Reply