LACP ports from B3 vs B5 Enterasys Switch


Userlevel 1
Is there a difference between these two switches when configuring LACP? We replaced a B3 with a B5 switch with identical configuration and the LACP ports appeared to create a loop. The only difference between these two units (besides model) would be the B5 had a newer firmware 06.81.04.0001. Any suggestions would be appreciated.

12 replies

Userlevel 3
Hello,

On B3 switches, we used to have LACP enabled by default on all ports. On B5 switches, we no longer have LACP enabled per port by default, as there were complaints about LAG groups automatically forming when two links were connected between switches.

You will need to turn on LACP on the ports with command "set port lacp port PORT_STRING enable".

Regards,
Ryan Careno
Extreme Networks GTAC
Userlevel 1
Careno, Ryan wrote:

Hello,

On B3 switches, we used to have LACP enabled by default on all ports. On B5 switches, we no longer have LACP enabled per port by default, as there were complaints about LAG groups automatically forming when two links were connected between switches.

You will need to turn on LACP on the ports with command "set port lacp port PORT_STRING enable".

Regards,
Ryan Careno
Extreme Networks GTAC

To confirm, lacp ports would require this command such as:
set port lacp port ge.1.46-48 enable"

Is this correct?
Userlevel 3
Careno, Ryan wrote:

Hello,

On B3 switches, we used to have LACP enabled by default on all ports. On B5 switches, we no longer have LACP enabled per port by default, as there were complaints about LAG groups automatically forming when two links were connected between switches.

You will need to turn on LACP on the ports with command "set port lacp port PORT_STRING enable".

Regards,
Ryan Careno
Extreme Networks GTAC

Mark,

That is correct. B5 configuration does not have that command enabled for the ports like the B3 has. Setting that command should bring the LAG up. You can also verify if LACP packets are being broadcast every 30 seconds on ports with command "show port lacp port ge.1.46-48 counters" and look at the LACPDU TX and RX values for transmitted and received.

Regards,
Ryan Careno
Userlevel 1
Careno, Ryan wrote:

Hello,

On B3 switches, we used to have LACP enabled by default on all ports. On B5 switches, we no longer have LACP enabled per port by default, as there were complaints about LAG groups automatically forming when two links were connected between switches.

You will need to turn on LACP on the ports with command "set port lacp port PORT_STRING enable".

Regards,
Ryan Careno
Extreme Networks GTAC

Thanks Ryan. I believe that will resolve the issue. Also much appreciated for the prompt reply.
Userlevel 4
Mark,

The short answer is that they should be almost identical. Depending on what has changed in firmware of course.

Can you post the lacp and port configurations from each?
show port status for the lag port and underlying physical ports
show lacp lag.0.x
show lacp groups
Userlevel 4
Daniel Coughlin wrote:

Mark,

The short answer is that they should be almost identical. Depending on what has changed in firmware of course.

Can you post the lacp and port configurations from each?
show port status for the lag port and underlying physical ports
show lacp lag.0.x
show lacp groups

and the spanning tree configuration
Userlevel 1
Daniel Coughlin wrote:

Mark,

The short answer is that they should be almost identical. Depending on what has changed in firmware of course.

Can you post the lacp and port configurations from each?
show port status for the lag port and underlying physical ports
show lacp lag.0.x
show lacp groups

Thanks. Here is the lacp and port configs on the existing B3 switch which match the new B5 switch.

set lacp aadminkey lag.0.1 10

set port lacp port ge.1.46 aadminkey 10

set port lacp port ge.1.47 aadminkey 10

set port lacp port ge.1.48 aadminkey 10

set port vlan ge.1.1-45 520

Port Status
ge.1.1 Down Up N/A N/A BaseT RJ45
ge.1.2 Up Up 100.0M full BaseT RJ45
ge.1.3 Up Up 100.0M full BaseT RJ45
ge.1.4 Up Up 100.0M full BaseT RJ45
ge.1.5 Up Up 100.0M full BaseT RJ45
ge.1.6 Up Up 100.0M full BaseT RJ45
ge.1.7 Up Up 100.0M full BaseT RJ45
ge.1.8 Up Up 100.0M full BaseT RJ45
ge.1.9 Up Up 10.0M half BaseT RJ45
ge.1.10 Up Up 10.0M half BaseT RJ45
ge.1.11 Up Up 10.0M half BaseT RJ45
ge.1.12 Up Up 10.0M half BaseT RJ45
ge.1.13 Up Up 10.0M half BaseT RJ45
ge.1.14 Up Up 10.0M half BaseT RJ45
ge.1.15 Up Up 10.0M half BaseT RJ45
ge.1.16 Up Up 10.0M half BaseT RJ45
ge.1.17 Up Up 10.0M half BaseT RJ45
ge.1.18 Down Up N/A N/A BaseT RJ45
ge.1.19 Down Up N/A N/A BaseT RJ45
ge.1.20 Down Up N/A N/A BaseT RJ45
ge.1.21 Down Up N/A N/A BaseT RJ45
ge.1.22 Down Up N/A N/A BaseT RJ45
ge.1.23 Down Up N/A N/A BaseT RJ45
ge.1.24 Down Up N/A N/A BaseT RJ45
ge.1.25 Down Up N/A N/A BaseT RJ45
ge.1.26 Down Up N/A N/A BaseT RJ45
ge.1.27 Down Up N/A N/A BaseT RJ45
ge.1.28 Down Up N/A N/A BaseT RJ45
ge.1.29 Down Up N/A N/A BaseT RJ45
ge.1.30 Down Up N/A N/A BaseT RJ45
ge.1.31 Down Up N/A N/A BaseT RJ45
ge.1.32 Down Up N/A N/A BaseT RJ45
ge.1.33 Down Up N/A N/A BaseT RJ45
ge.1.34 Down Up N/A N/A BaseT RJ45
ge.1.35 Down Up N/A N/A BaseT RJ45
ge.1.36 Down Up N/A N/A BaseT RJ45
ge.1.37 Down Up N/A N/A BaseT RJ45
ge.1.38 Down Up N/A N/A BaseT RJ45
ge.1.39 Down Up N/A N/A BaseT RJ45
ge.1.40 Down Up N/A N/A BaseT RJ45
ge.1.41 Down Up N/A N/A BaseT RJ45
ge.1.42 Down Up N/A N/A BaseT RJ45
ge.1.43 Down Up N/A N/A BaseT RJ45
ge.1.44 Down Up N/A N/A BaseT RJ45
ge.1.45 Down Up N/A N/A Combo RJ45/SFP
ge.1.46 dormant Up 1.0G full Combo RJ45/SFP
ge.1.47 dormant Up 1.0G full Combo RJ45/SFP
ge.1.48 dormant Up 1.0G full Combo RJ45/SFP
lag.0.1 Up Up 3.0G full lag
lag.0.2 Down Up lag
lag.0.3 Down Up lag
lag.0.4 Down Up lag
lag.0.5 Down Up lag
lag.0.6 Down Up lag

B3(su)->show lacp lag.0.1
Global Link Aggregation state: enabled
Single Port LAGs: disabled

Aggregator: lag.0.1
Actor Partner
System Identifier: 00:1F:45:44:8B:28 00:1F:45:9E:72:FC
System Priority: 32768 32768
Admin Key: 10
Oper Key: 10 10
Attached Ports: ge.1.46
ge.1.47
ge.1.48

B3(su)->show lacp groups
LACP groups supported 6

As stated earlier, the B5 config file matches this B3 identically. When the B5 powered up, it appeared to create a loop and started taking down other network segments. We powered down the B5 switch and all network services returned to normal.

Your thoughts are appreciated.
Hi Mark.

One question, wich vlan are configured the ports ge.1.46-48? Another question did you configure in both switches "set lacp singleportlag enable"?

Regards,

Paulo Mauricio
Userlevel 1
Hi Paulo. Have configured a host vlan and a vlan for voip both tagged on ge.1.46-48 which matches our B3 config. Also noticed on the B3, the "Single Port LAGs" are disabled. Would they need to be enabled on the B5?

I believe the command "set port lacp port ge.1.46-48 enable" on the earlier post should resolve our loop issue but would like to confirm that we would or would not require to enable the "set lacp singleportlag" command.
Userlevel 3
Mark Robinson wrote:

Hi Paulo. Have configured a host vlan and a vlan for voip both tagged on ge.1.46-48 which matches our B3 config. Also noticed on the B3, the "Single Port LAGs" are disabled. Would they need to be enabled on the B5?

I believe the command "set port lacp port ge.1.46-48 enable" on the earlier post should resolve our loop issue but would like to confirm that we would or would not require to enable the "set lacp singleportlag" command.

The command "set lacp singleportlag enable" is only needed when we are initially trying to form the lag with a single port, with the intention to add a second port later down the line. Without this enabled, it would require two ports to link up for the lag to form. The behavior of singleportlag is only applicable to creation of the lag, not the operational aspect of it.

If you have singleportlag disabled, form a two port lag, and one of the cables gets disconnected, the lag will still stay operational on the single port even with singleportlag disabled.

Regards,
Ryan Careno
Userlevel 1
Mark Robinson wrote:

Hi Paulo. Have configured a host vlan and a vlan for voip both tagged on ge.1.46-48 which matches our B3 config. Also noticed on the B3, the "Single Port LAGs" are disabled. Would they need to be enabled on the B5?

I believe the command "set port lacp port ge.1.46-48 enable" on the earlier post should resolve our loop issue but would like to confirm that we would or would not require to enable the "set lacp singleportlag" command.

Paulo. Thanks for clarifying the singleportlag. Cheers to you and your team.
Mark Robinson wrote:

Hi Paulo. Have configured a host vlan and a vlan for voip both tagged on ge.1.46-48 which matches our B3 config. Also noticed on the B3, the "Single Port LAGs" are disabled. Would they need to be enabled on the B5?

I believe the command "set port lacp port ge.1.46-48 enable" on the earlier post should resolve our loop issue but would like to confirm that we would or would not require to enable the "set lacp singleportlag" command.

Thks Ryan for explanation. I thinked singleportlag was in case link dow, and only one link still up.

Regards

Paulo Maurício

Reply