null ARP table on a C5 stack


I have a stack composed of 2 C5 series with F/W Fw:06.71.03.0025

It's some day that I'm experiencing networks problems (hosts becoming unreachable and getting back online after a random time)

The only strange thing that I've noticed is that the "show arp" command returns null adrresses

C5(su)->show arp
LINK LEVEL ARP TABLE
IP Address Phys Address Flags Interface
---------------------------------------------------------
10.104.2.14 00-00-00-00-00-00 host
10.101.2.226 00-00-00-00-00-00 host
10.101.2.241 00-00-00-00-00-00 host
10.101.3.92 00-00-00-00-00-00 host
10.101.50.5 00-00-00-00-00-00 host
10.103.2.134 00-00-00-00-00-00 host
10.103.10.11 00-00-00-00-00-00 host
---------------------------------------------------------

Any idea on what caused/how to fix this ?

Thank you

Omar Valente

9 replies

Is the switch routing?
Yes it is
Any update for this. Getting the same issue.
long story short. My issue was with some card readers with non standard behaviour on the net. these devices somehow were getting flushed from the switch mac address table but were still present on the ARP table (and since they were on the arp table no flood was taken to find them). Lowering the ARP table agetime to value much smaller than the switch SAT table solved the problem

Omar Valente
Thx for that. Not sure if this is related. My switch does do routing. Under the routing interface I see the ARP table populated as per normal but the switch ARP table I get null values like yourself.

My question is - does the switch ARP table affect the routing ARP table?
For what I have been understanding that's normal when the switch is doing routing too

Omar Valente
If it is a router then go in "router"-Modus:

C5(su)->router

C5(su)->router>enable

C5(su)->router#Show ip arp
Hello, it seems that we have similary problems. Could you solved your problem ?

We although have a stacked C5 Coreswitch with Routing functions, Vers Fw:06.71.05.0008

We see in some vlans the same issue, some hosts are not reachable for an undefined time from other vlans. In the router arp, the host are still registerd, int the switch mac table they are missing. After a ping from the router the the hosts , they are reachable again. from all other vlans.
It seems, that the switch do not forward arp request or renew his own mac address table.

Next Step will be a SW upgrade
Robert: I had to set a a very short age time for the mac table.... I had to set it to like 15 seconds to prevent this from happeining. This caused an higher CPU consumption but that was not an issue for me.

Hope it Helps

Omar Valente

Reply