Header Only - DO NOT REMOVE - Extreme Networks

pelco cctv multicasting problem


Hello i have trouble with seting up multicasting in my X440-X460 switches. I can ping every device in network, but Video is not showing under my WorkStation or isnt recorded. I have run wireshark on my Workstation sniffing for multicast trafic but no trafic was found. How to diagnose this situation. (Windows firewal is diabled)

Run Wireshark on the workstation affected.
Click Capture > Interfaces > Place a check mark next the Endura NIC > Click Start > Let the capture run for a minute > Click Stop.
In the display filter type udp.dstport==2901 then click Apply.
If the workstation is receiving multicast traffic from the System Manager your output will look like the sample below. If it does not contact your network administrator.
http://buildingskb.schneider-electric.com/casefiles/12770/udp.dstport.2901.png



Network topology



Bud_1-X460.2 # show port utilization bandwidth Port Link Link Rx Peak Rx Tx Peak Tx State Speed % bandwidth % bandwidth % bandwidth % bandwidth ================================================================================ 1 A 100 0.00 0.00 0.00 0.02 2 A 100 0.00 0.00 0.00 0.02 3 A 100 0.00 0.00 0.00 0.02 4 A 100 0.00 0.00 0.00 0.02 5 R 0 0.00 0.00 0.00 0.00 6 A 100 0.00 0.00 0.00 0.02 7 A 100 0.00 0.02 0.00 0.01 8 A 1000 0.00 0.00 0.00 0.00 9 A 100 0.80 0.80 0.00 0.01 10 A 1000 0.40 0.40 0.00 0.00 11 A 100 1.39 1.76 0.01 0.01 12 A 100 1.33 1.33 0.00 0.01 13 A 1000 0.00 0.22 2.88 2.88 14 A 1000 0.30 0.45 0.00 0.00 15 A 1000 0.00 0.01 0.00 0.54 16 A 100 4.54 6.36 0.00 8.77 17 R 0 0.00 0.00 0.00 0.00 18 R 0 0.00 0.00 0.00 0.00 19 R 0 0.00 0.00 0.00 0.00 20 A 1000 0.00 0.00 0.00 0.00 21 R 0 0.00 0.00 0.00 0.00 22 R 0 0.00 0.00 0.00 0.00 23 R 0 0.00 0.00 0.00 0.00 24 R 0 0.00 0.00 0.00 0.00 25 A 1000 1.91 1.91 0.00 0.02 26 R 0 0.00 0.00 0.00 0.00 27 R 0 0.00 0.00 0.00 0.00 28 R 0 0.00 0.00 0.00 0.00 29 NP 0 0.00 0.00 0.00 0.00 30 NP 0 0.00 0.00 0.00 0.00 ================================================================================ > indicates Port Display Name truncated past 8 characters Link State: A-Active, R-Ready, NP-Port Not Present, L-Loopback [/code]

Hints from Pelco:
  1. Does the selected switch support an appropriate number of Internet Group Management Protocol (IGMP) entries for the installation? It is important not to exceed the number of IGMP entries the switch can handle, because it will either block multicast traffic or flood multicast traffic when these limits are exceeded.

Bud_21-X440.16 # show config # # Module devmgr configuration. # configure snmp sysName "Bud_21-X440" configure sys-recovery-level switch reset # # Module vlan configuration. # configure vlan default delete ports all configure vr VR-Default delete ports 1-24 configure vr VR-Default add ports 1-24 configure vlan default delete ports 1-24 create vlan "managment2" configure vlan managment2 tag 100 create vlan "v1-KD" configure vlan v1-KD tag 10 create vlan "v3-CCTV" configure vlan v3-CCTV tag 30 create vlan "v4-SCADA" configure vlan v4-SCADA tag 40 configure vlan managment2 add ports 23-24 tagged configure vlan managment2 add ports 20 untagged configure vlan v1-KD add ports 23-24 tagged configure vlan v1-KD add ports 1-4 untagged configure vlan v3-CCTV add ports 23-24 tagged configure vlan v3-CCTV add ports 5-16 untagged configure vlan Mgmt ipaddress 192.168.10.21 255.255.255.0 # # Module fdb configuration. # # # Module rtmgr configuration. # # # Module mcmgr configuration. # # # Module aaa configuration. # configure account admin encrypted "w57pp4$GwwfA/PzMpfpfYS0fq3XK0" Press to continue or to quit: # # Module acl configuration. # # # Module bfd configuration. # # # Module ces configuration. # # # Module cfgmgr configuration. # # # Module dosprotect configuration. # Press to continue or to quit: # # Module dot1ag configuration. # # # Module eaps configuration. # # # Module edp configuration. # # # Module elrp configuration. # # # Module ems configuration. # # # Module epm configuration. # # # Module erps configuration. # # # Module esrp configuration. # # # Module ethoam configuration. # # # Module etmon configuration. # # # Module hal configuration. # # # Module idMgr configuration. # # # Module ipSecurity configuration. # # # Module ipfix configuration. # # # Module lldp configuration. # # # Module mrp configuration. # # # Module msdp configuration. # # # Module netLogin configuration. # # # Module netTools configuration. # # # Module poe configuration. # # # Module rip configuration. # # # Module r.png configuration. # # # Module snmpMaster configuration. # # # Module stp configuration. # configure mstp region 00049698acd8 configure stpd s0 delete vlan default ports all disable stpd s0 auto-bind vlan default enable stpd s0 auto-bind vlan Default # # Module synce configuration. # # # Module telnetd configuration. # # # Module tftpd configuration. # # # Module thttpd configuration. # enable web http # # Module vmt configuration. # # # Module vsm configuration. # [/code]

6 replies

Userlevel 7
Hi Piotr,

Just to confirm, your PC isn't receiving the 239.255.255.250 stream?

What is sending this stream out? Is it in the same VLAN as your PC?

-Brandon
Brandon Clay wrote:

Hi Piotr,

Just to confirm, your PC isn't receiving the 239.255.255.250 stream?

What is sending this stream out? Is it in the same VLAN as your PC?

-Brandon

This immage with ip 239.255.255.250 is sample output from wireshark runing workstation when switch is streaming multicast packets from camera to Workstation. In my case output from wireshark is blank.. so my configuration is wrong. All devices are in one VLAN "v3-CCTV". All switches are runing IGMP Snooping but: - Switch1 doesn't see multicast group from Switch2 and Switch3. - Switch2 doesn't see multicast group from Switch1 an Switch3. - Switch3 doesnt see multicast group from Switch1 and Switch2 How to make my switch1 to see multicast groups from switch2 and switch3? Im reading about something called IGMP Querier, is there something like this in Summit X440 or X460?
Userlevel 7
Brandon Clay wrote:

Hi Piotr,

Just to confirm, your PC isn't receiving the 239.255.255.250 stream?

What is sending this stream out? Is it in the same VLAN as your PC?

-Brandon

Is there an IP address on any of the switches in VLAN 'v3-CCTV'? If so, IGMP query is enabled by default in EXOS and there should be a querier. You can confirm this with the command 'show igmp vlan v3-CCTV'.

Are the links between the switches configured to have the v3-CCTV vlan on them?
Userlevel 7
Brandon Clay wrote:

Hi Piotr,

Just to confirm, your PC isn't receiving the 239.255.255.250 stream?

What is sending this stream out? Is it in the same VLAN as your PC?

-Brandon

Glad to hear you were able to get this worked out Piotr!
Userlevel 6
Couple of observations and questions. If you have igmp snooping enabled the switch will prune back all the mcast streams till it sees a join from your pc.

Each Camera should also have it's own ip and mcast address. If you do a show igmp snoop detail on the switch you should see all the mcast senders (cameras) and what mcast address they are using. This would also tell you if the camera was actually transmitting out a mcast stream.

Your PC would need to do a join for each of the cameras you wish to record and watch.

Each of those ports that are hooked up to a camera should be receiving xxx bandwidth all the time if the camera is working.

You could also create a mirror port and add one of the camera's ports or the vlan and do your sniff from that port to see what the camera's are sending out.

Good luck
Problem solved! Thanks! Any switch hasn't configured IP so i think there wasn't anyone to send query. So i run under switch1 this command and everything works like charm!

configure vlan "v3-CCTV" ipaddress 192.168.3.254 255.255.255.0[/code]

before ip configuration:
Bud_1-X460.2 # show igmp vlan "v3-CCTV"Interface on VLAN v3-CCTV is enabled and up.
inet 0.0.0.0/0
Locally registered multicast addresses:
Learned multicast addresses(Last Querier=0.0.0.0):
239.168.3.37 239.168.3.41 239.168.3.42
239.168.3.43 239.168.3.50 239.168.3.60
239.168.3.62 239.168.3.7 239.168.3.8
239.168.3.16
s = static igmp member
Flags:
IP Fwding NO IPmc Fwding NO IGMP YES
IGMP Ver V2 Snooping YES Proxy Query YES
XmitRtrAlrt YES RcvRtrAlrtReq NO
and after configuration:

Bud_1-X460.6 # show igmp vlan "v3-CCTV"Interface on VLAN v3-CCTV is enabled and up.
inet 192.168.3.254/24
Locally registered multicast addresses:
224.0.0.2 224.0.0.22
Learned multicast addresses(Last Querier=192.168.3.254):
239.168.3.37 239.168.3.38 239.168.3.41
230.10.10.8 239.168.3.42 239.168.3.43
239.168.3.44 239.168.3.45 239.168.3.46
239.168.3.47 239.168.3.48 239.168.3.49
239.168.3.50 239.168.3.60 239.168.3.62
239.168.3.7 239.168.3.8 239.168.3.16
239.255.255.250 224.0.0.252
s = static igmp member
Flags:
IP Fwding NO IPmc Fwding NO IGMP YES
IGMP Ver V2 Snooping YES Proxy Query YES
XmitRtrAlrt YES RcvRtrAlrtReq NO

Reply