Header Only - DO NOT REMOVE - Extreme Networks
Question

Port channel between x440g2 48 p and cisco cat 6500


Userlevel 1
i have configured port channel on my cisco and extreme switch but when i connect the interfaces the port channel doesnt come up not sure what i am doing wrong here. please see configuration

CISCO CONFIG
------------------------------------------------------------------------------------------

interface Port-channel2
description 7th Floor Copper Trunk Uplinks
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-14,16-20,24-29,31-4094
switchport mode trunk
bandwidth 4096000
no ip address
logging event link-status
logging event spanning-tree status
logging event bundle-status
logging event trunk-status
load-interval 30
snmp ifindex persist
mls qos trust cos
spanning-tree portfast trunk
spanning-tree link-type point-to-point
end

interface range GigabitEthernet2/11 - 12
description 7th Floor Copper Uplink 1
switchport
switchport trunk allowed vlan 1-14,16-20,24-29,31-4094
switchport mode trunk
no ip address
logging event link-status
logging event spanning-tree status
logging event bundle-status
logging event trunk-status
load-interval 30
keepalive 30
mls qos trust cos
spanning-tree portfast trunk
spanning-tree link-type point-to-point
channel-protocol pagp
channel-group 2 mode desirable
end

EXOS CONFIG
-------------------------------------------------------------------------------------------------
enable sharing 1:2 grouping 1:2,3:48 algorithm address-based L2

sh sharing detail
Load Sharing Monitor
Config Current Agg Min Ld Share Dist Ld Share Agg Link Link Up
Master Master Control Active Algorithm Flags Group Mbr State Transitions
================================================================================
1:2 1:2 Static 1 L2 A 1:2 Y A 5
L2 3:48 - R 1
==============================================================================

12 replies

Userlevel 1
Hi,

Pagp is a Cisco proprietary protocol it is not support by any other vendor, you need to configure the Cisco with LACP.

Regards
Userlevel 2
Lutha,
please note if you need to configure the exos side for lacp as well as it looks like it is currently setup as a static lag

the following article should be able to help you achieve this:
https://gtacknowledge.extremenetworks.com/articles/How_To/how-to-configure-sharing-LAG-LACP-in-Summi...

Regards,
Userlevel 1
HI Guys

I have tried below configuration and port channel still doesnt work
================================================================

interface Port-channel 3
description 7th Floor Copper Trunk Uplinks
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-14,16-20,24-29,31-4094
switchport mode trunk
bandwidth 4096000
no ip address
logging event link-status
logging event spanning-tree status
logging event bundle-status
logging event trunk-status
load-interval 30
snmp ifindex persist
mls qos trust cos
spanning-tree portfast trunk
spanning-tree link-type point-to-point
end

interface range GigabitEthernet3/7 - 8
description 7th Floor Copper Uplink 3
switchport
switchport trunk allowed vlan 1-14,16-20,24-29,31-4094
switchport mode trunk
no ip address
logging event link-status
logging event spanning-tree status
logging event bundle-status
logging event trunk-status
load-interval 30
keepalive 30
mls qos trust cos
spanning-tree link-type point-to-point
channel-group 3 mode active
end

on extreme side
enable sharing 1:2 grouping 1:2,3:48 algorithm address-based L2 lacp

m at my wits end now m not sure where i go wrong

Can a member kindly share their port channel configs between cisco device and extreme.

Thanks
Userlevel 2
Would this perhaps be the issue? https://gtacknowledge.extremenetworks.com/articles/Solution/LACP-incompatibity-between-extreme-and-c...
Userlevel 1
I have checked the logs and theres no error like this

LACPDU. Actor: System ID 0x0000, 00-04-96-44-05-d0; Key 0x0efd; Port ID 0x0000, 0x0fea; State 0x0d. Partner: System ID 0x8000, ca-fe-22-42-be-ef; Key 0x0001; Port ID 0x8000, 0x0001; State 0x04. Collector: Max delay 0.

or any error to do with port-channeling

only message i see in logs is the below

12/19/2017 17:58:06.54 [i] Slot-1: Port 3:48 link down
12/19/2017 17:57:10.14 [i] Slot-1: Port 1:2 is UP with speed 1000, Add to aggregator 1:2 with speed: 1000
12/19/2017 17:57:10.14 [i] Slot-1: Port 1:2 link UP at speed 1 Gbps and full-duplex
12/19/2017 17:56:47.69 [i] Slot-1: Port 3:48 is UP with speed 1000, Add to aggregator 1:2 with speed: (down)
12/19/2017 17:56:47.69 [i] Slot-1: Port 3:48 link UP at speed 1 Gbps and full-duplex
12/19/2017 17:56:37.49 [i] Slot-1: Port 3:48 is Down, remove from aggregator 1:2
12/19/2017 17:56:37.49 [i] Slot-1: Port 3:48 link down
12/19/2017 17:41:27.45 [i] Slot-1: Port 3:48 is UP with speed 1000, Add to aggregator 1:2 with speed: (down)
12/19/2017 17:41:27.45 [i] Slot-1: Port 3:48 link UP at speed 1 Gbps and full-duplex

A few seconds after plugging the second port the switch starts to slow down in between commands as soon as i disable the port the switch runs normally again
Userlevel 2
Lutha wrote:

I have checked the logs and theres no error like this

LACPDU. Actor: System ID 0x0000, 00-04-96-44-05-d0; Key 0x0efd; Port ID 0x0000, 0x0fea; State 0x0d. Partner: System ID 0x8000, ca-fe-22-42-be-ef; Key 0x0001; Port ID 0x8000, 0x0001; State 0x04. Collector: Max delay 0.

or any error to do with port-channeling

only message i see in logs is the below

12/19/2017 17:58:06.54 [i] Slot-1: Port 3:48 link down
12/19/2017 17:57:10.14 [i] Slot-1: Port 1:2 is UP with speed 1000, Add to aggregator 1:2 with speed: 1000
12/19/2017 17:57:10.14 [i] Slot-1: Port 1:2 link UP at speed 1 Gbps and full-duplex
12/19/2017 17:56:47.69 [i] Slot-1: Port 3:48 is UP with speed 1000, Add to aggregator 1:2 with speed: (down)
12/19/2017 17:56:47.69 [i] Slot-1: Port 3:48 link UP at speed 1 Gbps and full-duplex
12/19/2017 17:56:37.49 [i] Slot-1: Port 3:48 is Down, remove from aggregator 1:2
12/19/2017 17:56:37.49 [i] Slot-1: Port 3:48 link down
12/19/2017 17:41:27.45 [i] Slot-1: Port 3:48 is UP with speed 1000, Add to aggregator 1:2 with speed: (down)
12/19/2017 17:41:27.45 [i] Slot-1: Port 3:48 link UP at speed 1 Gbps and full-duplex

A few seconds after plugging the second port the switch starts to slow down in between commands as soon as i disable the port the switch runs normally again

Sounds like a loop and the port channel isn't working. I noticed on port 3 on the cisco you don't have this command: channel-group 3 mode active. Does that command need to be on that interface?
Userlevel 1
Lutha wrote:

I have checked the logs and theres no error like this

LACPDU. Actor: System ID 0x0000, 00-04-96-44-05-d0; Key 0x0efd; Port ID 0x0000, 0x0fea; State 0x0d. Partner: System ID 0x8000, ca-fe-22-42-be-ef; Key 0x0001; Port ID 0x8000, 0x0001; State 0x04. Collector: Max delay 0.

or any error to do with port-channeling

only message i see in logs is the below

12/19/2017 17:58:06.54 [i] Slot-1: Port 3:48 link down
12/19/2017 17:57:10.14 [i] Slot-1: Port 1:2 is UP with speed 1000, Add to aggregator 1:2 with speed: 1000
12/19/2017 17:57:10.14 [i] Slot-1: Port 1:2 link UP at speed 1 Gbps and full-duplex
12/19/2017 17:56:47.69 [i] Slot-1: Port 3:48 is UP with speed 1000, Add to aggregator 1:2 with speed: (down)
12/19/2017 17:56:47.69 [i] Slot-1: Port 3:48 link UP at speed 1 Gbps and full-duplex
12/19/2017 17:56:37.49 [i] Slot-1: Port 3:48 is Down, remove from aggregator 1:2
12/19/2017 17:56:37.49 [i] Slot-1: Port 3:48 link down
12/19/2017 17:41:27.45 [i] Slot-1: Port 3:48 is UP with speed 1000, Add to aggregator 1:2 with speed: (down)
12/19/2017 17:41:27.45 [i] Slot-1: Port 3:48 link UP at speed 1 Gbps and full-duplex

A few seconds after plugging the second port the switch starts to slow down in between commands as soon as i disable the port the switch runs normally again

the port-channel does not take the command. the command is applied to the individual ports the will be joining the port channel which is nterface range GigabitEthernet3/7 - 8
Userlevel 7
Lutha wrote:

I have checked the logs and theres no error like this

LACPDU. Actor: System ID 0x0000, 00-04-96-44-05-d0; Key 0x0efd; Port ID 0x0000, 0x0fea; State 0x0d. Partner: System ID 0x8000, ca-fe-22-42-be-ef; Key 0x0001; Port ID 0x8000, 0x0001; State 0x04. Collector: Max delay 0.

or any error to do with port-channeling

only message i see in logs is the below

12/19/2017 17:58:06.54 [i] Slot-1: Port 3:48 link down
12/19/2017 17:57:10.14 [i] Slot-1: Port 1:2 is UP with speed 1000, Add to aggregator 1:2 with speed: 1000
12/19/2017 17:57:10.14 [i] Slot-1: Port 1:2 link UP at speed 1 Gbps and full-duplex
12/19/2017 17:56:47.69 [i] Slot-1: Port 3:48 is UP with speed 1000, Add to aggregator 1:2 with speed: (down)
12/19/2017 17:56:47.69 [i] Slot-1: Port 3:48 link UP at speed 1 Gbps and full-duplex
12/19/2017 17:56:37.49 [i] Slot-1: Port 3:48 is Down, remove from aggregator 1:2
12/19/2017 17:56:37.49 [i] Slot-1: Port 3:48 link down
12/19/2017 17:41:27.45 [i] Slot-1: Port 3:48 is UP with speed 1000, Add to aggregator 1:2 with speed: (down)
12/19/2017 17:41:27.45 [i] Slot-1: Port 3:48 link UP at speed 1 Gbps and full-duplex

A few seconds after plugging the second port the switch starts to slow down in between commands as soon as i disable the port the switch runs normally again

You would see log messages about an invalid LACP system ID on the Cisco switch, not the Extreme switch.
Userlevel 1
Is there another method of acheiving this between cisco and extreme
Userlevel 7
Lutha wrote:

Is there another method of acheiving this between cisco and extreme

Since the switches slow down after activating both links there seems to be a significant problem, thus if you try to use a static LAG, you would probably make the situation worse.
Userlevel 1
Hi Lutha

This is what i have on my switches and the port channel works

on cisco side:
interface Port-channel20 description SCPDA010200 switchport switchport trunk native vlan 999 switchport trunk allowed vlan 100,113,201,300,400,501,601,613,1000,1200 switchport mode trunk logging event link-status storm-control broadcast include multicast storm-control broadcast level 2.00 spanning-tree guard loop ip dhcp snooping trust end [/code]interface TenGigabitEthernet1/14
description SCPDAA010200 3:49
switchport trunk native vlan 999
switchport trunk allowed vlan 100,113,201,300,400,501,601,613,1000,1200
switchport mode trunk
logging event link-status
storm-control broadcast include multicast
storm-control broadcast level 2.00
channel-group 20 mode active
spanning-tree guard loop
ip dhcp snooping trust
end [/code]interface TenGigabitEthernet1/13
description SCPDAA010200 2:49
switchport trunk native vlan 999
switchport trunk allowed vlan 100,113,201,300,400,501,601,613,1000,1200
switchport mode trunk
logging event link-status
storm-control broadcast include multicast
storm-control broadcast level 2.00
channel-group 20 mode active
spanning-tree guard loop
ip dhcp snooping trust
end[/code]
on Extreme side:
enable sharing 2:49 grouping 2:49,3:49 algorithm address-based L2 lacp [/code]If you are using fiber you should configure the guard loop also by default on MSTP and RSTP the link types are point-to-point.

Hope this helps

Regards
Userlevel 7
Hi Lutha,

you should verify that the links are connected the way you want. You could enable LLDP on both the Cisco and Extreme switches, enable just one of the links, and then verify LLDP neighbors on both switches, and verify LACP information received on both switches.

Then you disable this port again and enable the other port. There you perform the same checks.

After that you closely examine the the LLDP and LACP information, as well as the logs of both switches, if everything is OK.

Since you seem to be using STP, you should verify STP operation as well.

Your configuration looks OK on first glance, I have not yet experienced problems with LACP between Cisco IOS and EXOS switches. Thus I'd say you need to dig deeper to find the root cause.

Thanks,
Erik

Reply