Question

Auto Negotiation after Upgrade to 22.5.1.7-patch1-7

  • 6 August 2019
  • 1 reply
  • 121 views

The scenario:
We are currently running 21.1.3.7-patch1-7 on our Summit x460-G2 endpoint switches. We use third party 10 Gb SM GBICs which currently are running using auto ON.
After upgrading to 22.5.1.7-patch1-7 the port is disabled and there is a message in the log:

Warn:HAL.Port.OpticCfgCflct> Slot-1: The configuration for the SF+_LR optic module is not correct - please configure port 1:52 for auto-negotiation Off and speed 10000

I have two questions.
  1. Is this normal, expected behavior?
  2. Is there a best practice way to set this prior to upgrading?
We use sharing on our uplink ports and you need to first disable sharing before you can change the auto mode for a port. So the manual method right now is:
  • Disable sharing for the port
  • Change the auto mode to speed 10000 duplex full
  • Enable sharing again
I had thought of using a UPM script with a time trigger. Setting the auto off seems to not impact the switch while it is running the older firmware.

1 reply

From my experience:
  1. Yes, i experienced this before. One-timer when booting. From my experience setting to on can be a problem in 21.X too, although I never saw I real disable, only a port not working.
  2. One possibility: You could save the config as default.xsf, change it there and do an "unconfigure switch" (reboot of the switch!). Most time it works perfectly, but there is also a change it goes wrong. So have a console access.
I would not recommend an upm script. If something goes wrong you have a longer offline-time.

Reply