BGP community not being sent


not showing the /32 being advertise but the other /24 in seq 20 are being advertised whats missing for the /32 to be sent out ?

configure bgp add network 31.91.192.143 255.255.255.255
create access-profile blackholes type ipaddress

configure access-profile blackholes add 10 ipaddress 31.91.192.143 /32 exact

configure route-map xo-rm add 10 permit
configure route-map xo-rm 10 add match nlri-list blackholes
configure route-map xo-rm 10 add set community 2828 : 1650
configure route-map xo-rm add 20 permit
configure route-map xo-rm 20 add match nlri-list level3-net

conf bgp neighbor 202.112.52.105 route-map-filter out xo-rm
configure bgp neighbor 202.112.52.105 send-community

show transmitted routes show all the /24 but not the /32 with the set community whats missing here ?

15 replies

Userlevel 1
Hi Joseph,
I think you pasted cisco config.

I EXOS if you want add & send blackhole route through BGP you need to add the blackhole route
through CLI .
Please do the below mentioned steps.

1.Add CLI "configure iproute add blackhole 10.0.0.1/32 .
2.Create a policy then add set community "2828 : 1650".
3.Mpa the policy through network command.
4.configure bgp add network 10.0.0.1/32 network-policy ext2
5.In BGP config you need to add configure bgp neighbor [i] send-community both.
I think you missed this.
For extended community we need to mention this command or we need to add send-community extended.
By default EXOs will send standard communuity alone.

* (Engineering) X670G2-72x.256 # sh bgp neighbor 50.0.0.2 transmitted-routes detail all
Advertised Routes:
Route: 10.0.0.1/32, Active
Origin IGP, Next-Hop 50.0.0.1, MED 0
As-PATH: 1
Community: 185337458

Hope this helps.

-Senthil.M
hi thank you for the answer this is extremeWare 7.2 configuration ,
1 cant add blackhole on the /32 i get an error "IP" is directly attached to local subnet (255.255.255.255)its part of the vlan
2 configure route-map xo-rm 10 add set community 2828 : 1650
3 added the policy via "conf bgp add network 31.91.192.143/32 xo-rm "
4
5 no BOTH is avaiable on 7.2 we got " conf bgp neighbor 202.112.52.105 send-community

only change is the mapping on number 3 , and its still not seem to be sending the /32 after soft-reset out
thanks in advanace for the help
Userlevel 1
Hello Joseph,

Can you please try this config in CLI mode.
Meanwhile I will try to get help for extreme ware configuration.

-Senthil.M
whats cli mode ? and what config should i try ? what i pasted is what i have in
Userlevel 1
Hello Joseph,

Sorry for the confusion.
CLI mode is the one which you are working now.
I just confirmed these commands are older version & its updated now.
Extremeware product also goes end of life.

As per your command we need not to go for extended communities/both command.
I guess extended communities is not available in extremeware 7.0.

Can you please try with these command alone & check whether its working.

configure route-map xo-rm 10 add set community 2828 : 1650
conf bgp add network 31.91.192.143/32 xo-rm
conf bgp neighbor 202.112.52.105 send-community

-Senthil.M
hi senthil
here is the config i have already in ,what i do see is the second route-map seq is being advertised all the /24 are there but seq 10 with the /32 and the set community is not , comparing this to cisco we do miss a NULL0 route on the /32 but when trying to add blackhole iproute on the /32 i get an error that its part of the vlan , so maybe the fix is adding another type of null route on the /32 ?

configure route-map xo-rm add 10 permit
configure route-map xo-rm 10 add match nlri-list blackholes
configure route-map xo-rm 10 add set community 2828 : 1650
configure route-map xo-rm add 20 permit
configure route-map xo-rm 20 add match nlri-list level3-net

configure bgp add network 38.96.190.143 255.255.255.255 xo-rm
configure bgp neighbor 207.110.52.105 send-community

create access-profile "blackholes" type ipaddress
configure access-profile "blackholes" add 10 permit ipaddress 38.96.190.143/32 exact
configure access-profile "blackholes" add 15 permit ipaddress 66.246.45.6/32 exact

thank you
Userlevel 1
Hi,
I'm not sure about this config.
After adding "66.246.45.6/32" whether BGP send 38.96.190.143/32 with community to its peer.?

-Senthil.M
no it doesnt ,transmitted routes shows only the /24 which are the seq 20 on the route map but not the /32 can i email the whole config for you to look at
Userlevel 7
ExtremeWare 7.2 is very old software. This sounds like a limitation or bug. Before attempting to do any troubleshooting, I would highly recommend upgrading to the latest 7.8.4 version.
What switch model is this?
BD6808

Image : Extremeware Version 7.8.1.1 [ssh] [wlan] by Release_Master on 05/23/08 10:31:31

BootROM : 8.2
hi drew, now that we ruled out a bug since i am running 7.8.1.1 any other suggestion as far as config change ?
will summery only kill any /32 advertisement ?
configure bgp add aggregate-address 38.96.190.0 255.255.254.0 summary-only
configure bgp add network 38.96.190.143 255.255.255.255 route-map xo-rm
does those negate each other ?
Userlevel 7
I (really) don't know how ExtremeWare was working with BGP. If it was similar to current EXOS, then your aggregate-address would be the only one advertised for all matching routes. You need an active matching route in your RIB for it to work.
can you show an example on the configuration i sent here on top please , want to try anything at this point ,nothing worked so far
thanks
Userlevel 1
Hi joseph,
As stephane mentioned the /32 prefix should be active in route table.
Then only BGP can transmits that prefix to its peer.
Exrtemeware is old version some of us are not familiar with it.
This route map functionality for /32 prefix with community may not be work in your version or
it might be a bug.(As drew mentioned)


Since this query is looping for a while we suggest you to check some older version command reference guide & Concepts guide.
This guides belongs to higher version than extremeware.
You may get a info about your query.


I pasted the link.

https://www.extremenetworks.com/wp-content/uploads/2014/03/EXOSReference_bookmap.pdf

https://www.extremenetworks.com/wp-content/uploads/2014/03/EXOS_Concepts_Guide_15_3_2.pdf

Meanwhile you may paste the entire config I will check.
since it is very older version not sure we can get a solution.
Any we will try to resolve or to have any work around for this issue.

Please attach or paste your version command reference guide.

-Senthil.M
Thank you for the reply I am sure there is something missing in the confirm that prevent it from being sent out I'll paste the whole thing shortly or you prefer me emailing it to you directly

Reply