Header Only - DO NOT REMOVE - Extreme Networks

bpdu-restrict doesn't work (PVST+) on EXOS 16.2.1.6


Userlevel 4
Hello, everybody!

I can't make port to be disabled after it receives BPDU. I've connected the port to C2960 and it is still forwarding regardless it's access or trunk port on cisco.

Please, take a look at my confs:

PORT:

configure stpd V12 ports mode dot1d 3:10
configure stpd V12 ports link-type edge 3:10
configure stpd V12 ports edge-safeguard enable 3:10
configure stpd V12 ports bpdu-restrict enable 3:10

STPD:

* Slot-1 sw-b119-1.87 # sh stpd v12Stpd: V12 Stp: ENABLED Number of Ports: 2
Rapid Root Failover: Disabled
Operational Mode: 802.1W Default Binding Mode: PVST+
802.1Q Tag: 12
Ports: 1:53*,3:10
Participating Vlans: V12
Auto-bind Vlans: V12
Bridge Priority : 32768
Operational Bridge Priority: 32768
BridgeID : 80:00:02:04:96:8b:d5:26
Designated root : 10:00:00:04:96:83:b0:f7
RootPathCost: 1400 Root Port : 1:53
MaxAge : 20s HelloTime : 2s ForwardDelay : 15s
CfgBrMaxAge : 20s CfgBrHelloTime: 2s CfgBrForwardDelay: 15s
Topology Change Time : 35s Hold time : 1s
Topology Change Detected : FALSE Topology Change : FALSE
Number of Topology Changes : 7
Time Since Last Topology Change: 60s
Topology Change initiated locally on Port 1:53
Topology Change last received on Port none from none
Backup Root : Off Backup Root Activated : FALSE
Loop Protect Event Window : 180s Loop Protect Threshold : 3
New Root Trap : On Topology Change Trap : Off
Tx Hold Count : 6
* Slot-1 sw-b119-1.88 #

STPD OUTPUT

* Slot-1 sw-b119-1.89 # show stpd v12 ports 3:10

Port Mode State Cost Flags Priority Port ID Designated Bridge
3:10 802.1D FORWARDING 200000 eDee-w-G-- 128 810a 80:00:02:04:96:8b:d5:26

Total Ports: 1

------------------------- Flags: ----------------------------
1: e=Enable, d=Disable
2: (Port role) R=Root, D=Designated, A=Alternate, B=Backup, M=Master
3: (Config type) b=broadcast, p=point-to-point, e=edge, a=auto
4: (Oper. type) b=broadcast, p=point-to-point, e=edge
5: p=proposing, a=agree
6: (partner mode) d = 802.1d, w = 802.1w, m = mstp
7: i = edgeport inconsistency
8: S = edgeport safe guard active
s = edgeport safe guard configured but inactive
8: G = edgeport safe guard bpdu restrict active in 802.1w and mstp
g = edgeport safe guard bpdu restrict active in 802.1d
9: B = Boundary, I = Internal
10: r = restricted role, t = active role
* Slot-1 sw-b119-1.90 #

Could you please tell me what is wrong? I can provide all additional information required.

Many thanks in advance,

Ilya

1 reply

Userlevel 4
Well, the solution was found. Russian engineers at distributor company investigated:

You should disable/enable to activate bpdu-restrict feature in PVST+/dot1w mode.

It would be rude to share my thoughts now...

The topic could be closed.

Reply