BUG: soft lockup - CPU#1 stuck


Userlevel 1
One X460G2-48t-10G4 switch with 15.6.1.4 took reboot due to below errors:

10/07/2015 05:39:01.88 Booting after System Failure.
10/07/2015 05:39:01.74 Changing to watchdog warm reset mode
10/07/2015 05:38:09.20 CPU 1: soft watchdog expiration warning EPC ffffffff802ade80(r4k_wait+0x20/0x40) at 12 seconds.
10/07/2015 05:38:09.20 CPU 0: soft watchdog expiration warning EPC ffffffff802ade80(r4k_wait+0x20/0x40) at 12 seconds.
10/07/2015 05:38:04.20 CPU 1: soft watchdog expiration warning EPC ffffffff802ade80(r4k_wait+0x20/0x40) at 7 seconds.
10/07/2015 05:38:04.20 CPU 0: soft watchdog expiration warning EPC ffffffff802ade80(r4k_wait+0x20/0x40) at 7 seconds.
10/07/2015 05:37:59.20 CPU 1: soft watchdog expiration warning EPC ffffffff802ade80(r4k_wait+0x20/0x40) at 2 seconds.
10/07/2015 05:37:59.20 CPU 0: soft watchdog expiration warning EPC ffffffff802ade80(r4k_wait+0x20/0x40) at 2 seconds.
10/07/2015 04:42:39.00 CPU 1: Kernel thread was stuck for 10.40 seconds, jiffies: 4420685096
10/07/2015 04:42:38.00 CPU 0: Kernel thread was stuck for 8.93 seconds, jiffies: 4420684996
10/07/2015 04:42:36.10 CPU 0: soft watchdog expiration warning EPC ffffffff802ade80(r4k_wait+0x20/0x40) at 7 seconds.
10/07/2015 04:42:35.73 CPU 1: soft watchdog expiration warning EPC ffffffff802ade80(r4k_wait+0x20/0x40) at 7 seconds.
10/07/2015 04:42:31.10 CPU 0: soft watchdog expiration warning EPC ffffffff802ade80(r4k_wait+0x20/0x40) at 2 seconds.
10/07/2015 04:42:30.63 CPU 1: soft watchdog expiration warning EPC ffffffff802ade80(r4k_wait+0x20/0x40) at 2 seconds.
10/07/2015 04:20:05.05 BUG: soft lockup - CPU#1 stuck for 72s! [swapper:0]
10/07/2015 04:20:05.05 BUG: soft lockup - CPU#0 stuck for 72s! [swapper:0]
10/07/2015 04:20:05.05 BUG: soft lockup - CPU#1 stuck for 171s! [swapper:0]
10/07/2015 04:20:05.01 BUG: soft lockup - CPU#0 stuck for 171s! [swapper:0]
10/07/2015 04:01:03.00 CPU 1: Kernel thread was stuck for 10.34 seconds, jiffies: 4420435496
10/07/2015 04:01:02.00 CPU 0: Kernel thread was stuck for 9.00 seconds, jiffies: 4420435396
--------

Even though the switch is up now but these errors are still reporting. Could you please help me in this regard? This switch is installed a month ago.

4 replies

Userlevel 4
Hi

Please create a GTAC case with below outputs for analyze this issue.

1) show tech

2) show log message nvram

Thanks,
Suresh.B
Userlevel 2
Hi Harkanwaljeet SIngh,
From the platform, logs and version of code looks like we are hitting condition explained in :
https://gtacknowledge.extremenetworks.com/articles/Solution/Stack-of-X460-G2-logs-message-BUG-soft-l...

Can you give a try with recommendation provided in resolution section of the link and see if helps ?

Thanks,
Syed Nishath
Userlevel 6
Hi, all!

I agree.
First of all - you have to try another version EXOS (better upgrade from BootRom), try "run diag ext" and then opening case in TAC.

Thank you!
Userlevel 7
Hi Harkanwaljeet,
Have you been able to upgrade your switch to see if the above information has resolved the issue?

Reply