Cannot ping google from switch.

Userlevel 1
I'm new to networking and new to extreme switches. I just setup x440g2 switch and can ping everything on my network but I cannot ping google. What am I missing.

6 replies

Userlevel 7
Did you configure a route/default gateway ?

#configure iproute add default x.x.x.x
Userlevel 3
Hi Nola,
are you trying to ping from switch or from hosts in your network?
Can you ping any public IP like or

Userlevel 7
Ron wrote:

Did you configure a route/default gateway ?

#configure iproute add default x.x.x.x

Or as Konstantin mentioned if you ping website instead of the IP you'd need to configure the IP of the DNS.
I think you need check some setting in your network :
1. Routing and gateway in your network.
you setting gateway on your switch , you also need check session reply can back to you .
2. DNS setting is correct before you ping FQDN
you need setting name server,and you can get ip-address when you ask FQDN to DNS on your switch before PING FQDN.
3.checking outgoing policy can let your switch ping out .
It's mean you need make sure your company 's out going policy can let your switch's ip-address can pass through with your firewall, IPS....etc.
Userlevel 1
I'm thinking my routing and gateway is ok. I say this because anything device attached to it like a PC or IP phone is working correctly.

DNS setting, are you referring to a DNS setting on the switch or servers for the network. I did not see and switch commands for configuring DNS I will have to go back and check.

For DNS are you saying that I will have to use the command below and enter the name of the DNS server

configure dns-client add name-server

Firewall, I will have to check and see if there is setting on the firewall for switches.
Userlevel 1
I'm thinking its the way I configured the switch. All the other switches seem to be able to ping google. So what am I missing? I have all the switches configured the same way.
Userlevel 1
Any ideas from anyone. Has anyone else experience this problem.