changing slot number in stack

  • 20 February 2015
  • 29 replies
  • 1967 views

On my current working stack, i have 2 x670v and 2x440. I added another 2 x670v to the stack, I want to change the slot numbers of the current 2 x440 to a different stack number. By doing this, will the config also adapt to the change? or would i need to reconfigure it?

Setup is:

x670v <- Slot 1
x670v <- Slot 2
x670v <- Slot 5
x670v <- Slot 6
x440p <- Slot 3
x440p <- Slot 4

What i want:

x670v <- Slot 1
x670v <- Slot 2
x670v <- Slot 3
x670v <- Slot 4
x440p <- Slot 5
x440p <- Slot 6

29 replies

Userlevel 5
You will need to reconfigure for the new slot number
Userlevel 6
Hi!

You need manually configure each slot number (which you want to change), like this:

# configure stacking node-address "xx:xx:xx:xx:xx:xx" slot-number 2
Userlevel 4
Beware thats the you might change youre configuration when you change slot numbers.
Userlevel 6
Beware thats the you might change youre configuration when you change slot numbers.not quite
in this case - probably Master is x670v <- Slot 1, so global configuration will be from Master and not changing, but ports configuration can change, like 4:10
Userlevel 4
Beware thats the you might change youre configuration when you change slot numbers.Thats what I mean.. 🙂
Userlevel 6
Beware thats the you might change youre configuration when you change slot numbers.Then Like for you )))
Thank you for all the replies, now I am encountering issues with my x440s not finding the master node, and getting stuck at pending-AAA, I have checked all possible cause of this bug, but I haven't been successful, I have tried rebuilding the stack numerous times, but it still can't find the master node, even though i can see it in the "show stacking"

any advice on this?
Userlevel 4
firmware version
same partition ---could you check this
master capability enabled or disabled
license ?
Userlevel 6
You can see on front panel Master-node = 1
You can disconnect node on which you want to change stack#, in pending-AAA type REBOOT AS MASTER-CAPABLE, after reboot you can configure this node.
Userlevel 7
Hi,
No information in the logs of the master node?
The x440s are configured as Standby node, not Master-Capable (as you are very likely to have a license mismatch)?
If you have unconfigured the x440s stacking config, have you configured back the enhanced protocol for stacking?
Hi

partition used = secondary
firmware = summitX-15.6.1.4.xos
x440 = master capability not enabled

enabled enhanced protocol.

will attach screenshots
Userlevel 4
Is the partition same on all switches in stack ?
x670v switches have the same partition settings, i think x440 has different partition.



As you can see, slot 3 which is the x440 switch, can be seen in the stack topology but cannot be configured, and is unable to see the master node. causing it to be stuck at AAA
Userlevel 4
Put the x440 in same partition as the x670 switches
This will solve ur problem
Put the x440 in same partition as the x670 switches
This will solve ur problem
if you mean, all on secondary? it is already in it. if not, what do you mean? how do I do this?
Userlevel 4
you might have to load the image again to x440's so that it is loaded to the right partition
then reboot.
You should be able to do this slot by slot.
Userlevel 4
check if you have the below commands
download image image.exos partition slot 3/4
Userlevel 4
Easiest way to upgrade x440 's as standalone to the right partition and add it to stack again
hi,

I have done what you have suggested, and still this persists 😞
Userlevel 4
could you check the license level on all switches.
you can edit stacking license on x440.
could you check the license level on all switches.
you can edit stacking license on x440.
hi parthiban,

this is the current settings:

show stacking configuration
Stack MAC in use:
Node Slot Alternate Alternate
MAC Address Cfg Cur Prio Mgmt IP / Mask Gateway Flags Lic
------------------ --- --- ---- ------------------ --------------- --------- ---
*00:04:96:98:78:25 1 1 Auto CcEe--iNn Aa
00:04:96:98:99:ba 2 2 Auto CcEe--iNn Aa
00:04:96:97:a5:5c 3 3 Auto CcEe--iNn Aa

saw this on the log files:

02/24/2015 16:59:24.42 Slot-2: Slot-3 FAILED (1) License Mismatch
02/24/2015 16:59:24.37 Slot-1: Slot-3 FAILED (1) License Mismatch
02/24/2015 16:59:24.37 Slot-1: Slot-3 has failed for the reason of "License Mismatch".
Userlevel 6
could you check the license level on all switches.
you can edit stacking license on x440.
That's mean - you have License Mismatch 🙂
could you check the license level on all switches.
you can edit stacking license on x440.
yes, i get that, 😛 but i don't get where the license mismatch is, all are of the same setting 😛
Userlevel 4
configure stacking {node-address node-address | slot slot-number} license-level[core | advanced-edge | edge]
Description
Allows you to restrict the license level at which the node operates.

Try this command and reboot the slot

Reply