Cisco IP Phone wrong vlan

Cisco IP Phone refuses to go on the voice vlan.
Data vlan is untagged. Voice vlan is tagged.
LLDP is configured as follows:

configure lldp port 2:33 advertise system-name
configure lldp port 2:33 advertise vendor-specific dot3 mac-phy
configure lldp port 2:33 advertise vendor-specific med capabilities
configure lldp port 2:33 advertise vendor-specific med power-via-mdi
configure lldp port 2:33 advertise vendor-specific med policy application voice vlan BH-Voice dscp 46

This is the same config on all the other ports where the phones work just fine, just this one phone doesn't go on the correct vlan.
I have deleted vlan config on the port and reentered the LLDP config again.
Disabled port and power to the port. Deleted DHCP address. Waited 10 minutes then enabled the port and power. I even tried only having the voice vlan tagged on the port and it didn't work.

Any ideas? Only thing I haven't done yet is reboot the switch.

8 replies

Are you sure that the phones support LLDP? I have a bunch of older Cisco phones 7960 7940 7912 that only support CDP. Have you tried setting the vlan tag manually in the phone settings to rule out the lldp/cdp issue?

press ** # two times in the settings to unlock those settings.
We have a mix of 7941/42 and 7961/62 phones that all work just fine on extreme switches.
Phone in question is a 7941. Another 7941 on the same switch works just fine.
Sounds like you need to factory reset that phone. Sometimes our Avaya phones get stuck and we just need to #craft them 😉.
Userlevel 4
Just wanted to make sure that both phones were tested on the same PORT and one failed and one worked fine or were they tested on the same switch but different ports. If different ports then please check out the config on the port or test the same port to be sure.
It's not the phone. Did factory reset and it upgraded twice and still went on wrong vlan. Took phone to a Cisco switch, got IP on voice vlan. Put phone on another Extreme switch in a different closet and phone gets IP on voice vlan. Take it back to original closet plug in on different port, gets IP on the Data vlan. All the other phones on that closet are on the voice vlan.
I'm going to reboot the switch tonight and see if that fixes it.
If that doesn't work, do a packet capture on that port and look for Avaya option 242 in your DHCP advertisement.
Userlevel 4
One more check would be to run these commands to make sure that vlans are tagged and untagged on the port

sh conf detail | include "vlan Data add ports"
sh conf detail | include "vlan Voice add ports"
one last check
verify lldp on the port is enabled:
enable lldp port (port#)
Restarting the switch stack fixed the issue for this phone and another phone that was on wrong vlan.
Probably a bug in the software would be my guess.