Question

configure SNMPv3

  • 17 June 2019
  • 4 replies
  • 383 views

Hello Team,
I was trying to configure SNMPv3 in vain from v2 which was working fine.

Below are the configs done so far

1.SNMPv3 User
configure snmpv3 add user netadmin authentication md5 Rwa@456t# privacy Rwa@456t#
2.SNMPv3 group
configure snmpv3 add group "v3group" user "netadmin" sec-model usm
3. SNMPv3 Access
configure snmpv3 add access "v3group" sec-model usm sec-level priv read-view "defaultAdminView" write-view "defaultAdminView" notify-view "defaultAdminView
4.SNMPv3 Target Address
configure snmpv3 add target-addr "Observium" param "NetworkTeam" ipaddress 10.150.96.50 transport-port 162 tag-list "TrapSink"
configure snmpv3 add target-addr "observium" param "NetworkTeam" ipaddress 10.150.96.50 transport-port 162 vr "VR-Mgmt" tag-list "TrapSink"

When I go on my SNMP server and try to add my switches I get below error
"No reply on credentials netadmin/authPriv using v3."

Someone help me out please
Appreciate your help,thanks very much

Theogene K.

4 replies

Userlevel 5
Make sure to "enable snmp access snmpv3" and "enable snmp access"
Thanks B-rad
However,they are all enabled

Userlevel 5
Hi Kwihangana,

What version of your SNMP manager are you using? Is that Observium?
There were similar issues with other devices in the past: https://github.com/librenms/librenms/issues/3858

Hope that helps,
Tomasz
Userlevel 2
When you type the user command in please specify the authentication hash and encryption method.
configure snmp3 add user netadmin authentication md5 Rwa@456t# privacy 3des Rwa@456t#

DES is the default on XOS when you don't specify, but your SNMP server may be trying to use triple DES, or even AES. Also double check that your SNMP server is using MD5 and not SHA-1.

Can you double check/post the settings from your SNMP server?

Reply