Header Only - DO NOT REMOVE - Extreme Networks

Configuring Exos Virtual Box


Hi,

I am trying to setup my lab environment, with virtual box 4.3.26. I have uploaded the virtual box extension pacl. I have downloaded the EXOS VM, but when ever I try to import the VM the machine is not being listed in the folder specified.

This is the very first time I am using Virtual Box. Might be some dumb issue.

Had been couple of days that I have googled the issue, but couldn't resolve. Pls. help.

Regards,
Manish

34 replies

@Manish

Can you post the picture? Usually you just import appliance and configure the virtualbox interfaces, do you have vms with .ovf extension?
Userlevel 5
Hi Manish, only Open Virtualization Format or OVF files can be imported as Virtual Machines into Virtualbox. If you've downloaded the VM from https://xkit.extremenetworks.com/app/v/extremexosvm, you'll first have to decompress the file. Once done, you can create a VM in virtualbox using the standard process of creating a virtual machine (Name it and select Next, you can keep all the default settings)



When selecting the Hard drive to use, select the Use an existing virtual hard drive file and browse to the folder you decompressed above. You should be able to see a .vdi file inside.



Once done, you should be able to see the VM listed in your VM list. You can then specify your network/serial port options and start the VM.

All the best
Userlevel 6
Manish, here's an OVA of the latest EXOS VM.
[list=1]

Download it and double-click the .ova file. Virtualbox will import it automagically...

Admin edit: See this article on where to download Virtual EXOS
Manish, here's an OVA of the latest EXOS VM.
[list=1]

Download it and double-click the .ova file. Virtualbox will import it automagically...

Admin edit: See this article on where to download Virtual EXOS
Daniel,

The link you have provided is either expired or wrong. Can you please submit a new one.

Thanks a lot.
Userlevel 6
Manish, here's an OVA of the latest EXOS VM.
[list=1]

Download it and double-click the .ova file. Virtualbox will import it automagically...

Admin edit: See this article on where to download Virtual EXOS
Armen, you can now find the latest EXOS VM in GitHub: https://github.com/extremenetworks/Virtual_EXOS
Userlevel 6
Manish, here's an OVA of the latest EXOS VM.
[list=1]

Download it and double-click the .ova file. Virtualbox will import it automagically...

Admin edit: See this article on where to download Virtual EXOS
Additional context for those that come later:

https://gtacknowledge.extremenetworks.com/articles/Q_A/Where-to-download-the-latest-version-of-ExOS-...
Manish, here's an OVA of the latest EXOS VM.
[list=1]

Download it and double-click the .ova file. Virtualbox will import it automagically...

Admin edit: See this article on where to download Virtual EXOS
Hi Daniel,

May I know, Where can I get the summitX-21.1.2.14-patch1-2.iso?

Thanks
Userlevel 7
Manish, here's an OVA of the latest EXOS VM.
[list=1]

Download it and double-click the .ova file. Virtualbox will import it automagically...

Admin edit: See this article on where to download Virtual EXOS
Hi Gopalakrishnan,
I think maybe you mean
code:
vm-21.1.2.14-patch1-2.iso
? Patch versions of EXOS VM aren't usually posted unless there is a compelling reason to upload them.
Userlevel 6
Manish, here's an OVA of the latest EXOS VM.
[list=1]

Download it and double-click the .ova file. Virtualbox will import it automagically...

Admin edit: See this article on where to download Virtual EXOS
To add to Drew's comment, patch versions for the VM are not usually generated.

A patch version is issued to correct some bug in production code. The VM is a testing tool not meant for production so there's no compelling reason to provide patches to it.
Manish, here's an OVA of the latest EXOS VM.
[list=1]

Download it and double-click the .ova file. Virtualbox will import it automagically...

Admin edit: See this article on where to download Virtual EXOS
Thanks Drew and Daniel.But I need this patch for one of my devstack environment staging. Is there any way to get it ? kindly confirm. Currently I have
code:
vm-21.1.2.14.iso.
Userlevel 6
Manish, here's an OVA of the latest EXOS VM.
[list=1]

Download it and double-click the .ova file. Virtualbox will import it automagically...

Admin edit: See this article on where to download Virtual EXOS
Again, no patch versions are produced for VM images. It just makes no sense...

Since many features don't work in the VM (i.e. VPLS), or work differently (LAG only supports round-robin, which is not available in physical switches), you can't use it to make sure a specific patch solves a certain problem in a specific configuration. You need to use real switches for that.
Manish, here's an OVA of the latest EXOS VM.
[list=1]

Download it and double-click the .ova file. Virtualbox will import it automagically...

Admin edit: See this article on where to download Virtual EXOS
Okay. Thanks Daniel


Hi All,

Thanks for your replies.

@ Tavares Belmont :
Pls. find the PSR attached along, showing the file that got downloaded from https://xkit.extremenetworks.com/app/v/extremexosvm. I tried downloading it twice had the same file size, though till now I didn't check the md5. As I mentioned googled it, followed the procedure but failed to import as nothing was being detected.

@ Kawawa :
I downloaded the file from the link, I compressed the entire file as well as tried just compressing the VM, but post that couldn't find the .vdi file. I tried specifying the .vdi extention, but did't find any such file in the directory.

@ Daniel Flouret :
Many thanks. The link that you shared was very usefull. I am able to create the machine in VB now. I imported it to GNS3 as well. I tried linking it with VB option in GNS3, connected it to a Cisco IOS machine, but after giving the IP not able to ping each other. I read in an article, it has to be imported as QEMU. Is it so?? Also the I started the VM today and it shows its a trial for 30 days. So what happens after 30 days can I use the same after it gets expired doing a fresh installation.

Waiting in anticipation.

Regards,
Manish
Userlevel 6


Hi All,

Thanks for your replies.

@ Tavares Belmont :
Pls. find the PSR attached along, showing the file that got downloaded from https://xkit.extremenetworks.com/app/v/extremexosvm. I tried downloading it twice had the same file size, though till now I didn't check the md5. As I mentioned googled it, followed the procedure but failed to import as nothing was being detected.

@ Kawawa :
I downloaded the file from the link, I compressed the entire file as well as tried just compressing the VM, but post that couldn't find the .vdi file. I tried specifying the .vdi extention, but did't find any such file in the directory.

@ Daniel Flouret :
Many thanks. The link that you shared was very usefull. I am able to create the machine in VB now. I imported it to GNS3 as well. I tried linking it with VB option in GNS3, connected it to a Cisco IOS machine, but after giving the IP not able to ping each other. I read in an article, it has to be imported as QEMU. Is it so?? Also the I started the VM today and it shows its a trial for 30 days. So what happens after 30 days can I use the same after it gets expired doing a fresh installation.

Waiting in anticipation.

Regards,
Manish
The VM has a core license but, for some reason it also had a demo license installed.

Remove the demo licensewith the following command:
debug epm clear trial-license
[/code]After reboot the 30-day message will disappear.
Hi [i]Daniel,

I happen to come across another post of yours in which you have explained about interface.

I gave the loopback interface enable command and was able to ping the the self interface on the EXOS machine. If I can create the lab without importing the machine to GNS3, I am fine with it as well. As i read your post I understand that you create labs in VB. I assume that you might use multiple devices to create a virtual lab. Can you pls. share some documents which would explain how to use VB to connect multiple devices together instead of importing it to GNS 3 (even this would help)

Regards,
Manish
@Manish S

Send me your email, i can share my vm with you. 😉
@ Tavares Belmont :

Have you tried connecting multiple EXOS machines together. My machines have started but I am not able to inter-connect them on GNS3. Earlier I was not able to ping the self IP but post referring to a post-reply by Daniel I started getting replies for self IP. Throwing some light on how to get the devices inter-connected on GNS3 or Oracle VB would be really appreciated.

email ID : manish@algort.co.in

Thanks in advance.

Regards,
Manish
Userlevel 6
Manish,

I've shared this document in other posts but here it goes again. It's a quick and dirty How-To manual detailing installation and interconnection of VMs in VB.
https://www.dropbox.com/s/79bvn8vzinmme70/Installing%20EXOS-VM.pdf?dl=0
Hi Daniel,

I happened to stumble upon the doc couple of hours back. Had a brief go-through, hope I might get some time to work on it tonight.

Many thanks.

Regards,
Manish
Hi Daniel,

I followed the doc with the exact steps, but still I am unable to ping the machines.

I can see the links are active, but cant see any edp info. Have cross checked the configuration of the interfaces. Any guess what could be missing.

1. I had cloned the machine's.
2. Assigned IP on the default vLAN for all three.
3. Enabled ipforwarding
4. Enabled stpd.

I also observed, that the machines have port number 2 blocked in the vLAN they are in.

One more thing the how to increase the buffer window size. The screen of guest window in small. Most of the commands outputs I cannot see, like iparp,fdb I am able to see just the last counters. I also tried changing the screen resolution, as I had similar issue while taking remote session, but it didn't resolve.

Pls. suggest.

Regards,
Manish
Userlevel 6
Manish,

Let's start with your last question. There's no way to modify the console window in VirtualBox. That's why I always configure access through the mgmt vlan.

The first adapter in the VM should always point to a Host-Only adapter. This adapter has a default address of 192.168.56.1 (unless you changed it), so I configure the mgmt port in my switches with addresses in that range (192.168.56.11 for the first switch, 12 for the second, etc.)

Once you have done that you can connect to the VMs using putty or other telnet/ssh emulator (telnet 192.168.56.1X), where you can modify the number of rows, and lines buffered....

Regarding your first problem, please execute the following command in your host machine:
vboxmanage showvminfo
and copy it here so we can take a look at inter-vm connections.
Hi Daniel,

Took some time figuring out how to execute the command in host machine. Some how figured it out.

pls. find the output as requested.

For sw1 :

H:\>cd Program Files\Oracle\VirtualBox

H:\Program Files\Oracle\VirtualBox>vboxmanage showvminfo sw1
Name: sw1
Groups: /
Guest OS: Linux 2.6 / 3.x (32 bit)
UUID: c574df53-bfa7-419e-9bdb-a4ea31f1a97c
Config file: E:\Virtual Box Machines\sw1\sw1.vbox
Snapshot folder: E:\Virtual Box Machines\sw1\Snapshots
Log folder: E:\Virtual Box Machines\sw1\Logs
Hardware UUID: c574df53-bfa7-419e-9bdb-a4ea31f1a97c
Memory size: 256MB
Page Fusion: off
VRAM size: 8MB
CPU exec cap: 100%
HPET: off
Chipset: piix3
Firmware: BIOS
Number of CPUs: 1
PAE: off
Long Mode: on
Synthetic CPU: off
CPUID overrides: None
Boot menu mode: message and menu
Boot Device (1): Floppy
Boot Device (2): DVD
Boot Device (3): HardDisk
Boot Device (4): Not Assigned
ACPI: on
IOAPIC: off
Time offset: 0ms
RTC: UTC
Hardw. virt.ext: on
Nested Paging: on
Large Pages: on
VT-x VPID: on
VT-x unr. exec.: on
State: powered off (since 2015-04-17T12:00:00.000000000)
Monitor count: 1
3D Acceleration: off
2D Video Acceleration: off
Teleporter Enabled: off
Teleporter Port: 0
Teleporter Address:
Teleporter Password:
Tracing Enabled: off
Allow Tracing to Access VM: off
Tracing Configuration:
Autostart Enabled: off
Autostart Delay: 0
Default Frontend:
Storage Controller Name (0): IDE Controller
Storage Controller Type (0): PIIX4
Storage Controller Instance Number (0): 0
Storage Controller Max Port Count (0): 2
Storage Controller Port Count (0): 2
Storage Controller Bootable (0): on
IDE Controller (0, 0): E:\Virtual Box Machines\sw1\EXOS_VM-15.7.1.4-disk1.vmdk (
UUID: dca9d52e-8e3e-48b4-9869-ca2f4b973ece)
IDE Controller (1, 0): Empty
NIC 1: MAC: 000130DF0000, Attachment: Host-only Interface 'VirtualBox
Host-Only Ethernet Adapter', Cable connected: on, Trace: off (file: none), Type:
Am79C973, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: allow-all,
Bandwidth group: none
NIC 2: MAC: 000130DF0000, Attachment: Internal Network 'Link1', Cable
connected: on, Trace: off (file: none), Type: Am79C973, Reported speed: 0 Mbps,
Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 3: MAC: 000130DF0000, Attachment: Internal Network 'Link3', Cable
connected: on, Trace: off (file: none), Type: Am79C973, Reported speed: 0 Mbps,
Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 4: MAC: 000130DF0000, Attachment: Internal Network 'vlab.base-3',
Cable connected: off, Trace: off (file: none), Type: Am79C973, Reported speed: 0
Mbps, Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 5: MAC: 000130DF0000, Attachment: Internal Network 'vlab.base-4',
Cable connected: off, Trace: off (file: none), Type: Am79C973, Reported speed: 0
Mbps, Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 6: MAC: 000130DF0000, Attachment: Internal Network 'vlab.base-5',
Cable connected: off, Trace: off (file: none), Type: Am79C973, Reported speed: 0
Mbps, Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 7: MAC: 000130DF0000, Attachment: Internal Network 'vlab.base-6',
Cable connected: off, Trace: off (file: none), Type: Am79C973, Reported speed: 0
Mbps, Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 8: MAC: 000130DF0000, Attachment: Internal Network 'vlab.base-7',
Cable connected: off, Trace: off (file: none), Type: Am79C973, Reported speed: 0
Mbps, Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
Pointing Device: PS/2 Mouse
Keyboard Device: PS/2 Keyboard
UART 1: I/O base: 0x03f8, IRQ: 4, disconnected
UART 2: disabled
LPT 1: disabled
LPT 2: disabled
Audio: disabled
Clipboard Mode: Bidirectional
Drag'n'drop Mode: disabled
VRDE: disabled
USB: disabled
EHCI: disabled

USB Device Filters:



Bandwidth groups:

Shared folders:

Video capturing: not active
Capture screens: 0
Capture file: E:\Virtual Box Machines\sw1\sw1.webm
Capture dimensions: 1024x768
Capture rate: 512 kbps
Capture FPS: 25

Description:
This is a virtual ExtremeXOS instance running v15.3.2.11.
Guest:

Configured memory balloon size: 0 MB

For sw2 :

H:\Program Files\Oracle\VirtualBox>vboxmanage showvminfo sw2
Name: sw2
Groups: /
Guest OS: Linux 2.6 / 3.x (32 bit)
UUID: 0a94d2e9-e166-4282-88ec-22b6bdb0437b
Config file: E:\Virtual Box Machines\sw2\sw2.vbox
Snapshot folder: E:\Virtual Box Machines\sw2\Snapshots
Log folder: E:\Virtual Box Machines\sw2\Logs
Hardware UUID: 0a94d2e9-e166-4282-88ec-22b6bdb0437b
Memory size: 256MB
Page Fusion: off
VRAM size: 8MB
CPU exec cap: 100%
HPET: off
Chipset: piix3
Firmware: BIOS
Number of CPUs: 1
PAE: off
Long Mode: on
Synthetic CPU: off
CPUID overrides: None
Boot menu mode: message and menu
Boot Device (1): Floppy
Boot Device (2): DVD
Boot Device (3): HardDisk
Boot Device (4): Not Assigned
ACPI: on
IOAPIC: off
Time offset: 0ms
RTC: UTC
Hardw. virt.ext: on
Nested Paging: on
Large Pages: on
VT-x VPID: on
VT-x unr. exec.: on
State: powered off (since 2015-04-17T11:37:46.000000000)
Monitor count: 1
3D Acceleration: off
2D Video Acceleration: off
Teleporter Enabled: off
Teleporter Port: 0
Teleporter Address:
Teleporter Password:
Tracing Enabled: off
Allow Tracing to Access VM: off
Tracing Configuration:
Autostart Enabled: off
Autostart Delay: 0
Default Frontend:
Storage Controller Name (0): IDE Controller
Storage Controller Type (0): PIIX4
Storage Controller Instance Number (0): 0
Storage Controller Max Port Count (0): 2
Storage Controller Port Count (0): 2
Storage Controller Bootable (0): on
IDE Controller (0, 0): E:\Virtual Box Machines\sw2\EXOS-1 Clone-disk1.vmdk (UUID
: bc6791ec-c3bf-4223-a9bd-bda9ebd23b5c)
IDE Controller (1, 0): Empty
NIC 1: MAC: 000130DF0000, Attachment: Host-only Interface 'VirtualBox
Host-Only Ethernet Adapter', Cable connected: on, Trace: off (file: none), Type:
Am79C973, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: allow-all,
Bandwidth group: none
NIC 2: MAC: 000130DF0000, Attachment: Internal Network 'Link2', Cable
connected: on, Trace: off (file: none), Type: Am79C973, Reported speed: 0 Mbps,
Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 3: MAC: 000130DF0000, Attachment: Internal Network 'Link1', Cable
connected: on, Trace: off (file: none), Type: Am79C973, Reported speed: 0 Mbps,
Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 4: MAC: 000130DF0000, Attachment: Internal Network 'vlab.base-3',
Cable connected: off, Trace: off (file: none), Type: Am79C973, Reported speed: 0
Mbps, Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 5: MAC: 000130DF0000, Attachment: Internal Network 'vlab.base-4',
Cable connected: off, Trace: off (file: none), Type: Am79C973, Reported speed: 0
Mbps, Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 6: MAC: 000130DF0000, Attachment: Internal Network 'vlab.base-5',
Cable connected: off, Trace: off (file: none), Type: Am79C973, Reported speed: 0
Mbps, Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 7: MAC: 000130DF0000, Attachment: Internal Network 'vlab.base-6',
Cable connected: off, Trace: off (file: none), Type: Am79C973, Reported speed: 0
Mbps, Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 8: MAC: 000130DF0000, Attachment: Internal Network 'vlab.base-7',
Cable connected: off, Trace: off (file: none), Type: Am79C973, Reported speed: 0
Mbps, Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
Pointing Device: PS/2 Mouse
Keyboard Device: PS/2 Keyboard
UART 1: I/O base: 0x03f8, IRQ: 4, disconnected
UART 2: disabled
LPT 1: disabled
LPT 2: disabled
Audio: disabled
Clipboard Mode: Bidirectional
Drag'n'drop Mode: disabled
VRDE: disabled
USB: disabled
EHCI: disabled

USB Device Filters:



Bandwidth groups:

Shared folders:

Video capturing: not active
Capture screens: 0
Capture file: E:\Virtual Box Machines\sw2\sw2.webm
Capture dimensions: 1024x768
Capture rate: 512 kbps
Capture FPS: 25

Description:
This is a virtual ExtremeXOS instance running v15.3.2.11.
Guest:

Configured memory balloon size: 0 MB

For sw3 :

H:\Program Files\Oracle\VirtualBox>vboxmanage showvminfo sw3
Name: sw3
Groups: /
Guest OS: Linux 2.6 / 3.x (32 bit)
UUID: 4f4648ac-39bf-44bb-ab9f-cedc3ef0432d
Config file: E:\Virtual Box Machines\sw3\sw3.vbox
Snapshot folder: E:\Virtual Box Machines\sw3\Snapshots
Log folder: E:\Virtual Box Machines\sw3\Logs
Hardware UUID: 4f4648ac-39bf-44bb-ab9f-cedc3ef0432d
Memory size: 256MB
Page Fusion: off
VRAM size: 20MB
CPU exec cap: 100%
HPET: off
Chipset: piix3
Firmware: BIOS
Number of CPUs: 1
PAE: off
Long Mode: on
Synthetic CPU: off
CPUID overrides: None
Boot menu mode: message and menu
Boot Device (1): Floppy
Boot Device (2): DVD
Boot Device (3): HardDisk
Boot Device (4): Not Assigned
ACPI: on
IOAPIC: off
Time offset: 0ms
RTC: UTC
Hardw. virt.ext: on
Nested Paging: on
Large Pages: on
VT-x VPID: on
VT-x unr. exec.: on
State: powered off (since 2015-04-17T11:47:08.000000000)
Monitor count: 1
3D Acceleration: off
2D Video Acceleration: off
Teleporter Enabled: off
Teleporter Port: 0
Teleporter Address:
Teleporter Password:
Tracing Enabled: off
Allow Tracing to Access VM: off
Tracing Configuration:
Autostart Enabled: off
Autostart Delay: 0
Default Frontend:
Storage Controller Name (0): IDE Controller
Storage Controller Type (0): PIIX4
Storage Controller Instance Number (0): 0
Storage Controller Max Port Count (0): 2
Storage Controller Port Count (0): 2
Storage Controller Bootable (0): on
IDE Controller (0, 0): E:\Virtual Box Machines\sw3\sw3-disk1.vmdk (UUID: 2c90ea
5-f8c4-4613-acc5-350dca634fd0)
IDE Controller (1, 0): Empty
NIC 1: MAC: 000130DF0000, Attachment: Host-only Interface 'VirtualBox
Host-Only Ethernet Adapter', Cable connected: on, Trace: off (file: none), Type
Am79C973, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: allow-all,
Bandwidth group: none
NIC 2: MAC: 000130DF0000, Attachment: Internal Network 'Link3', Cable
connected: on, Trace: off (file: none), Type: Am79C973, Reported speed: 0 Mbps,
Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 3: MAC: 000130DF0000, Attachment: Internal Network 'Link2', Cable
connected: on, Trace: off (file: none), Type: Am79C973, Reported speed: 0 Mbps,
Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 4: MAC: 000130DF0000, Attachment: Internal Network 'vlab.base-3',
Cable connected: off, Trace: off (file: none), Type: Am79C973, Reported speed:
Mbps, Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 5: MAC: 000130DF0000, Attachment: Internal Network 'vlab.base-4',
Cable connected: off, Trace: off (file: none), Type: Am79C973, Reported speed:
Mbps, Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 6: MAC: 000130DF0000, Attachment: Internal Network 'vlab.base-5',
Cable connected: off, Trace: off (file: none), Type: Am79C973, Reported speed:
Mbps, Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 7: MAC: 000130DF0000, Attachment: Internal Network 'vlab.base-6',
Cable connected: off, Trace: off (file: none), Type: Am79C973, Reported speed:
Mbps, Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
NIC 8: MAC: 000130DF0000, Attachment: Internal Network 'vlab.base-7',
Cable connected: off, Trace: off (file: none), Type: Am79C973, Reported speed:
Mbps, Boot priority: 0, Promisc Policy: allow-all, Bandwidth group: none
Pointing Device: PS/2 Mouse
Keyboard Device: PS/2 Keyboard
UART 1: I/O base: 0x03f8, IRQ: 4, disconnected
UART 2: disabled
LPT 1: disabled
LPT 2: disabled
Audio: disabled
Clipboard Mode: Bidirectional
Drag'n'drop Mode: disabled
VRDE: disabled
USB: disabled
EHCI: disabled

USB Device Filters:



Bandwidth groups:

Shared folders:

Video capturing: not active
Capture screens: 0
Capture file: E:\Virtual Box Machines\sw3\sw3.webm
Capture dimensions: 1024x768
Capture rate: 512 kbps
Capture FPS: 25

Description:
This is a virtual ExtremeXOS instance running v15.3.2.11.
Guest:

Configured memory balloon size: 0 MB

Regards,
Manish
Userlevel 6
Manish,

Sorry for the delay.

All your VMs have the same MAC address.
NIC 1: MAC: 000130DF0000, Attachment: Host-only Interface 'VirtualBox
Host-Only Ethernet Adapter', Cable connected: on, Trace: off (file: none), Type
Am79C973, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: allow-all,
Bandwidth group: none
[/code]
When you clone a VM there's a small message asking if you want to want to reinitialize the MAC address of all network cards. If you don't check it, all your clones will have the same MAC addresses. That's what you did (or, rather, didn't do) so all your VM have the same MAC address. That's what is causing your problems.



Extreme switches have only one MAC per switch, so having the same MAC address for all adapters in a VM is not a problem. But when you connect several VMs and all of them have the same MAC...

Edit every adapter in every VM and modify the MAC Address in the Advanced section. Just press the green symbol to the right and VirtualBox will do that for you.



I always use 000130DF000X, where the X corresponds to the VM (0 for sw0, 1 for sw1, 2 for sw2, etc...) so I can trace the MACs in a traffic capture, but you may use whatever suits you.
Hi Daniel,

Thanks a lot!!!

Mission accomplished..lol. It worked.

Regards,
Manish
Userlevel 6
Good to know!

Can you please mark the question as answered?

Reply