connectivity to a switch (X440)

  • 20 October 2014
  • 10 replies


I have a strange problem and wondered if someone can shed some light on this for me.

We have x440-48p which in-situ and 'working'.

I am trying to allocate a couple of ports to a particular VLan.

When I try to connect directly to the switch using RJ45 and Telnet I cannot gain any access. My system doesn't even show the login screen and I am unable to ping the unit.

However if I connect to one of our other Extreme Devices I can then connect to the problem device using a web browser and can see the basic config details.

When I click on the VLAN configuration it doesn't list any ports being associated with the VLAN.

If I click RELOAD I am presented with the following message:

"There are some unsaved changes in the form. Do you want the form to be updated?"

I click on Yes and the receive the following:

"Do you want to apply the changes to "VLAN NAME" Note: Modification to the IP Addresses will first un-configure the current IP Addresses."

Again I accept the changes.

However, the problem device still doesn't show the ports associated with the VLAN, I have to press RELOAD again and we go around in a loop.

Is this sort of behaviour correct or am I doing something wrong?

Many thanks in advance

10 replies

Userlevel 7

Telnet is enabled by default, so if you can't connect that means:
a) telnet has been disabled (and maybe ssh only is enabled). As you can access by web, which is not default, that's a possibility
b) you are not on the correct vlan / IP subnet (maybe there's no IP at all).

When you say you connect directly to the switch in RJ45, do you mean in the Mgmt port, or an inband port? Are you sure the Mgmt port has an IP address configured, or that the inband port belong to a vlan with an IP configured? Are you, in either case, on the same IP subnet?
Hi Stephane,

On the problem device neither the Mgmt port or any of the normal Inband/RJ45ports will respond. I'm not sure if the Mgmt port has been assigned an IP address as it was configured by someone who did not document anything. I can confirm that I am on the same subnet.

This doesn't happen on any of the other Extreme switches that we have, they all work perfectly well.

At this moment I am slightly more concerned about the apparently 'unstable' configuration which doesn't appear to be saving as we keep getting in to the loop stated above where we have to continually commit and save changes to see the ports associated with a particular VLAN.
Userlevel 6
Good Morning Jason

Is it possible to connect to the serial port of the 440? It would be good to grab some data. At this point we don't know if it is a Web issue or that the switch is unstable.

Hello Paul,

I was hoping you'd turn up on the forum. I was having trouble with the serial port as well but I'll go back to the switch and see if I can download the config.

Is there anything else you require?
Userlevel 6
Hey Jason

At this point lets look at a few commands like show VLAN, show , show management, and show switch.

What type of issue were you getting going into the console? Where you set to 9600 N81 with the cable that comes with it? The console is the one on the bottom and the out of band management is the one on top. I mention this only because I have caught myself plugging into the wrong one several times 🙂 There is something to be said for the DB9 port.

Hi Paul,

The difficulties are more to do with the laptop we use to connect. The serial port connection keeps responding saying the port is in use. I'm just trying to find out what, apart from a built in modem, might be holding the port.

I noticed on the 'Browser View' that there is an option to use the CLI via CLI Proxy. Will I be able to get the details you need via that? If so where can I find CLI Proxy as I cannot locate it on the website.

Thanks mate,

Userlevel 6
Hey Jason

CLI proxy is supposed to be under e-support but I can't find it. Let me know what version you are running and I will get it and post it to dropbox.

Hi Paul,

That'd be great, thanks very much

Current version is
Userlevel 6
Hey Jason

I have posted the archive version here

try it out and let me know if you have any issues. I only saw this version one for 15.4 and one for 15.5 so I am hoping it is correct

Hi Paul,
Apologies for not coming back to you sooner but I have been away from the office for a while.

Many thanks for the CLI Proxy software. I have quickly tried to use this but it doesn;t appear to run. This may be a Java isue as I notice there is a Java folder installed as part of the install however I do
not have Java on my current device. I will sort this out in the next few hours.

In the meantime I will start to obtain the details you requested - namely Show Switch, Show VLAN, Show VLAN Name, Show Management and I will post them here seperately.

Kind Regards,